elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


  Mostrar Mensajes
Páginas: 1 2 3 4 5 6 7 8 9 [10] 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
91  Sistemas Operativos / GNU/Linux / Re: No puedo acceder a wp-admin desde WAN haciendo NAT? en: 6 Noviembre 2019, 14:24 pm
Ya puede solucionarlo. El problema estaba en que, en la raiz no hay dirreccionamiento de url por la cual no afecta tanto entrar con el dominio o por ip privada pero una vez quieres entrar en wp-admin, el wp-admin redirecciona la url a la ip privada auque estes accediendo desde WAN, ya que esta configurado en el panel de wordpress, inserté esto en wp-config en mi caso (/home/wordpress/wp-config.php):

Código:
define('WP_HOME','http://losheredia.ddns.net');
define('WP_SITEURL','http://losheredia.ddns.net');

Con esto le estas diciendo a wordpress que las urls sean de tipo "htttp://losheredia.ddns.net/*". También si tienes phpmyadmin modifica la base de datos de wordpress, tabla wp_options. Mas información en https://kinsta.com/es/base-de-conocimiento/cambiar-wordpress-url/

Ahora si esto está configurado y el NAT esta bien configurado al acceder a http://losheredia.ddns.net:8000 podrás acceder a la web y si se cargan las imagenes significa que tienen acceso al panel de administración de wordpress.

Ahora toca en LAN, ya que si accedemos a 192.168.0.2/wp-admin lo encontrará pero sin formato, así que lo que debemos de hacer es. En el ordenador donde queremos acceder  por LAN a wp-admin/ debemos de modificar el archivo /etc/hosts y insertar esta linea:
Código:
192.168.0.2           losheredia.ddns.net

y en el host del servidor añadir el /etc/hosts:
Código:
127.0.0.1               losheredia.ddns.net

Para acceder desde LAN con esta configuración sería igual a la que si estuvieramos en WAN
http://losheredia.ddns.net/wp-admin

Así puedes acceder tanto en LAN como WAN y trabajar.
92  Sistemas Operativos / GNU/Linux / Re: No puedo acceder a wp-admin desde WAN haciendo NAT? en: 6 Noviembre 2019, 00:46 am
URLs. No hay ninguna URL cuando cargo tu wordpress que apunte a "losheredia.ddns.net:8000". Todas las URLs apuntan a tu IP privada.

Si y me fijé que me da una ip local

Es decir, cuando hago http://losheredia.ddns.net:8000/wp-admin me da http://192.168.0.2:8000/wp-admin haciendo así que no me vaya.
Pero en losheredia.ddns.net:8000 va bien.

93  Sistemas Operativos / GNU/Linux / Re: No puedo acceder a wp-admin desde WAN haciendo NAT? en: 6 Noviembre 2019, 00:37 am
No es error de apache, es error de tu wordpress. Tu servidor me contesta correctamente con la instalación de wordpress pero tu HTML tiene rutas apuntando a tu ip privada. Por lo que significa que tu wordpress está mal configurado.

Es tema de puertos o urls?

Además en el colegio me redirreccionaba a http://192.168.0.2:8000/wp-admin, que es aquello que provoca que me de la ip local y no la wan?
94  Sistemas Operativos / GNU/Linux / No puedo acceder a wp-admin desde WAN haciendo NAT? en: 6 Noviembre 2019, 00:14 am
Hola, al instalar LAMP en mi servidor RPi3, creé tres VirtualHosts en apache2:
  • Para trabajos de HTML/CSS (80)
  • Proyecto personal (puerto 8080)
  • Wordpress (puerto 8000)

configuré el router para que  cuando vaya a mi dominio "losheredia.ddns.net:8000" se redirija al puerto 8000 del server:

Lista de Servidores Virtuales
Nombre          WAN              IP LAN           LAN       Protocolo   Estado   Opciones
....
wordpress   8000   192.168.0.2   8000   TCP           Activado   Modificar/Eliminar


/etc/apache2/sites-enabled/000-default.conf
Código:
<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /home/webserver

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>
<VirtualHost *:8080>
        ServerName GTE
        ServerAdmin webmaster@localhost
        #ServerAlias pruebas2.local
        DocumentRoot /home/gte/
        ErrorLog ${APACHE_LOG_DIR}/error_gte.log
        CustomLog ${APACHE_LOG_DIR}/access_gte.log combined
</VirtualHost>
<VirtualHost *:8000>
        ServerName wordpress
        ServerAdmin webmaster@localhost
        DocumentRoot /home/wordpress/
        ErrorLog ${APACHE_LOG_DIR}/error_wordpress.log
        CustomLog ${APACHE_LOG_DIR}/access_wordpress.log combined
</VirtualHost>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
/etc/apache2/sites-available/000-default.conf
Código:
<VirtualHost *:80>
        # The ServerName directive sets the request scheme, hostname and port that
        # the server uses to identify itself. This is used when creating
        # redirection URLs. In the context of virtual hosts, the ServerName
        # specifies what hostname must appear in the request's Host: header to
        # match this virtual host. For the default virtual host (this file) this
        # value is not decisive as it is used as a last resort host regardless.
        # However, you must set it for any further virtual host explicitly.
        #ServerName www.example.com

        ServerAdmin webmaster@localhost
        DocumentRoot /home/webserver

        # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
        # error, crit, alert, emerg.
        # It is also possible to configure the loglevel for particular
        # modules, e.g.
        #LogLevel info ssl:warn

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        # For most configuration files from conf-available/, which are
        # enabled or disabled at a global level, it is possible to
        # include a line for only one particular virtual host. For example the
        # following line enables the CGI configuration for this host only
        # after it has been globally disabled with "a2disconf".
        #Include conf-available/serve-cgi-bin.conf
</VirtualHost>
<VirtualHost *:8080>
        ServerName GTE
        ServerAdmin webmaster@localhost
        #ServerAlias pruebas2.local
        DocumentRoot /home/gte/
        ErrorLog ${APACHE_LOG_DIR}/error_gte.log
        CustomLog ${APACHE_LOG_DIR}/access_gte.log combined
</VirtualHost>
<VirtualHost *:8000>
        ServerName wordpress
        ServerAdmin webmaster@localhost
        DocumentRoot /home/wordpress/
        ErrorLog ${APACHE_LOG_DIR}/error_wordpress.log
        CustomLog ${APACHE_LOG_DIR}/access_wordpress.log combined
</VirtualHost>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

y toda la configuración de wordpress esta bién (esta instalada en /home/wordpress/), en LAN va todo bien, pero al acceder desde el exterior (WAN) e inserto en el navegador "losheredia.ddns.net:8000" me accede a la página que estoy creando pero si accedo a "losheredia.ddns.net:8000/wp-admin" se queda cargando...

También pasa que me devuelve la ip local (http://192.168.0.2:8000) al hacer http://losheredia.ddns.net:8000


Temo que es alguna problematica de puertos. Mi pregunta es, ¿porque al acceder al losheredia.ddns.net:8000 puedo acceder pero al losheredia.ddns.net:8000/wp-admin no puedo?
95  Sistemas Operativos / GNU/Linux / Re: Porque mi GNOME desktop en Debian no se vé? El login si se muestra. en: 1 Noviembre 2019, 01:01 am

Este problema se debe a NetworkManager -

Añadiendo un nuevo archivo.conf al directorio /etc/NetworkManager/conf.d/ en este manual le voy a llamar mi_red.conf introducimos el mismo código:
Código:
[device]
wifi.scan-rand-mac-address=no

[connection]
ethernet.cloned-mac-address=permanent
wifi.cloned-mac-address=permanent

Luego guardamos el archivo y, dentro de la consola de comando, reiniciamos NetworkManager usando el siguiente comando:

Código:
systemctl restart NetworkManager




Vale, ya entiendo el error debe ser alguna inacompatibilidad sobre la tarjeta de wifi + LAN y tarjeta NVIDIA integrada. Hice lo que me diciste. Añadí el archivo /etc/NetworkManager/conf.d/wlan.conf y allí inserte las lineas de configuración, i reinicié el servicio y pc.

Ahora, con esta solución unicamente un mensaje de error, no dos.

Es decir, antes de hacer lo que me dijiste me salía estos dos errores:

Código:
[     10.974097] rt10192ee: Polling FW ready fail!! REG_MCVFWOL:0x00000304. count = 3001
[     12.065251] rt10192ee: Polling FW ready fail!! REG_MCVFWOL:0x00000306. count = 3001

ahora solo sale uno, este.
Código:
[     11.160769] rt18192ee: Polling FW ready fail!! REG_MCUFWDL:0x00000306. count = 3001

Me gustaría saber que hice para en el archivo nuevo que creé y que significa cada uno, donde lo puedo ver? Es para ver si puedo configurar algo para que no aparezca ese mensaje.


P.D: Todavía sale este mensaje al principio del todo:
[     1.492033] Spectre V2 : Spectre mitigation: LFENCE not serializing, switching to generic retpoline
96  Sistemas Operativos / GNU/Linux / Re: Porque mi GNOME desktop en Debian no se vé? El login si se muestra. en: 27 Octubre 2019, 20:06 pm
Una consulta.... cuantas particiones hiciste?
Me parece que te comiste un paso en la instalacion

reformulo mi pregunta, que microprosesador tenes y que kernel tenes.?


El microprocessador es AMD Sempron (tm) LE-1250, con la kenel
Código:
Linux debian-10 4.19.0-6-686-pae #1 SMP Debian 4.19.67-2+deb10u1 (2019-09-20) i686 GNU/Linux
.

Yo cuando instslé el SO lo di a que se instale en todo el disco y predeterminadamente tiene el swap y la carpeta root. Pero me dio a elegir si queria instalar las requerimientos basicos, y le di que no. Eso pudo afectar?
97  Sistemas Operativos / GNU/Linux / Porque mi GNOME desktop en Debian no se vé? El login si se muestra. en: 27 Octubre 2019, 15:20 pm
Hola.

Quise montar mi propio ordenador, con una torre vieja que tenía. Me compré 4 modulos de DIMM DDR2 800MHZ 4GB, una tarjeta de red inalambrica tp-link 300Mbps PCI Express Adapter TL-WN881ND y un ssd  crucial MX500 de 1TB

Los componentes estan instalados en una placa madre ASOCK ALiveNF6G-GLAN (https://www.asrock.com/mb/nvidia/alivenf6g-glan/ ), con una fuente de alimentación PC CASE 460 PC con modelo LPK12-30P4E

Le instalé el SO Debian 10.1. Al arrancar salen estos mensajes:

Despues del arranque que da la opción de acceder a la BIOS o Boot Menu sale correctamente el GNU GRUB de Debian version 2.02+dfsg1-20 y al seleccionar la entrada de Debian sale una pantalla de error, que mas tarde desaparece:
Código:
[     1.492033] Spectre V2 : Spectre mitigation: LFENCE not serializing, switching to generic retpoline

Después desaparece y sale los mensajes típicos de arranque de linux, pero acaba con el siguiente mensaje:
Código:
[     10.974097] rt10192ee: Polling FW ready fail!! REG_MCVFWOL:0x00000304. count = 3001
[     12.065251] rt10192ee: Polling FW ready fail!! REG_MCVFWOL:0x00000306. count = 3001

Finalmente sale el login de Debian, inicio session y la mayoría de veces sale esto (a veces sale, ya aveces no):
https://drive.google.com/file/d/11YWqsiRsFPPhhUphisZ-TCVcxBoX9Wt8/view?usp=sharing [img]

Además cuando accedo al tty y miro el log /var/log/messages me sale esto:
https://drive.google.com/file/d/1acgHBs5-C3KU_WeqUh5zL9Nz_LglVCPa/view?usp=sharing [img]

Porque no se me vé el desktop? Que puedo hacer? desinstalé e instalé el GNOME y me hace lo mismo

Enlaces:
 https://www.amazon.es/dp/B073ZC52BJ?ref=ppx_pop_mob_ap_share (DIMM DDR2 800MHz)
 https://www.amazon.es/dp/B078211KBB/ref=cm_sw_r_wa_apap_8VduPt4x5q9dd (SSD 1TB)
 https://www.amazon.es/dp/B006BSPTAQ/ref=cm_sw_r_wa_apap_kC5fw2TcNN611 (tarjeta wifi)

P.D: Cuando tengo todos los componentes, los nuevos y la tarjeta de red LAN de dos puertos, no se vé la interfaz gráfica y cuando se la quito, se inicia bién, ahora mismo el P.D lo estoy escribiendo desde la PC de torre y va bastante bien.

Es recomendable que me cambié de fuente de alimentación ya que he presenciado antes de escribir esta pregunta, reinicio del sistema y que se "colgaba" y por la RAM no puede ser.

Además presiento que va un poco más lenta, no mucho. Me recomendais comprar otro microprocesador AMD?

Auque si tengo el SSD y la RAM DIMM DDR2, y el procesador o la fuente, son viejas, puedes dar dificultades?
98  Sistemas Operativos / GNU/Linux / Re: ¿Como cerrar session de un usuario ssh remotamente desde la shell con auth.log? en: 22 Octubre 2019, 12:57 pm
Para cerrar sessión de un usuario en especifico, es con este comando:
Código:
ps -ef | grep sshd | grep nombre_usuario
Al ejecutar el comando te saldran varias sessiones o una, de ese usuario, por la cual debes de saber en que tty está (ps/1,ps/0...) y con ello matar el proceso
Código:
pkill -9 -t pts/0

Código:
root@servheredia:/home/administrador# ps -ef | grep sshd | grep administrador
root      2805   464  0 23:38 ?        00:00:00 sshd: administrador [priv]
adminis+  2833  2805  0 23:38 ?        00:00:00 sshd: administrador@pts/0
root      2850   464  0 23:38 ?        00:00:00 sshd: administrador [priv]
adminis+  2863  2850  0 23:38 ?        00:00:00 sshd: administrador@pts/1

Si quiero matar el 3 proceso, haría
Código:
pkill -9 -t pts/0

Y con ello cerraría la session del usuario remotamente conectado.

NOTA: El comando se debe de ejecutar desde el servidor ssh, no desde el cliente ni otro.

FUENTE: https://alquimistadesistemas.com/matar-todas-las-sesiones-activas-de-ssh-de-un-usuario.html
99  Sistemas Operativos / GNU/Linux / ¿Como cerrar session de un usuario ssh remotamente desde la shell con auth.log? en: 20 Octubre 2019, 23:44 pm
¿Como cerrar session de un usuario ssh remotamente desde la shell con la info que me da el archivo log, auth.log?

Con la info que me dan estas lineas?

Código:
Oct 20 22:34:23 servheredia su: pam_unix(su:session): session opened for user root by administrador(uid=0)
Código:
Oct 20 22:21:36 servheredia sshd[3883]: Accepted password for administrador from 192.168.0.3 port 55592 ssh2

Gracias
100  Sistemas Operativos / GNU/Linux / Re: Fallo temporal en la resolución del nombre en: 20 Octubre 2019, 23:40 pm
Lo más probable es que haya una regla de firewall que bloque DNS.

Es verdad, fue porque el puerto 53 estaba bloqueado, gracias. Un despiste.
Páginas: 1 2 3 4 5 6 7 8 9 [10] 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines