elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recuerda que debes registrarte en el foro para poder participar (preguntar y responder)


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación C/C++ (Moderadores: Eternal Idol, Littlehorse, K-YreX)
| | |-+  Problema en DevC++, compila pero no se ejecuta.
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema en DevC++, compila pero no se ejecuta.  (Leído 28,829 veces)
jairogon

Desconectado Desconectado

Mensajes: 24


Ver Perfil
Problema en DevC++, compila pero no se ejecuta.
« en: 5 Julio 2010, 03:28 am »

Este programa se compila bien en DevC pero no se ejecuta, en cambio en Borland cambiando las cabeceras funciona perfecto, NO se por que?????
Código:

//Programa que imprime asteriscos
#include<iostream>
#include<cstdlib>

using namespace std;

int main()
{
  system("cls");

  int i=0;
   while(i++<=20)
   {
 for(int k=0;k<i;k++)
 {
for(int j=0;j<i;j++)
{
cout<<"*";
}
cout<<"\n";
 }
 cout<<"\n\n\n";
   }
   cin.get();
   return 0;
}


« Última modificación: 5 Julio 2010, 03:33 am por Littlehorse » En línea

Littlehorse
All the world's a stage
Moderador
***
Desconectado Desconectado

Mensajes: 2.714


Nie Dam Sie


Ver Perfil WWW
Re: Compila bien y no corre
« Respuesta #1 en: 5 Julio 2010, 03:32 am »

jairogon, utiliza títulos descriptivos para los post. Ya es el segundo post que pones con el mismo titulo.

En cuanto al código, no veo porque no debería de ejecutarse. Cual es el error cuando lo intentas ejecutar?. Ten en cuenta que Borland es un IDE obsoleto.

Saludos


En línea

An expert is a man who has made all the mistakes which can be made, in a very narrow field.
jairogon

Desconectado Desconectado

Mensajes: 24


Ver Perfil
Re: Compila bien y no corre
« Respuesta #2 en: 5 Julio 2010, 04:03 am »

jairogon, utiliza títulos descriptivos para los post. Ya es el segundo post que pones con el mismo titulo.

En cuanto al código, no veo porque no debería de ejecutarse. Cual es el error cuando lo intentas ejecutar?. Ten en cuenta que Borland es un IDE obsoleto.

Saludos


Dice "Archivo Fuente No compilado"
En línea

Mr.Blue


Desconectado Desconectado

Mensajes: 441



Ver Perfil WWW
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #3 en: 5 Julio 2010, 04:20 am »

Te falto decir que compliador es, le pusiste que compile, lo quisistes ejecutar directo?


Edit: No leei bien.
Emm
yo recien lo compile en dev-c++, y funciona bien, Compila y ejecuta.
« Última modificación: 5 Julio 2010, 18:27 pm por Sr.Blanco » En línea

misterharry

Desconectado Desconectado

Mensajes: 12


Ver Perfil
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #4 en: 6 Julio 2010, 04:52 am »

DevC esta lleno de bugs...
te recomiendo usar codeblocks que esta disponoble tanto para win como linux
y su proyecto aun esta en marcha :D en mayo sacaron la ultima version

http://www.codeblocks.org/downloads/26
En línea

androidsc3

Desconectado Desconectado

Mensajes: 29


El conocimiento te hace libre


Ver Perfil
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #5 en: 6 Julio 2010, 05:21 am »

Que windows tienes yo hace tiempo me salia el mismo error con windows vista  :P
En línea

rub'n


Desconectado Desconectado

Mensajes: 1.125


(e -> λ("live now")); tatuar -> λ("α");


Ver Perfil WWW
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #6 en: 6 Julio 2010, 07:21 am »

y mi me paso igual   con mucho codigos ,,,

( reinstalalo OSEA EL DEV-C++ )  ,,,eso  me soluciono ese problema  igual al tuyo ,,,,

cuando le daba ctrl f9 compilaba ,,,pero al darle ctrl f10  para ejecutar decia codigo fuento no compilado

« Última modificación: 6 Julio 2010, 07:23 am por pran » En línea



rubn0x52.com KNOWLEDGE  SHOULD BE FREE!!!
If you don't have time to read, you don't have the time (or the tools) to write, Simple as that. Stephen King.
@synthesize
Wiki

Desconectado Desconectado

Mensajes: 639


Another Brick in the Wall


Ver Perfil WWW
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #7 en: 6 Julio 2010, 08:21 am »

Como ya os han dicho, no usar compiladores como borland, y a ser posible, usar code::blocks antes devC.
En línea

bizco


Desconectado Desconectado

Mensajes: 698


Ver Perfil
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #8 en: 6 Julio 2010, 15:47 pm »

aparte de todo, yo creo que solo han instalado el ide, les falta el compilador.
En línea

codeliber

Desconectado Desconectado

Mensajes: 35



Ver Perfil
Re: Problema en DevC++, compila pero no se ejecuta.
« Respuesta #9 en: 11 Julio 2010, 21:32 pm »

Ha salido una "remake" del DevC++, es de este año 2010.

http://wxdsgn.sourceforge.net/

Segun el codigo que desarrolles, igual te hace falta poner algo de estas librerias:
../../Dev-Cpp/lib/libcomctl32.a
../../Dev-Cpp/lib/libgdi32.a
../../Dev-Cpp/lib/libcomdlg32.a

(se ponen en: Project Option -> Addicional command line Optio....)

 ;D

En línea

No quiero ser un pez, por eso necesito que me enseñes a pescar. :)
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines