elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Los 10 CVE más críticos (peligrosos) de 2020


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación C/C++ (Moderadores: Eternal Idol, Littlehorse, K-YreX)
| | |-+  Compila pero no se ejecuta! Ayuda por favor.
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Compila pero no se ejecuta! Ayuda por favor.  (Leído 2,582 veces)
durindemoria

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Compila pero no se ejecuta! Ayuda por favor.
« en: 5 Diciembre 2015, 22:18 pm »

Buenas a todos.

Mi problema es el siguiente, estoy realizando un codigo en C++ para consola, y cuando lo compila no tiene problemas, pero cuando lo voy a ejecutar se abre la consola y no muestra nada, queda en negro.
Lo que quier aclarar es lo siguiente... NO ES PROBLEMA DEL CODIGO, el codigo esta bien, digo ya postie en otros lados y me pidieron el codigo.
Estuve intentando en Visual Studio 2013, QtCreator y NetBeans 8.0.2, siempre da el mismo resultado, la consola en negro.
Tambien me di cuenta que codigos que escribi anteriormente, digamos meses atras, si los ejecuta, muestra en consola todo y esta no da ningun error, por ende SOLO PASA CON LOS PROYECTOS NUEVOS.
Uso Windows 7 64 bits , no se si interesa, pero lo pongo por las dudas.

Si alguien me pudiera ayudar, desde ya muchas gracias.

Edit

Me olvide de decir, cuando intento hacer correr el programa, la consola no se cierra con nada, ni con alt+ctrl, ni con la X, ni con el administrador de tareas, algunas veces si, pero la mayoria de la veces no, y ademas la IDE donde estoy haciendo se traba, queda corriendo el programa y no lo detiene y no puedo hacer nada solo cerrar y volver a abrir.

CODIGO:
Código:
#include <stdio.h>
#include <iostream>

using namespace std;

int main()
{

cout << "HOLA  MUNDO" << endl;
cin.ignore();
return 0;

}


« Última modificación: 5 Diciembre 2015, 23:08 pm por durindemoria » En línea

engel lex
Moderador Global
***
Desconectado Desconectado

Mensajes: 15.514



Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #1 en: 5 Diciembre 2015, 22:31 pm »

de todas formas pon el código y si el compilador te da mensajes al momento de la compilación tambien


En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
class_OpenGL


Desconectado Desconectado

Mensajes: 437

Si usas Direct3D, no eres mi amigo :P


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #2 en: 6 Diciembre 2015, 10:10 am »

Prueba a desactivar el antivirus. Lo que pasa es que este analiza tu programa por si fuera un virus. Al menos eso me pasaba a mí :D
En línea

Programador aficionado. Me quiero centrar en programar videojuegos. La API que uso para crearlos es OpenGL
durindemoria

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #3 en: 7 Diciembre 2015, 01:45 am »

Prueba a desactivar el antivirus. Lo que pasa es que este analiza tu programa por si fuera un virus. Al menos eso me pasaba a mí :D

Muchas gracias!!! Funciono! Estuve toda la semana tratando de averiguar que era.  ;-)
En línea

DarK_FirefoX


Desconectado Desconectado

Mensajes: 1.256


Be the change you wanna see in te world


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #4 en: 9 Diciembre 2015, 16:12 pm »

Prueba a desactivar el antivirus. Lo que pasa es que este analiza tu programa por si fuera un virus. Al menos eso me pasaba a mí :D

Alguien puede decir ¿por que? O esto fue una respuesta tipo vidente :silbar:

Pues el compañero @durindemoria no ofrece ninguna información acerca del antivirus. Y de acuerdo al código que pone, no debería dar problemas con el anti-virus. Además no dice que los proyectos antiguos si los corre?

 :¬¬

Salu2s
En línea

class_OpenGL


Desconectado Desconectado

Mensajes: 437

Si usas Direct3D, no eres mi amigo :P


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #5 en: 9 Diciembre 2015, 21:04 pm »

Jajaja. Es cierto que es un razonamiento un tanto alocado. He pensado eso tan rápido porque "recientemente" hubo un tema similar :D Entonces, para ir descartando, dije esa solución
En línea

Programador aficionado. Me quiero centrar en programar videojuegos. La API que uso para crearlos es OpenGL
DarK_FirefoX


Desconectado Desconectado

Mensajes: 1.256


Be the change you wanna see in te world


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #6 en: 9 Diciembre 2015, 22:42 pm »

Jajaja. Es cierto que es un razonamiento un tanto alocado. He pensado eso tan rápido porque "recientemente" hubo un tema similar :D Entonces, para ir descartando, dije esa solución

Ya esta! Bueno, ya sabemos que es lo que pasa. Estaría bien saber ¿Por qué?
Al menos a mi me pica la curiosidad

Salu2s
En línea

class_OpenGL


Desconectado Desconectado

Mensajes: 437

Si usas Direct3D, no eres mi amigo :P


Ver Perfil
Re: Compila pero no se ejecuta! Ayuda por favor.
« Respuesta #7 en: 9 Diciembre 2015, 23:42 pm »

Esto siempre me ha pasado con el compilador de MinGW (solamente he probado este y el que usa Visual Studio 2013 - 2015). Lo más seguro sea que MinGW hace código máquina que se parece a algún tipo de virus conocido y por ello tiene que analizarlo bien.
Digo que se analiza pues pasado un rato, Avast (el antivirus que yo usaba) dejaba ejecutarse a la aplicación.
No se me ocurre otra cosa XD
En línea

Programador aficionado. Me quiero centrar en programar videojuegos. La API que uso para crearlos es OpenGL
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Compila bien, pero no ejecuta !! Solucionado
Java
Vingilot 4 3,390 Último mensaje 8 Enero 2008, 15:20 pm
por Vingilot
Como se compila y ejecuta un programa java en linux
Java
Dem0ny 2 8,716 Último mensaje 27 Noviembre 2008, 22:24 pm
por Amerikano|Cls
Problema en DevC++, compila pero no se ejecuta.
Programación C/C++
jairogon 9 30,450 Último mensaje 11 Julio 2010, 21:32 pm
por codeliber
compila y ejecuta bien, pero me muestra un caracter raro
Programación C/C++
pedroarcego 7 3,146 Último mensaje 7 Septiembre 2010, 11:28 am
por Garfield07
Ejercicio compila pero no se ejecuta « 1 2 »
Programación C/C++
David8 15 6,613 Último mensaje 20 Abril 2014, 22:47 pm
por David8
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines