elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Sigue las noticias más importantes de seguridad informática en el ttwitter! de elhacker.NET


  Mostrar Temas
Páginas: 1 2 3 [4] 5 6 7
31  Programación / Desarrollo Web / Problema con jquery y safari en: 3 Febrero 2016, 16:07 pm
Hola a todos,  tengo el siguiente problema estoy haciendo una matriz donde cargo una imagen,  que me proviene de un modal de bootstrap. El problema se me está presentado en un la Tablet de Mac que utiliza safari como navegador. Este código lo estoy ejecutando en una Tablet Android con Chrome y sin problema al igual que en una pc con Windows que tengo instalado la versión de safari para Windows y también se me ejecuta bien. Aquí les dejo el código para ver si me pueden ayudar.

Saludos

Código  jquery
Código:
//Actiavamos el modo de edición.
$(".edicion").click(function(){
cl = $(this).attr('class');
pos = cl.indexOf("span-imagenedion");
if(pos < 0){
$(this).removeClass("span-imagenedioff").addClass("span-imagenedion");
$('div.imgmosa').each(function(){
$(this).removeClass("span-imagenlim").addClass('span-imagenmas');
});
}else{
$(this).removeClass("span-imagenedion").addClass("span-imagenedioff");
$('div.imgmosa').each(function(){
$(this).removeClass("span-imagenmas").addClass('span-imagenlim');
});
}

});

//Cargasmos el modal con la lista de tipo del producto.
$("div.span-imagenmas").live('click',function(){
id = $(this).attr('id');
$("#divid").val(id);
     $.post('index.php?c=movimiento&f=tipolistmodal',function(data){
$("#tab-prod").html(data.tabla);
$("#myModal3").modal();
},'json');

});
Código HTML
Código:
  <div class="row show-grid">
  <div class="span1 imgmosa" id="div1"></div>
  <div class="span1 imgmosa" id="div2"></div>
  <div class="span1 imgmosa" id="div3"></div>
  <div class="span1 imgmosa" id="div4"></div>
  <div class="span1 imgmosa" id="div5"></div>
  <div class="span1 imgmosa" id="div6"></div>
  <div class="span1 edicion"></div>
  </div> 
32  Programación / Desarrollo Web / Problema con evento de Jquery en: 24 Enero 2016, 21:12 pm
Hola a todos tengo el siguiente problema. Estoy creando una tabla desde php la cual la imprimo con un echo para cargar eso datos al html con jquery en una de sus celda (td) quiero programar un evento de clic de Jquery el cual no se me está ejecutando a continuación le dejo el código.

Saludos

PHP

Código:
$table_prod =  '<table class="table">
  <thead>';
  $table_prod .= '<tr>';
  $table_prod .= '<th>Código</th>';
  $table_prod .= '<th>Descripción</th>';
  $table_prod .= '<th>Precio/cantidad</th>';
  $table_prod .='</tr>';  
  $table_prod .='</thead>';
  $table_prod .= '<tbody>';
  if(count($datos_prod) > 0){
  foreach($datos_prod  as $value){
  $table_prod .= '<tr>';
  $table_prod .= '<td>'. $value['codigo'].'</td>';
  $table_prod .= '<td>'. $value['descripcion'].'</td>';
  $table_prod .= '<td  style="text-align: center;"><a id="prod_transf"   href="#" title="Clic para transferir"><span class="label label-success">'.$value['precio1'].'<br />'.$value['cantidad'].'</span></a></td>';
  $table_prod .='</tr>';
  }
  }else{
  $table_prod .= '<tr>';
  $table_prod .= '<td colspan="3"><span class="label label-important">No tiene datos a mostrar</span></td>';
  $table_prod .='</tr>';
}
$table_prod .='</tbody>
      </table>';
echo $table_prod;

Jquery

Código:
$('#prod_transf').click(function(){
alert("OK");
/*document.getElementById('player').play();
    playing = true;*/
});
33  Programación / PHP / Problema con el Buffer de memoria de php. en: 6 Diciembre 2015, 19:05 pm
Hola  todos:

 Tengo el siguiente problema. Estoy leyendo un fichero que de Excel que tiene 5 columnas y 500 registro con las clases PHPExcel. Lo que me está sucediendo es lo siguiente que cuando termino de leer el fichero y guardarlo en una base de datos se me vacían todas las variables que tengo cuando veo el uso de la memoria me aumenta de 6861680  a 12813440  lo cual no me deja hacer más ningún proceso. Existe alguna forma en que yo pueda forzar que la memoria se me vacié para hacer el siguiente proceso provee con ob_clean pero si me mantiene casi igual.

Saludos.
34  Programación / Desarrollo Web / Problema con Datepicker en: 20 Noviembre 2015, 23:19 pm
Hola a todos:

 Tengo el siguiente problema, estoy usando un datepicker el cual cuando tengo alguna fecha en el input no me respeta el mes que tiene la fecha sino que me aparece con la del día en curso. Este datepicker está hecho para bootstrap y tengo colocado en mi proyecto el bootstrap 2.3.2.

Saludos
35  Programación / Bases de Datos / Importar CSV a Mysql con Phpmyadmin. en: 24 Septiembre 2015, 17:23 pm
Hola a todos:

 Estoy importando un fichero CSV separado por comas que tengo a mysql pero tengo el siguiente problema.  Si la columna tiene alguna palabra acentuada no me inserta el valor del campo para ese registro. Tengo definido en mi Base de datos UTF-8 al igual que los campos de mi tabla.

Saludos
36  Programación / Desarrollo Web / [Resuelto] Insertar fichero .skp en html 5 en: 3 Septiembre 2015, 17:47 pm
Hola a todos,  tengo el siguiente problema.  Tengo un fichero hecho en Skechup y quiero montarlo en una página que tengo creada con html 5 css3.  Si alguien me pudiera ayudar.

Saludos
37  Programación / Desarrollo Web / Worpress woocome exportar CSV en: 23 Agosto 2015, 20:42 pm
Hola a todos:
Tengo una tienda virtual en worpress con woocome y quisiera que cuando el usuario procese su pedido,  me genere un csv con ese pedido que se acaba de realizar.  Hora lo tengo hecho de forma tal que el usuario tenga que iniciar sesión para poder descargar el csv.
Saludos
38  Programación / Scripting / problema con la compilación con cx_Freeze en: 8 Agosto 2015, 00:15 am
Hola todos,  estoy compilando un programa que cree en Python 3.4 para obtener el número de serie del disco duro de la máquina. Cuando lo ejecuto a través del script desde la consola, se me ejecuta bien y me da el resultado que necesito pero cuando ejecuto el (.exe) que me crea después de la compilación me da  el siguiente error.



Este es el código

Código
  1. #Importamos la libreria OS para el trabajo de directory.
  2. import sys
  3. import os
  4. #Obtenemos el número de serie del HDD.
  5. def get_serial_number(volume=None):
  6.  
  7.    data = os.popen('vol '+'c:', 'r').read()
  8.    data = data.split()
  9.    cadena = str(data[len(data)-1:])
  10.    return cadena.replace("['", "").replace("']", "").replace("-", "")
  11.  
  12. #Creamos el fichero y directory con el # de serie.
  13. def grabartxt(serie_numero):
  14.  
  15.    #Cremos el directory si no existe.
  16.    directoryPath = 'C:/Altus'
  17.    if not os.path.exists(directoryPath):
  18.        os.mkdir(directoryPath)
  19.  
  20.    #Escribimos el Fechero.
  21.    directoryFile = directoryPath+"/Altus.txt"
  22.    if not os.path.isfile(directoryFile):
  23.        archi=open(directoryFile,'a')
  24.        archi.write(str(serie_numero))
  25.        archi.close()
  26.  
  27. grabartxt(get_serial_number())
  28. #print(get_serial_number())
  29.  
  30.  
39  Programación / Desarrollo Web / Estilos CSS en: 24 Junio 2015, 21:34 pm
Hola a todos: tengo el siguiente problema estoy haciendo una degradación en una plantilla que estoy usando con CSS3 y bootstrap. El degradado lo estoy haciendo  de abajo hacia arriba y en  los monitores cuando lo muestro me deja una línea en blanco en la parte inferior les dejo el código del body. Si alguien me pudiera ayudar.

Saludos

Código:
      body {
        padding-top: 40px;
        padding-bottom: 40px;
      background: linear-gradient(#23afe6, #fbb9f5);
        background-repeat: no-repeat;
      }

40  Programación / Bases de Datos / Problema de inserat acentos en mysql en: 23 Junio 2015, 17:13 pm
Hola a todos:

Estoy tratando de insertar una cadena  de texto que estoy leyendo de un fichero de exel con php, la cual contiene acentos.  El campo donde estoy insertando los datos es un campo Text de longitud 0 para que sea ilimitado ya que la cadena puede variar su longitud, el  character set de la tabla es UTF-8 con la colletion general.

Lo que me está sucediendo que cuando hago el insert de los datos, la cadena de texto  se me corta, al primer acento que aparece. Quedando incompleta en el campo de la base de datos. 

Cambie el tipo de character set a latin1 y problema me persiste, también ice un debug y en la variable donde se almacenan los datos,  para el insert no está cortada ni tiene caracteres raro.

Saludos
Páginas: 1 2 3 [4] 5 6 7
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines