elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


  Mostrar Temas
Páginas: 1 2 3 4 5 [6]
51  Programación / .NET (C#, VB.NET, ASP) / Obtener valores de un DataGridView [SOLUCIONADO] en: 19 Marzo 2010, 12:50 pm
Hola!
He implementado este evento CellContentClick para que cuando se haga click sobre una fila de un objeto DatagridView se rellenen con los datos de dicha fila unos TextBox del mismo formulario:

Código:
Private Sub DataGridView1_CellContentClick(ByVal sender As System.Object, ByVal e As System.Windows.Forms.DataGridViewCellEventArgs) Handles DataGridView1.CellContentClick
        Me.txtDni.Text = Me.DataGridView1.CurrentRow.Cells.Item("dni").Value
        Me.txtNombre.Text = Me.DataGridView1.CurrentRow.Cells.Item("nombre").Value
        Me.txtTelefono.Text = Me.DataGridView1.CurrentRow.Cells.Item("telefono").Value
    End Sub

El problema es que al hacer click no siempre se rellenan los TextBox, teniendo que dejar cierto tiempo entre click y click para que sí se rellenen.

¿Alguien sabe por qué es el problema y cómo puedo solucionarlo?

Un saludo y gracias :)
52  Programación / .NET (C#, VB.NET, ASP) / 'Microsoft.Jet.OLEDB.4' en: 4 Marzo 2010, 23:43 pm
Hola ,
estoy intentando conectar abrir un archivo access  mediante este código en visual studio 2005:
Código:
Imports System.Data.OleDb

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Try
            Dim strCon As String = "Provider=Microsoft.Jet.OLEDB.4; Data souce=C:\Documents and Settings\Administrador\Mis documentos\prueba.mdb"

            Dim oCON As OleDbConnection = New OleDbConnection(strCon)
            oCON.Open()
        Catch ex As Exception
            MessageBox.Show(ex.Message)
        End Try


    End Sub
End Class

El caso es que el evento click me da el siguietne error:
El proveedor 'Microsoft.Jet.OLEDB.4' no está registrado en el equipo local


Alguien me podría decir qué hago mal y cómo puedo solucionarlo??
No consigo acceder a una base de datos desde código, aunque sí mediante el interfaz gráfico de visual studio.

Muchas gracias :)
53  Programación / PHP / Usar variable PHP en HTML [SOLUCIONADO] en: 7 Febrero 2010, 12:23 pm
Hola!
tengo el siguiente código para una página:

Código:
<html><head><title>Ejercicio 8</title></head>

<?
echo "El método que ha usado fue: ",$_SERVER[REQUEST_METHOD],"<br>";
$a = $_REQUEST['color'];
?>

<body bgcolor = $a>

<?
echo "<br>El valor de la variable es: ", $a;
?>
</body></html>

Desde un formulario de otra página le llega a ésta el color de fondo que debe tener. La variable $a almacena el número hexadecimal del colro en cuestión.
El problema es que al cargar la página con el color que debiera, sale todo negro.
Supongo que sea porque el valor de $a es 0 en la línea de HTML, pero no en los scripts de PHP.

Mi pregunta:
¿Cómo puedo pasar el valor de la variable desde un script PHP a una línea del mismo fichero en HTML?

Muchas gracias :)
54  Programación / Bases de Datos / Problema para conectar Oracle FORMS con OracleXE en: 17 Enero 2010, 16:16 pm
Hola!
Tengo instalado:
- Oracle 10g XE
- Oracle DeveloperSuite 10g

Estoy aprendiendo a utilizar Oracle Forms incluido en la suite.
Después de instalar la suite puedo conectar con la base de datos con normalidad, pero de pronto, sin haber realizado ningún cambio de configuración ni nada de nada me deja de conectar. No importa que reinicie el programa o el sistema operativo, que no hay manera de que conecte, dando el siguiente error:
ORA-12154: TSN:no se ha podido resolver el identificador de conexión especificado
He probado como ya he dicho a reiniciar, a configurar de nuevo la red local con el asistente (que al hacer la prueba de conexión me dice que es correcta), a intentar conectar con distintos usuarios de la base de datos incluido el administrador "system".
El archivo C:\DevSuiteHome_1\NETWORK\ADMIN\tnsnames.ora tiene el siguiente contenido:
Código:
XE =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = ordenado-0f0775)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = XE)
    )
  )
El nombre del equipo, del puerto y de la base de datos son los correctos.
El problema aparece sin causa alguna (al menos que me de yo cuenta) pero contextos en los que se ha podido dar el problema:
- después de desgramentar la unidad
- después de reiniciar el sistema operativo
- sin causa aparente

Nunca he cambiado configuración alguna y la única solución al problema que he encontrado es desinstalar y volver a instalar la suite para que vuelva a funcionar por lo menos una vez más.

Por favor, alguien me puede ayudar???
Si hace falta algún dato decídmelo que en seguida lo subo :)


Muchas gracias.


Start OC4J Instance
55  Programación / Java / Problema con secuencia de escape Ctrl + z en: 21 Agosto 2009, 19:23 pm
Buenas....

tengo el siguiente código:

Código:
import java.io.*;
public class CMediana {

public static void main(String[]args)
{

int temp = 0;
int i = 0;
int nElementos = 0;

final char eof = (char)-1;


do{
System.out.print("Cuántos elementos tendrá la serie? ");
nElementos = Leer.datoInt();
}while(nElementos < 1);


int []m = new int [nElementos];

System.out.println("Introduzca una serie de números");
System.out.println("Para salir pulse [Ctrl][z]");

do{
System.out.print("Número " + (i+1) + ": ");
m[i] = Leer.datoInt();
i++;
}while(i < m.length && m[i] != eof);
}
}

La clase Leer es una clase creada para leer los datos de tipo "int".

El problema es que cuando puslo Ctrl + z el resultado es el siguiente (por ejemplo):

Cuántos elementos tendrá la serie? 6
Introduzca una serie de números
Para salir pulse [Ctrl][z]
Número 1: 23
Número 2: 54
Número 3: 2
Número 4: Número 5: Número 6:

El resultado que me gustaría que fuese al pular la secuencia de salida del programa es el siguiente:

Cuántos elementos tendrá la serie? 6
Introduzca una serie de números
Para salir pulse [Ctrl][z]
Número 1: 23
Número 2: 54
Número 3: 2
Número 4:

¿Alguien me puede ayudar por favor??? :)
56  Programación / Java / Duda con método available() en: 10 Agosto 2009, 22:04 pm
hola!!!
tengo el siguietne código extraído de un ejercicio de Fco. Javier Ceballos ("Java 2: Curso de programación"):
Código:
import java.io.*;

public class CTest {

public static void main (String[]args)
{
InputStreamReader isr = new InputStreamReader (System.in);
BufferedReader flujoE = new BufferedReader (isr);
PrintStream flujoS = System.out;

char car = 0;
int ncars;

try
{
flujoS.print("Caracter: ");
car = (char)flujoE.read();
flujoS.println(car);


ncars = flujoE.available();
flujoE.skip(ncars);


flujoS.print("Caracter: ");
car = (char)flujoE.read();
flujoS.print(car);
}

catch(IOException e)
{

}
}
}


el problema y duda que tengo es que la línea :
Código:
ncars = flujoE.available();

produce un error ya que el método available() no está definido para el tipo BufferedReader.

En un ejemplo del libro el código es así tal cual( no lo he modificado), sin embargo cuando intento compilar el programa me lanza el error en dicha línea. Es una errata del libro o estoy haciendo algo mal???
por otro lado he sustituido ese intento de vaciar el buffer con:
Código:
System.in.skip(System.in.available());
pero no se vacía el buffer. En este otro caso por qué no funciona el vaciado???

Gracias y espero respuesta :)
57  Programación / Java / duda básica con método available() en: 7 Junio 2009, 13:51 pm
Hola!!
supongo que esto sea una pregunta bastante sencilla, pero he intentado buscar info al respecto y no he conseguido solucionar el problema.

el programa en cuestión tiene que leer un caracter, visualizarlo y luego otra vez lo mismo, leer y visualizar.

el problema es que he buscado la manera de saltar los caracteres de retroceso de carro y salto de línea, encontrando la siguiente solución:

Código:
ncars = flujoE.available();
flujoE.skip(ncars);


lo que me ocurre es que me da un error, ay que no reconoce el método available() definido en el tipo BufferedReader (es el error que me da el compilador).

el código completo:

Código:
import java.io.*;

public class CTest {

public static void main (String[]args)
{
InputStreamReader isr = new InputStreamReader (System.in);
BufferedReader flujoE = new BufferedReader (isr);
PrintStream flujoS = System.out;

char car = 0;
int ncars;

try
{
flujoS.print("Caracter: ");
car = (char)flujoE.read();
flujoS.println(car);

ncars = flujoE.available();
flujoE.skip(ncars);

flujoS.print("Caracter: ");
car = (char)flujoE.read();
flujoS.print(car);
}

catch(IOException e)
{

}
}
}

sé que puede ser una tontería, pero como tengo muy poquita experiencia con Java (algo más con C) no doy con la solución
muchas gracias :)
58  Sistemas Operativos / Windows / Crear USB bootable en: 27 Marzo 2009, 21:36 pm
Hola, estoy intentando hacer un USB bootable, para intentar iniciar el ordenador desde el USB y tener acceso al contenido del disco duro. Buscando por google encontré lo siguiente que hay que copiar en la unidad USB los siguientes archivos:
NTDLR
NDETECT.COM
boot.ini

el boot.ini tiene el siguietne contenido:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

Al copiar estos 3 archivos en el pendrive e iniciar el sistema desde la unidad USB aparece el siguieten mensaje de error : "disk boot failure, insert system disk and press enter".

Lo que NO QUIERO:
- que me den soluciones para iniciar el ordenador desde el CD-ROM u otras opciones (bien sean con el cd de windows xp, versiones desatendidas, etc...)
- instalar ningún programa extra que ayude a crear un pendrive bootable (ni de HP ni de ninguna compañía u open source o lo que sea)

Lo que SÍ QUIERO:
- iniciar el equipo desde un USB


Mi intención es crear lo que hace muchos años en MSDOS se hacía con el comando SYS C: A: para crear un diskette de sistema y poder iniciar el ordenador desde el diskette (querría saber por qué no funciona por el de aprender, ya que he leído que debería poder iniciarse así, copiando los archivos arriba indicados, pero el resultado no es el esperado.

DATOS(por si sirven de ayuda):
- están conectados los apartados necesarios del BIOS (USB legacy supprt, etc.....)para poder iniciar desde la unidad USB
- tengo un único disco duro con dos particiones (C: y D:)

Para culaquier otro dato no tendré problema en facilitarlo.

Gracias y un saludo. :)
Páginas: 1 2 3 4 5 [6]
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines