elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recuerda que debes registrarte en el foro para poder participar (preguntar y responder)


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)  (Leído 7,386 veces)
Kronos_neko

Desconectado Desconectado

Mensajes: 4


Ver Perfil
Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
« en: 10 Octubre 2010, 21:00 pm »

Hola que tal miembros de este foro, puedo decir que no soy nuevo en linux sin embargo tampoco soy tan experto como para resolver las cosas completamente por mi cuenta, y es dado que este problema ya he buscado varias soluciones y no logro arregarlo...
He aqui el meollo del asunto:
Hasta antes de el viernes pasado habia estado trabajando con Ubuntu 10.04, kernel: 2.6.32-25 con upgrade a ubuntustudio sin problemas, sin embargo hasta el jueves que coneccte unas bocinas logitech empezo a fallar, al principio todo era normal, pero el viernes que la volvi a prender me aparecia en el manejador de sonido de gnome "salida boba" y aparentemente mi carpeta /proc/asound habia desaparecido por lo que gnome no reconocia siquiera mi tarjeta de sonido e incluso los archivos de la carpeta no aparecen por ningun lado( ni devices.conf)

De ahi estuve probando soluciones:
-aplay -l me dice que no se encontraron tarjetas de sonido
-lspci | grep snd para buscar mi tarjeta no la encuentra, no me regresa coincidencias
-usando hardinfo para ver los dispositivos veo que si la reconoce
-con kde, el manejador de dispositivos me dice lo siguiente:
 
**En caso de que no salga la imagen dice: Kde ha detectado que uno o mas dispositivos internos de sonido han sido eliminados. y me muestra el nombre de la tarjeta de sonido: HDA intel(ALC268 Analog)

EN fin estuve probando varias formas, entre ellas las de este post:
http://foro.elhacker.net/gnulinux/problema_sonido_ubuntu_1004-t292671.0.html;msg1449338;topicseen

Pero sin obtener resultados. Podrian ayudarme?
Gracias


En línea

jbndg

Desconectado Desconectado

Mensajes: 175


Live together, die alone.


Ver Perfil
Re: Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
« Respuesta #1 en: 10 Octubre 2010, 21:22 pm »

Hola, a mi me paso algo parecido una vez, prueva esto:

Citar
Asegúrate que slmodemd no se está ejecutando.

pgrep slmodemd

Al ejecutar ese comando no debería salir nada por consola. Si lo hace, debes eliminar este elemento de tu sistema:

sudo apt-get remove sl-modem-daemon

Una vez hecho esto lo mejor es que reinicies para comprobar, sin posibilidad de meter la pata, si el sonido ya funciona mejor

Saludos y suerte.


En línea

Kronos_neko

Desconectado Desconectado

Mensajes: 4


Ver Perfil
Re: Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
« Respuesta #2 en: 22 Octubre 2010, 00:23 am »

Probe el comando que me decias y efectivamente no salio nada, sin embargo tampoco se corrigio el problema, aunque de hecho estubve haciendo investigacion en mi compu y ya descubri cual es el problema, y es que el modulo de sonido del kernel no se esta cargando automaticamente, para cargarlo uso modprobe, la cosa es que tengo que cargarlo cada que inicio...como puedo automatizar esto?
lo que pensaba era un script pero debe de haber alguna forma que sea de sistema y pueda configurar no...?¿
En línea

j4np0l


Desconectado Desconectado

Mensajes: 491


Destroying is always easier than creating


Ver Perfil
Re: Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
« Respuesta #3 en: 22 Octubre 2010, 21:30 pm »

...el modulo de sonido del kernel no se esta cargando automaticamente, para cargarlo uso modprobe, la cosa es que tengo que cargarlo cada que inicio...como puedo automatizar esto?

Agrega el nombre del módulo al archivo /etc/modules. Para cargarlo usas modprobe modulo no? Porque si lo cargas con otras opciones adicionales hay que hacer un par de cositas mas  ;D

Por ej, si necesitas cargar un módulo (en este caso snd-opl3sa2 que es de sonido) de la siguiente manera:

Código
  1. modprobe snd-opl3sa2

Agregas snd-opl3sa2 a /etc/modules y listo. Pero si lo tenés que cargar de esta forma:

Código
  1. modprobe snd-opl3sa2 index=0 id=CARD_0 port=0x370 sb_port=0x220 wss_port=0x530 midi_port=-1 fm_port=-1 irq=5 dma1=0 dma2=1 isapnp=0

Primero agregas snd-opl3sa2 a /etc/module y después creas el archivo /etc/modprobe.d/sound_card con el siguiente contenido:

Código:
## Added for sound card detection
options snd-opl3sa2 index=0 id=CARD_0 port=0x370 sb_port=0x220 wss_port=0x530 midi_port=-1 fm_port=-1 irq=5 dma1=0 dma2=1 isapnp=0


Saludos!
« Última modificación: 22 Octubre 2010, 21:39 pm por j4np0l » En línea

Kronos_neko

Desconectado Desconectado

Mensajes: 4


Ver Perfil
Re: Salida boba en Ubuntu 10.04(no reconoce mi tarjeta de sonido)
« Respuesta #4 en: 27 Diciembre 2010, 07:51 am »

hola que tal, despues de haberme desesperado y reinstalado mi sistema sigo con el mismo problema a diferencia de que ahora no cargando el modulo(snd-hda-intel) tengo sonido...
reinstale ubuntu 10.10 y le hice upgrade a ubuntustudio, en cuanto a sonido tengo oss, alsa y pulseaudio y todo parecia funcionar bien hasta ahora que reinicie y sigo con el problema...y tras checar el archivo que me decias /etc/modules solo encuentro en el el comando lp, asi a secas..
yo ya no entiendo que pasa u.u
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
windows no me reconoce la tarjeta de sonido
Windows
marrison 9 9,493 Último mensaje 25 Noviembre 2012, 22:05 pm
por Weyler
windows 7 no reconoce los conroladores de sonido ubuntu si
Windows
laindiadeloeste 7 2,349 Último mensaje 31 Marzo 2014, 23:29 pm
por dato000
pregunta boba, siglas de archivos
Dudas Generales
basickdagger 3 1,593 Último mensaje 5 Junio 2014, 17:00 pm
por basickdagger
Ubuntu no reconoce mi tarjeta m-audio delta « 1 2 »
GNU/Linux
FranKlr 16 4,708 Último mensaje 19 Noviembre 2014, 03:52 am
por FranKlr
Problemas salida sonido portatil
Hardware
Pintasconamor 1 420 Último mensaje 22 Julio 2021, 14:21 pm
por Randomize
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines