elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Como proteger una cartera - billetera de Bitcoin


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Como puedo instalar code::blocks en debian?
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: 1 [2] Ir Abajo Respuesta Imprimir
Autor Tema: Como puedo instalar code::blocks en debian?  (Leído 3,827 veces)
UsuarioProgramador

Desconectado Desconectado

Mensajes: 27


Con mi espada corto todo problema que se presente


Ver Perfil
Re: Como puedo instalar code::blocks en debian?
« Respuesta #10 en: 29 Julio 2017, 03:34 am »

soy un poco nuevo en linux y tal ves se de el caso en el que no sepa a quie archivo le doy para que se instale code::blocks porque a todos les doy y se abre y se cierra una terminal  :silbar: :silbar: :-\


a no listo ya lo instale encontré un archivo  que decía como instalarlo :V



Cuendo me dicen que coloque este codigo en el source.list

Código:
deb http://[b]repositorio_que_te_diga_netselect[/b]/ jessie main contrib non-free

# Repositorio  actualizaciones de seguridad estable
deb http://security.debian.org/ jessie/updates main contrib non-free

deb ftp://ftp.deb-multimedia.org stable main non-free

a que te refieres con repositorio que me de netselect??


y cuando instalo code::blocks me dice

Código:
checking if the compiler supports precompiled headers... yes
checking for wx-config... no
configure: error:
                wxWidgets must be installed on your system.

                Please check that wx-config is in path, the directory
                where wxWidgets libraries are installed (returned by
                'wx-config --libs' or 'wx-config --static --libs' command)
                is in LD_LIBRARY_PATH or equivalent variable and
                wxWindows version is 2.8.0 or above.



· No hagas doble post! usa el boton modificar
>aquí las reglas del foro
-Engel Lex


« Última modificación: 29 Julio 2017, 04:02 am por engel lex » En línea

A lo largo de la historia, el mundo ha estado controlado por grandes ideologías como la religión,el socialismo y el capitalismo, entre otras. Estas son todas las formas de esclavitud que han detenido nuestra evolución y nos han quitado nuestra libertad.
engel lex
Colaborador
***
Desconectado Desconectado

Mensajes: 15.347



Ver Perfil
Re: Como puedo instalar code::blocks en debian?
« Respuesta #11 en: 29 Julio 2017, 04:11 am »

Citar
Cuendo me dicen que coloque este codigo en el source.list
a que te refieres con repositorio que me de netselect?? 

lee esa respuesta completa... te indiqué todo D:

Citar
y cuando instalo code::blocks me dice

que te bajaste tu? -.-

codeblocks -> downloads  -> Download the binary release -> Linux 64-bit -> codeblocks_16.01_amd64_jessie.tar.xz

aquí el link... son puros .deb
http://sourceforge.net/projects/codeblocks/files/Binaries/16.01/Linux/Debian%20Jessie/codeblocks_16.01_amd64_jessie.tar.xz


intentas instalar el codeblocks_16.01_amd64.deb si te pide algo adicional, o te dice que hay dependencias rotas, instalas primero ese otro .deb (aunque el base debería resolverlas)


En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
do-while


Desconectado Desconectado

Mensajes: 1.276


¿Habra que sacarla de paseo?


Ver Perfil
Re: Como puedo instalar code::blocks en debian?
« Respuesta #12 en: 29 Julio 2017, 12:55 pm »

Si mal no recuerdo cuando salió Debian Jessie utilizaba wxwidgets 3, por aquel entonces codeblocks se basaba en la version 2.8 de wxwidgets, así que el paquete no se incluyó en Debian (fue una de las razones por las que directamente pasé a stretch).

En este momento está disponible a traves de los backports. Tendrás que mirar como activarlos y ya podrás instalar codeblocks. La otra alternativa es pasar a Debian Stretch (actual estable) o Buster (testing).

De todas formas en este momento, al menos en Debian y Arch, el paquete no funciona bien. Tiene cierres aleatorios que te van a obligar a guardar el documento de forma continua, casi al introducir cada línea de código, si no quieres perder todo lo que has hecho desde que has iniciado el IDE.

Tienes alternativas como Eclipse (apt-get install eclipse eclipse-cdt),un monstruo con el que para cualquier código sencillo vas a tener que estar creando un proyecto, Geany, muy básico y para mi gusto chapucero o Anjuta, que no lo conozco, y más.
« Última modificación: 29 Julio 2017, 13:04 pm por do-while » En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
engel lex
Colaborador
***
Desconectado Desconectado

Mensajes: 15.347



Ver Perfil
Re: Como puedo instalar code::blocks en debian?
« Respuesta #13 en: 29 Julio 2017, 19:31 pm »

te digo que con esa descarga se hace perfecto, yo lo instalé sin problemas XD
En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
Páginas: 1 [2] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines