elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a la Factorización De Semiprimos (RSA)


+  Foro de elhacker.net
|-+  Comunicaciones
| |-+  Redes
| | |-+  imposibilidad de autentificarme en Xampp
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: imposibilidad de autentificarme en Xampp  (Leído 3,073 veces)
mitx00

Desconectado Desconectado

Mensajes: 19


hello world


Ver Perfil
imposibilidad de autentificarme en Xampp
« en: 19 Diciembre 2011, 18:38 pm »

Buenos días a tod@s,

Quería crear un blog en wordpress y para ello instalé Xampp 1.7.7 en mi Ubuntu 11.10. Aunque al principio me daba el error de :
Código:
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://www.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

Lo solucioné con:

Código:
sudo /etc/init.d/apache2 stop
sudo /opt/lampp/lampp restart



Lo que me pasa ahora, una vez he configurado la contraseña con:

Código:
sudo /opt/lampp/lampp security


Al intentar entrar en http://localhost, me pide un usuario y una contraseña.La contraseña es la que acabo de poner, pero ¿el usuario?.Introduzco admin, lampp, root, el nombre de mi equipo...Pero nada. Según doy en aceptar vuelve a salirme el formulario de la contraseña.

Ya no sé qué hacer. No sé si es algo que está mal configurado o qué.

Si alguien tiene idea, y me puede echar un cable, se lo agradecería.

Un saludo.


En línea

En una sociedad basada en la explotación y la servidumbre, la naturaleza humana se degrada.  Pior Kropotkin.
madpitbull_99
Colaborador
***
Desconectado Desconectado

Mensajes: 1.911



Ver Perfil WWW
Re: imposibilidad de autentificarme en Xampp
« Respuesta #1 en: 19 Diciembre 2011, 20:15 pm »

En la carpeta de wwwroot, o la carpeta que tengas configurada como directorio del servidor web, tiene que haber algún fichero
.htaccess.

Búscalo y editalo, ahí deberías ver el nombre del usuario y la contraseña cifrada.

Para el tema del inicio de apache, te recomiendo leer los logs, si no consigues descifrarlos, puedes pegarlos aquí y te echaremos una mano.




En línea



«Si quieres la paz prepárate para la guerra» Flavius Vegetius

[Taller]Instalación/Configuración y Teoría de Servicios en Red
mitx00

Desconectado Desconectado

Mensajes: 19


hello world


Ver Perfil
Re: imposibilidad de autentificarme en Xampp
« Respuesta #2 en: 19 Diciembre 2011, 21:33 pm »

Gracias por responder, madpitbull_99 :

El directorio donde tengo configurado xampp es: /opt/lampp/

Aquí entro como root y encuentro estas carpetas:

bin
cgi bin
error
etc
htdocs
icons
libs
libexec
licenses
log
modules
phpmyadmin
sbin
share
tmp
var

Pero he "bicheado" por ellas y no encuentro .htaccess :-(

El manual lo saqué de  aquíhttp://robersoft.blogcindario.com/2011/09/00022-instalar-xampp-servidor-web-en-linux.html, donde asegura que el usuario por defecto es lampp, aunque a mí no me funciona.

No sé si puede ser un problema con la base de datos, pues al reiniciar xampp me sale esto:
Código:
Starting XAMPP for Linux 1.7.7...
XAMPP: Starting Apache...
XAMPP: Starting MySQL...
[b]XAMPP: Couldn't start MySQL![/b]
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

En los logs no he encontrado nada.Los pego por si acaso:

access_log

Código:
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET / HTTP/1.1" 302 -
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/ HTTP/1.1" 200 589
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/head.php HTTP/1.1" 200 1362
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/navi.php HTTP/1.1" 200 2321
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/start.php HTTP/1.1" 200 856
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/img/blank.gif HTTP/1.1" 200 43
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/xampp.js HTTP/1.1" 200 463
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/xampp.css HTTP/1.1" 200 3991
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/img/xampp-logo-new.gif HTTP/1.1" 200 4878
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/img/head-linux.gif HTTP/1.1" 200 1002
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/img/head-for.gif HTTP/1.1" 200 791
127.0.0.1 - - [19/Dec/2011:13:14:33 +0100] "GET /xampp/img/strichel.gif HTTP/1.1" 200 61
127.0.0.1 - - [19/Dec/2011:13:14:34 +0100] "GET /xampp/img/apachefriends.gif HTTP/1.1" 200 979
127.0.0.1 - - [19/Dec/2011:13:14:34 +0100] "GET /favicon.ico HTTP/1.1" 200 30894
127.0.0.1 - - [19/Dec/2011:13:14:35 +0100] "GET /xampp/php.php HTTP/1.0" 200 2
127.0.0.1 - - [19/Dec/2011:13:14:35 +0100] "GET /xampp/mysql.php HTTP/1.0" 200 3
127.0.0.1 - - [19/Dec/2011:13:14:35 +0100] "GET /xampp/cgi.cgi HTTP/1.0" 200 3
127.0.0.1 - - [19/Dec/2011:13:14:36 +0100] "GET /xampp/ssi.shtml HTTP/1.0" 200 4
127.0.0.1 - - [19/Dec/2011:13:14:36 +0100] "GET /xampp/perl.pl HTTP/1.0" 200 2
127.0.0.1 - - [19/Dec/2011:13:14:35 +0100] "GET /xampp/status.php HTTP/1.1" 200 3880
127.0.0.1 - - [19/Dec/2011:13:14:37 +0100] "GET /xampp/security.php HTTP/1.1" 200 3953
127.0.0.1 - - [19/Dec/2011:13:14:39 +0100] "OPTIONS * HTTP/1.0" 200 -
127.0.0.1 - - [19/Dec/2011:13:14:43 +0100] "OPTIONS * HTTP/1.0" 200 -
127.0.0.1 - - [19/Dec/2011:13:16:51 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:17:06 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:17:19 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:05 +0100] "GET / HTTP/1.1" 302 -
127.0.0.1 - - [19/Dec/2011:13:18:05 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:08 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:08 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:09 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:09 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:18:09 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:13:31:35 +0100] "GET / HTTP/1.1" 302 -
127.0.0.1 - - [19/Dec/2011:13:31:35 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:18:33:14 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:20:49:44 +0100] "GET /wordpress/wp-admin/install.php HTTP/1.1" 500 3088
127.0.0.1 - - [19/Dec/2011:20:49:44 +0100] "GET /favicon.ico HTTP/1.1" 200 30894
127.0.0.1 - - [19/Dec/2011:20:51:37 +0100] "GET / HTTP/1.1" 302 -
127.0.0.1 - - [19/Dec/2011:20:51:37 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:20:51:58 +0100] "GET /xampp/ HTTP/1.1" 401 1612
127.0.0.1 - - [19/Dec/2011:21:23:16 +0100] "GET /wordpress HTTP/1.1" 301 408
127.0.0.1 - - [19/Dec/2011:21:23:16 +0100] "GET /wordpress/ HTTP/1.1" 500 277
cgisock.11083 no se puede abrir
cgisock.14185 no se puede abrir
httpd.pid
error_log
Código:
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[Mon Dec 19 13:14:09 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Dec 19 13:14:09 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Dec 19 13:14:09 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 19 13:14:09 2011] [notice] Digest: done
[Mon Dec 19 13:14:10 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_ssl/2.2.21 OpenSSL/1.0.0c PHP/5.3.8 mod_apreq2-20090110/2.7.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 19 13:17:06 2011] [error] [client 127.0.0.1] user lampp: authentication failure for "/xampp/": Password Mismatch
[Mon Dec 19 13:17:19 2011] [error] [client 127.0.0.1] user admin not found: /xampp/
[Mon Dec 19 13:17:38 2011] [notice] caught SIGTERM, shutting down
[Mon Dec 19 13:17:45 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Dec 19 13:17:45 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Dec 19 13:17:45 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 19 13:17:45 2011] [notice] Digest: done
[Mon Dec 19 13:17:46 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_ssl/2.2.21 OpenSSL/1.0.0c PHP/5.3.8 mod_apreq2-20090110/2.7.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 19 13:18:08 2011] [error] [client 127.0.0.1] user  not found: /xampp/
[Mon Dec 19 13:18:08 2011] [error] [client 127.0.0.1] user  not found: /xampp/
[Mon Dec 19 13:18:09 2011] [error] [client 127.0.0.1] user  not found: /xampp/
[Mon Dec 19 13:18:09 2011] [error] [client 127.0.0.1] user  not found: /xampp/
[Mon Dec 19 13:18:09 2011] [error] [client 127.0.0.1] user  not found: /xampp/
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[Mon Dec 19 20:29:04 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Dec 19 20:29:04 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Dec 19 20:29:04 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 19 20:29:04 2011] [notice] Digest: done
[Mon Dec 19 20:29:05 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_ssl/2.2.21 OpenSSL/1.0.0c PHP/5.3.8 mod_apreq2-20090110/2.7.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 19 20:50:22 2011] [notice] caught SIGTERM, shutting down
[Mon Dec 19 20:50:29 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Dec 19 20:50:29 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Dec 19 20:50:29 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 19 20:50:29 2011] [notice] Digest: done
[Mon Dec 19 20:50:30 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_ssl/2.2.21 OpenSSL/1.0.0c PHP/5.3.8 mod_apreq2-20090110/2.7.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 19 20:50:49 2011] [notice] caught SIGTERM, shutting down
[Mon Dec 19 20:50:56 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Dec 19 20:50:56 2011] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Dec 19 20:50:56 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 19 20:50:56 2011] [notice] Digest: done
[Mon Dec 19 20:50:57 2011] [notice] Apache/2.2.21 (Unix) DAV/2 mod_ssl/2.2.21 OpenSSL/1.0.0c PHP/5.3.8 mod_apreq2-20090110/2.7.1 mod_perl/2.0.5 Perl/v5.10.1 configured -- resuming normal operations
[Mon Dec 19 20:51:58 2011] [error] [client 127.0.0.1] user root not found: /xampp/

php_error_log vacio

ssl_request_log vacio

Gracioas por la ayuda y un saludo :)

En línea

En una sociedad basada en la explotación y la servidumbre, la naturaleza humana se degrada.  Pior Kropotkin.
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Python - Autentificarme en una web « 1 2 »
Scripting
SheKeL_C$ 13 5,971 Último mensaje 29 Mayo 2010, 01:44 am
por ~ Yoya ~
no logro autentificarme con BT4
Wireless en Linux
rukymon 6 3,130 Último mensaje 1 Mayo 2011, 22:38 pm
por rukymon
La OCU denuncia la imposibilidad de comprar un PC sin Windows « 1 2 »
Noticias
wolfbcn 17 4,078 Último mensaje 30 Julio 2011, 20:59 pm
por ricki74
imposibilidad correcto rendimiento gtx 650 oc
Juegos y Consolas
Thony 25 4 3,296 Último mensaje 18 Abril 2013, 14:56 pm
por Thony 25
Imposibilidad con puertos y preguntas
Redes
JoseGutrz 4 1,932 Último mensaje 3 Octubre 2017, 07:12 am
por engel lex
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines