elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación C/C++ (Moderadores: Eternal Idol, Littlehorse, K-YreX)
| | |-+  Problema con eclipse c/c++
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con eclipse c/c++  (Leído 4,960 veces)
zaphiel

Desconectado Desconectado

Mensajes: 15


Ver Perfil
Problema con eclipse c/c++
« en: 2 Diciembre 2014, 21:44 pm »

Buenas compañeros.

He instalado adt bundle, eclipse juno para desarrollar en c, java y futuro Android. Instalado cygwin y CDT siguiendo esta guia http://mundogeek.net/archivos/2007/01/17/desarrollo-con-cc-en-eclipse/ pero no consigo instalar bien gcc, por lo que al intentar compilar un archivo.c me sale el error " Launch Failed: Binary Not Found error.", me parece que creo bien el proyecto. Pero como falla el compilador o gcc no se como arreglarlo.

Tengo java, jdk y jre instalados en la última versión.  Sobre Windows 8.1.

Alguna idea?

He puesto eclipse para tener todo en un mismo programa, además que en alguna asignatura tengo que usar ese.


Enviado desde mi OnePlus One usando Tapatalk 4.


En línea

Clerval

Desconectado Desconectado

Mensajes: 1



Ver Perfil
Re: Problema con eclipse c/c++
« Respuesta #1 en: 3 Diciembre 2014, 03:28 am »

Selecciona la carpeta del proyecto que quieras compilar y dale a una opción que dice "Build Project".
Creo que eso estaría arreglando tu inconveniente.

Un saludo  :)


En línea

zaphiel

Desconectado Desconectado

Mensajes: 15


Ver Perfil
Re: Problema con eclipse c/c++
« Respuesta #2 en: 3 Diciembre 2014, 12:01 pm »

Me sigue saliendo el problema.

Al hacer el build sale

 
Código:
**** Build of configuration Default for project ProyectC ****

****  WARNING: The "Default" Configuration may not build  ****
****  because it uses the "cdt.managedbuild.toolchain.gnu.cygwin.base"  ****
****  tool-chain that is unsupported on this system.  ****

****  Attempting to build...  ****

make all

Cannot run program "make": Launching failed
Error: Program "make" is not found in PATH

PATH=[C:\cygwin64\bin;C:/Program Files/Java/jre1.8.0_25/bin/server;C:/Program Files/Java/jre1.8.0_25/bin;C:/Program Files/Java/jre1.8.0_25/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;D:\Ingenieria\Eclipse\eclipse]

**** Build Finished ****

Algo del make falla, pero no se bien que es.
En línea

zShackra

Desconectado Desconectado

Mensajes: 59


Ver Perfil WWW
Re: Problema con eclipse c/c++
« Respuesta #3 en: 3 Diciembre 2014, 13:46 pm »

Me sigue saliendo el problema.

Al hacer el build sale

 
Código:
make all

Cannot run program "make": Launching failed
Error: Program "make" is not found in PATH

PATH=[C:\cygwin64\bin;C:/Program Files/Java/jre1.8.0_25/bin/server;C:/Program Files/Java/jre1.8.0_25/bin;C:/Program Files/Java/jre1.8.0_25/lib/amd64;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;D:\Ingenieria\Eclipse\eclipse]

Algo del make falla, pero no se bien que es.

Pues según dice ahí, make no existe en los directorios donde PATH redirige...
« Última modificación: 3 Diciembre 2014, 13:48 pm por zShackra » En línea

zaphiel

Desconectado Desconectado

Mensajes: 15


Ver Perfil
Re: Problema con eclipse c/c++
« Respuesta #4 en: 3 Diciembre 2014, 15:37 pm »

Cierto, en el PATH tengo  C:\cygwin64\bin, y no existe make, como se puede arreglar eso? Estan makeinfo y makeconv
En línea

zShackra

Desconectado Desconectado

Mensajes: 59


Ver Perfil WWW
Re: Problema con eclipse c/c++
« Respuesta #5 en: 3 Diciembre 2014, 18:01 pm »

Cierto, en el PATH tengo  C:\cygwin64\bin, y no existe make, como se puede arreglar eso? Estan makeinfo y makeconv

Renombra el fichero mingw32-make.exe a make.exe, entonces refresca y limpia el proyecto, reinicia Eclipse e intenta...
En línea

zaphiel

Desconectado Desconectado

Mensajes: 15


Ver Perfil
Re: Problema con eclipse c/c++
« Respuesta #6 en: 4 Diciembre 2014, 16:22 pm »

Ese fichero no esta en C:\cygwin64\bin, si aparece en C:\Dev-Cpp\bin (que dev c++ tampoco me funciona..., pero eso otro tema), volviendo a instalar cygwin ya me aparece make.exe en la carpeta C:\cygwin64\bin.

Pero al hacer build en eclipse y darle a run me sale esto.

Código:
make: *** No targets specified and no makefile found.  Stop.


Esto me aparece unicamente en el proyecto, faltan carpetas binary y alguna mas me quiere sonar, es asi? Hace mucho tiempo que no uso eclipse no me acuerdo como funcionaba :/

En línea

Eternal Idol
Moderador
***
Desconectado Desconectado

Mensajes: 5.718


Israel nunca torturó niños, ni lo volverá a hacer.


Ver Perfil WWW
Re: Problema con eclipse c/c++
« Respuesta #7 en: 4 Diciembre 2014, 17:13 pm »

Consulta la documentacion del software que estas usando.
En línea

La economía nunca ha sido libre: o la controla el Estado en beneficio del Pueblo o lo hacen los grandes consorcios en perjuicio de éste.
Juan Domingo Perón
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema sencillo en eclipse
Java
usernovell 2 1,337 Último mensaje 15 Marzo 2013, 17:27 pm
por 1mpuls0
[C++] Problema con bucle en Eclipse
Programación C/C++
HijoDePuta 4 1,813 Último mensaje 9 Agosto 2013, 20:14 pm
por HijoDePuta
Problema Eclipse
Java
Tronos154 8 2,675 Último mensaje 30 Enero 2014, 17:26 pm
por ~ Yoya ~
[Solucionado] Problema instalando WindowBuilder en Eclipse Neon
Java
agus0 0 1,694 Último mensaje 9 Septiembre 2016, 01:54 am
por agus0
Problema WindowBuilder (Eclipse) - Ventana Cortada
Java
K-YreX 3 1,114 Último mensaje 13 Abril 2020, 14:09 pm
por rub'n
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines