elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recuerda que debes registrarte en el foro para poder participar (preguntar y responder)


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación C/C++ (Moderadores: Eternal Idol, Littlehorse, K-YreX)
| | |-+  Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp  (Leído 3,507 veces)
Dober-ManN

Desconectado Desconectado

Mensajes: 50



Ver Perfil
Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« en: 31 Marzo 2013, 07:53 am »

Buenas foreros, tengo un problema que no logro identificar. Instale Qt y NetBeans, tanto en debian como en winXp, ni el simple codigo siguiente puedo ejecutar:

Código:
#include <iostream>
using namespace std;
int main() {
    Cout << "Hola Mundo";
    return 0;
}

ni tampoco:

Código:
#include <stdio.h>
using namespace std;
int main() {
    printf("Hola Mundo");
    return 0;
}


Al tratar de ejecutarlo me tira el siguiente error:

Citar
"/usr/bin/make" -f nbproject/Makefile-Debug.mk QMAKE= SUBPROJECTS= .build-conf
make[1]: Entering directory `/cygdrive/c/Documents and Settings/Wolframio/Mis documentos/NetBeansProjects/CppApplication_1'
"/usr/bin/make"  -f nbproject/Makefile-Debug.mk dist/Debug/Cygwin-Windows/cppapplication_1.exe
make[2]: Entering directory `/cygdrive/c/Documents and Settings/Wolframio/Mis documentos/NetBeansProjects/CppApplication_1'
mkdir -p build/Debug/Cygwin-Windows
rm -f build/Debug/Cygwin-Windows/main.o.d
g++    -c -g -MMD -MP -MF build/Debug/Cygwin-Windows/main.o.d -o build/Debug/Cygwin-Windows/main.o main.cpp
main.cpp: In function `int main()':
main.cpp:4: error: `Cout' undeclared (first use this function)
main.cpp:4: error: (Each undeclared identifier is reported only once for each function it appears in.)
nbproject/Makefile-Debug.mk:66: recipe for target `build/Debug/Cygwin-Windows/main.o' failed
make[2]: *** [build/Debug/Cygwin-Windows/main.o] Error 1
make[2]: Leaving directory `/cygdrive/c/Documents and Settings/Wolframio/Mis documentos/NetBeansProjects/CppApplication_1'
nbproject/Makefile-Debug.mk:59: recipe for target `.build-conf' failed
make[1]: *** [.build-conf] Error 2
make[1]: Leaving directory `/cygdrive/c/Documents and Settings/Wolframio/Mis documentos/NetBeansProjects/CppApplication_1'
nbproject/Makefile-impl.mk:39: recipe for target `.build-impl' failed
make: *** [.build-impl] Error 2


BUILD FAILED (exit value 2, total time: 4s)

Aqui unas imagenes para que observen:




Como lo tengo configurado al compilador:
Para C



Y para C++





Y es muy cansador porque quiero empezar a programar de una vez, pero este problema ya me tine loco, y para colmo, como les dije, el problema es basicamebte el mismo tanto en net beans, como en qt, y tanto en winXp como en debian.
Espero sepan ayudarme, les agradezco un monton de antemano.
Saludos


« Última modificación: 31 Marzo 2013, 08:09 am por Dober-ManN » En línea

do-while


Desconectado Desconectado

Mensajes: 1.276


¿Habra que sacarla de paseo?


Ver Perfil
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #1 en: 31 Marzo 2013, 11:50 am »

¡Buenas!

Es cout no Cout, recuerda que tanto C como C++ diferencian entre mayúsculas y minúsculas.

Si esto no te funciona avisa, ya que no he seguido mirando la configuración que tienes y no se si es la correcta o no.

¡Saludos!


En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
85

Desconectado Desconectado

Mensajes: 206



Ver Perfil WWW
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #2 en: 31 Marzo 2013, 13:42 pm »

no tenés una versión en español de ese compilador ? o sino un compilador de C++ en español, así entendés los resultados (LOG) que te muestra el compilador.

ahí decía
error: `Cout' undeclared (first use this function)

"'Cout' no declarado.."
En línea

Me cerraron el Windows Live Spaces, entonces me creé un WordPress XD
http://etkboyscout.wordpress.com/
pacoperico

Desconectado Desconectado

Mensajes: 100


Ver Perfil
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #3 en: 31 Marzo 2013, 16:13 pm »

Comprueba tambien que no exista ningun conflicto con el antivirus.
En línea

Dober-ManN

Desconectado Desconectado

Mensajes: 50



Ver Perfil
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #4 en: 31 Marzo 2013, 19:07 pm »

Gracias por las respuestas, con respecto a que tengo en mayuscula el Cout, es verdad, pero aun con minuscula (cout) me da el error, el mismo error, es algun problema con las librerias. y lo mismo con printf("hola mundo"); da el mismo error de "undeclared"... como les digo, es como que ni se da cuenta que tiene que buscarlas en las librerias...


y en debian, el cual formatee para ver si en una de esas se solucianaba, a pesar  de haber instalado ya al gcc y al g++, me indica que falta un tal "Make command":

« Última modificación: 31 Marzo 2013, 19:09 pm por Dober-ManN » En línea

85

Desconectado Desconectado

Mensajes: 206



Ver Perfil WWW
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #5 en: 31 Marzo 2013, 19:16 pm »

http://www.ubuntu-es.org/node/26248#.UVhuG6KBl2E
http://www.ubuntu-es.org/node/129385#.UVhuHaKBl2E
http://www.esdebian.org/foro/44245/no-compila-g
http://www.esdebian.org/foro/47846/problema-gcc-libreria
http://www.esdebian.org/foro/38571/problemas-compilando-programs-c-procedentes-windows-gcc

Unos links por ahí te ayudan, yo no te puedo ayudar porque no uso linux por el momento, pero algunos usan en esta comunidad, esperá que te respondan.




En línea

Me cerraron el Windows Live Spaces, entonces me creé un WordPress XD
http://etkboyscout.wordpress.com/
Dober-ManN

Desconectado Desconectado

Mensajes: 50



Ver Perfil
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #6 en: 31 Marzo 2013, 19:52 pm »

ok ok, gracias
En línea

Dober-ManN

Desconectado Desconectado

Mensajes: 50



Ver Perfil
Re: Ni un "Hola Mundo"en C/C++ logro programar, ni en debian ni xp
« Respuesta #7 en: 1 Abril 2013, 06:22 am »

Solucionado los problemas  ;D (por ahora xD). En Debian, lo selucione instalando el make desde la terminal, apt-get install make, y una vez echo eso, le agregue al NetBeans en donde dice "Make Command:" la direccion del make, osea /usr/bin/make y listo , ... aunque no tengo idea para que es este tal "make", alguien me lo puede decir?  :P
En windows, ya desistiendo de NetBeans, instale el wxDev-C++, el cual por alguna razon, me arreglo el problema en NetBeans, y me funciona nuevamente, ahora el porque, no tengo idea  :o, si alguno se le ocurre la razon, bienvenida sea la teoria, que tengo mucha curiosidad.

 Se que el wxDev-C++ se instala el mismo el compilador, cosa que me parece maravillosa ya que en casos como el mio que recien empiezan con C/C++, con lo cual no tienen la mas minima idea de a que se deben los errores, y que para colmo los errores no son muy explicativos xD, termina generando frustracion y bronca en los que se quieren iniciar, por lo que muchos abandonan la idea tachandolo de muy complicado (lo que la programacion a veces suele ser un rompe cabezas propiamente dicho). Volviendo al tema, el wxDev-C++ modifico alguna cosa que el NetBeans usaba o algo por el estilo, arreglandome el problema, pero quiero saber que es, y si es por culpa mia, me olvide algun paso o instalar algo, o es un error del compilador, el SO o el NetBeans, etc. s)
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
No logro cargar "php_mysql.dll" con PHP5
PHP
Nigtz 0 1,876 Último mensaje 22 Junio 2008, 15:53 pm
por Nigtz
recursos visual basic, """"""proceso inmortal"""""
Análisis y Diseño de Malware
Dark4ngel 7 9,513 Último mensaje 3 Noviembre 2011, 10:42 am
por Dark4ngel
Datos "escondidos" en particion RAW, no logro recuperarlos...
Windows
txente 7 4,683 Último mensaje 3 Enero 2012, 20:29 pm
por moikano→@
problema con "hola mundo"
Programación C/C++
SMFSM 5 1,536 Último mensaje 1 Marzo 2014, 15:18 pm
por Yoel Alejandro
Problema "Hola Mundo" Android
Java
csp 8 4,122 Último mensaje 6 Octubre 2014, 00:05 am
por ivancea96
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines