elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado:


  Mostrar Mensajes
Páginas: [1] 2 3 4 5 6
1  Sistemas Operativos / GNU/Linux / Re: Sin conexión al router en Ubuntu (máquina virtual) en: 24 Octubre 2018, 19:10
Normalmente ubuntu toma por defecto la red dependiendo del servidor DHCP que le pertenece al anfitrión.

Yo creo que tu problema no está en el servidor, sino en el sistema de virtualización. ¿Qué estás usando?, ¿Virtualbox, KVM, VMware?.

Estás usando un adaptador puente? DHCP local? servidor DNS local? NAT?, puedes acceder a una dirección IP externa en ves de un host, como por ejemplo 8.8.8.8?

Saludos.

Estoy usando VMware, en modo puente, IP estática, con servidor DNS 1.1.1.1, Ubuntu no reconoce el router pero si a si mismo.
2  Sistemas Operativos / GNU/Linux / Sin conexión al router en Ubuntu (máquina virtual) en: 24 Octubre 2018, 18:34
Hola, instalé en una máquina virtual Ubuntu server y al descargarme un programa, me dí cuenta de que no tenía conexión a Internet, hice un ping a mi router y no había conexión. Mi archivo interfaces está bien configurado y además lo intenté modificando el archivo resolv.conf pero nada. También miré la configuración de vmware y está todo bien, lo tengo en modo puente. Estos son los archivos:

interfaces:

Código:
auto lo
iface lo inet loopback

auto ens33
iface ens33 inet static
address 192.168.1.141
netmask 255.255.255.0
gateway 192.168.1.1


resolv.conf:

Código:
nameserver 1.1.1.1
search example.org


/etc/netplan/50-cloud-init.yam1:

Código:
network:
          ethernets:
               ens33:
                     addresses:
                     -  192.168.1.141/24
                     gateway4: 192.168.1.1
                     nameservers:
                           addresses:
                           - 1.1.1.1
                           search:
                           - example.org
                     optional: true
          version: 2


¿Alguien me puede ayudar?
3  Comunicaciones / Redes / Servidor secundario en Bind9 en: 10 Octubre 2018, 11:24
Hola, estoy usando Bind9 y tengo un servidor principal que funciona bien, el problema es el servidor secuandario, mi problema es que cuando hago que se transfiera los dominios del servidor principal al secundario, la primera vez funciona. Pero si modifico algo en el servidor principal, el servidor secundario no reconoce la configuración. También quiero que cuando el servidor principal no pueda resolver dominios, lo pueda hacer automáticamente el servidor secundario. ¿Alguien puede ayudarme?
4  Foros Generales / Dudas Generales / Re: Desesperado con los DNS en: 8 Octubre 2018, 20:11
- Si le das un ping a tu Puerta de Enlace (gateway)?

Código
  1. ping 192.168.1.1

-- Funciona? es la Puerta de enlace correcta?

No funciona  :o, pero como? Daba por obvio que funcionaría. Se supone que todo está bien. Tengo la máquina en modo puente e introduje bien las IP en la instalación de Ubuntu
5  Foros Generales / Dudas Generales / Re: Desesperado con los DNS en: 8 Octubre 2018, 19:35
- Pues eso, no tienes conexión a Internet. Entiendo que está utilizando máquinas virtuales, la pregunta es: ¿Has configurado bien tu Adaptador de Rede Virtual? Lo tienes en NAT, Brigde (Puente), ... ?

- Luego, aparece tu adaptador de red en la lista que muestra ifconfig?, tienes puesta una configuración IP válida?, usas DHCP (IP automática) o IP fija? - Por lo que veo usas IP fija (192.168.1.143), pero es la correcta?

-- Si vas a utilizar IP similares a la de tu PC real, entonces debes de configurar el Adaptador de Red Virtual como Bridge o Puente. SI usa NAT u otra, la configuración IP será completamente diferente. Mejor es usar DHCP (IP automática) por lo menos para saber que rango de IP pueden ser las correctas.

-Lo tengo en modo puente

-Si, cuando hago un ifconfig aparece mi tarjeta de red ens33, tengo IP fija y en la instalación introduje como mi IP la que tengo puesta, igualmente en el archivo interfaces.

-La IP de la máquina virtual es distinta al resto.
6  Foros Generales / Dudas Generales / Re: Desesperado con los DNS en: 8 Octubre 2018, 19:19
Saludos,

- Primero revisa si tienes conexión a Internet:

Código
  1. ping 8.8.8.8


-- Si falla, entonces debes de revisar que tengas una configuración IP válida (IP, Máscara, Puerta de enlace y DNS)

Cuando hago ping sale From 192.168.1.143 icmp_seq=1 Destination host unreachable
7  Foros Generales / Dudas Generales / Desesperado con los DNS en: 8 Octubre 2018, 18:27
Hola, estoy con Ubuntu Server, me pasa una cosa que no entiendo nada de nada y no tiene lógica. Instalé unas cuantas veces Ubuntu Server y cuando me pide mi dirección de IP y todo eso pongo que mi servidor DNS sea el 8.8.8.8 y abajo en search domain example.org.

Justo al acabar de instalarse Ubuntu server y sin tocar ningun archivo en 2 máquinas virtuales y con la misma configuración de la instalación, en una máquina  máquina con el servidor 8.8.8.8 me resuelve los dominios y en la otra máquina no.

La máquina la cual funciona la resolución de dominios no tiene configurado ni el resolv.conf, ni el archivo interface, nada.

Pero la máquina que no funcionaba la resolución tuve que tocar archivos, os pongo los archivos que configuré:

-Interfaces:

Código:
auto lo
iface lo inet loopback


auto ens33
iface ens33 inet static
    address 192.168.1.143
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1
    dns-nameservers 8.8.8.8
    dns-search local.minet

-hosts:

Código:
127.0.0.1   localhost.localdomain          localhost
192.168.1.143     sergio-server-inter.local.minet     sergio-server-inter


# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

No puedo ni hacer ping a google, me sale: Temporary failure in name resolution. No sé que más hacer...
En el archivo resolv.conf probé con poner:
Código:
nameserver 8.8.8.8
y no funcionaba

¿El arhcivo resolv.conf es solo para redes locales o sirve también para que un servidor externo nos resuelva los dominios?
8  Sistemas Operativos / GNU/Linux / Duda sobre servidores en local en: 7 Octubre 2018, 20:28
Hola, estoy aprendiendo sobre servidores en local y tengo varias dudas (tengo varios post preguntando acerca de dudas sobre bind9, pero estas son más exactas ya que estoy aprendiendo), estoy usando bind9 en Ubuntu Server y mis dudas son:

1. Tengo mi servidor bind9 y funciona perfectamente en local, pero a la hora de salir a Internet para que me resuelvan un dominio no me funciona. ¿Qué es lo que tengo que hacer para que mi servidor resuelva dominos en local y a la vez le resuelvan al servidor dominos desde Internet?

2. En mi red tengo un equipo con Mint (192.168.1.142) y tiene como servidor dns el mio (192.168.1.141), además tiene como servidor secundario el servidor 1.1.1.1. Pero cuando en el equipo Mint busco por internet no me resuelven los dominios. ¿Se supone que si mi servidor DNS no resuelve el dominio que a pedido Mint, el equipo Mint pasaría a preguntarle al segundo servidor DNS?

3. ¿Para que el fichero resolv.conf? ¿Y porqué por defecto tiene la ip 127.0.0.53?


Para facilitaros la ayuda os pongo lo que tengo en estos archivos, con la configuración de estos archivos me funciona el servidor DNS en local, pero pedir la resolución de dominios a Internet no me funciona:

-Interfaces:

Código:
auto lo
iface lo inet loopback

auto ens33
iface ens33 inet static
address 192.168.1.141
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameserver 127.0.0.1
dns-search example.org

-resolv.conf:

Código:
nameserver 127.0.0.1

Si tengo algo mal configurado o tengo que añadir algo, por favor decírmelo y siento ser pesado con este tema pero me gustaría comprenderlo lo mejor posible ya que es mi primera vez con servidores. Muchas gracias por vuestra atención.
9  Sistemas Operativos / GNU/Linux / Re: Al reiniciar Ubuntu Server se pierde mis configuraciones en: 7 Octubre 2018, 19:51
Muchisimas gracias por tu respuesta!! Me lo as aclarado todo  :-*
10  Sistemas Operativos / GNU/Linux / Re: Ayuda con bind9 en Ubuntu Server en: 7 Octubre 2018, 15:38
Saludos,

- Jeje, condenado fichero de configuración  :xD.

- Si sigues las reglas no deberías de tener problemas, por ejemplo la sintaxis para las zonas reversas es:

Código:
zone "1.168.192.in-addr.arpa" {
 type master;
 file "/etc/bind/192.168.1.0.rev";
};

-- Ves que no se pone la "variable" (0. 142. 141. eso)

- Luego, en tu fichero "/etc/bind/192.168.1.0.rev", hay que corregir para que quede asi:

Código:
;
; BIND reverse data file for local loopback interface
;
$TTL 604800
@ IN SOA servidor.sergio.com. root.sergio.com. (
         1  ; Serial
    604800  ; Refresh
     86400  ; Retry
   2419200  ; Expire
    604800 ) ; Negative Cache TTL
;
1.168.192.in-addr.arpa.     IN NS  servidor.sergio.com.
141                         IN PTR servidor.sergio.com.
142                         IN PTR sergio-mint.sergio.com.

-- El @ hace referencia a la zona en sí, aunque también se puede usar 1.168.192.in-addr.arpa. como lo estoy usando en el IN NS

-- Luego las reversas se sobreentienden que son parte de la zona en claro: "192.168.1." que junta serian "192.168.1.141" y "192.168.1.142"

- Te recomiendo tener a mano esta guía muy completa y en español:
https://debian-handbook.info/download/es-ES/stable/debian-handbook.pdf

-- En la página 288 habla sobre la sistaxis del fichero de configuración para las zonas inversas.

Muchas gracias!! Ahora funciona perfectamente, ¿sergio.com   IN     NS    servidor.sergio.com, significa que ese dominio es de mi servidor que se llama servidor.sergio.com verdad? ¿Y con SOA heredas la configuración de un archivo no?
Páginas: [1] 2 3 4 5 6
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines