elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Como proteger una cartera - billetera de Bitcoin


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  Problema con LocalHost
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con LocalHost  (Leído 1,174 veces)
z3nth10n


Desconectado Desconectado

Mensajes: 1.584


"Jack of all trades, master of none." - Zenthion


Ver Perfil WWW
Problema con LocalHost
« en: 1 Marzo 2013, 20:51 pm »

Hola amigos, pues estoy haciendo pruebas en localhost... Darhius me está ayudando, pero como comprenderéis no puedo echarle todo el muerto a el  :silbar:
Así que bueno, a ver lo que pasa por aquí...

El problema es, el siguiente, yo me instalé Xampp, me puse los archivos de FTP en C:\Xampp\htdocs\ikillcraft y luego puse los archivos de SMF dentro de la misma carpeta. Puse http://localhost/ikillcraft/install.php tuve algunas complicaciones pero las resolví (cosa que no afecta a lo que voy a preguntar, porque eran cosas de MySQL y eso todavía no lo he tocado).

Una vez instalado, fui a http://localhost/ikillcraft/inicio.php, y tuve dos errores dentro de lo que es el content.php, quien me haya estado viendo mis pasos anteriores sabrá de lo que hablo.

Para quien no losepa el content.php es un archivo que llamo desde un include dentro de un div de un index.php general.

Bueno, pues cuando entré me salio este error:

Notice: Undefined index: action in C:\xampp\htdocs\ikillcraft\content.php on line 11

Código del archivo: http://pastebin.com/u1j1wjBw

Un saludo.


« Última modificación: 1 Marzo 2013, 20:53 pm por Seazoux » En línea


Interesados hablad por Discord.
#!drvy
Moderador
***
Desconectado Desconectado

Mensajes: 5.639



Ver Perfil WWW
Re: Problema con LocalHost
« Respuesta #1 en: 1 Marzo 2013, 21:02 pm »

Linea 11.. compruebas si $_POST['action'] es igual a checkdata pero no compruebas si esta definido o no... por eso salta.

Código
  1. if (!empty($_POST['action']) && $_POST['action'] == "checkdata") {


Saludos


En línea

z3nth10n


Desconectado Desconectado

Mensajes: 1.584


"Jack of all trades, master of none." - Zenthion


Ver Perfil WWW
Re: Problema con LocalHost
« Respuesta #2 en: 1 Marzo 2013, 21:06 pm »

Linea 11.. compruebas si $_POST['action'] es igual a checkdata pero no compruebas si esta definido o no... por eso salta.

Código
  1. if (!empty($_POST['action']) && $_POST['action'] == "checkdata") {


Saludos

Olé :P

Podría dejar este post para futuros problemas? :P

Tengo otro, como vereis tengo una imagen captcha.php, pero no la detecta...  :-\

Buscad por aquí:

Código
  1. <img src="captcha.php" width="100" height="30" vspace="3" /><br>

Claro, tomad el código, ayer no se en que estaba pensando, pero no lo puse: http://pastebin.com/m9pPTUz3

Un saludo.
« Última modificación: 2 Marzo 2013, 11:30 am por Seazoux » En línea


Interesados hablad por Discord.
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[Problema/consulta] Sobre el localhost
PHP
Gusan0r 2 1,392 Último mensaje 28 Marzo 2009, 00:13 am
por [u]nsigned
Problema PHP localhost
PHP
MrNapster 7 12,955 Último mensaje 10 Diciembre 2009, 18:45 pm
por [u]nsigned
Problema con el localhost
PHP
WiseHidden 4 3,325 Último mensaje 15 Marzo 2011, 15:59 pm
por Nakp
[Problema] Tengo una web que en localhost funciona barbaro, pero en un servid...
Desarrollo Web
astinx 2 3,190 Último mensaje 22 Diciembre 2011, 23:20 pm
por astinx
Localhost « 1 2 »
PHP
DickGumshoe 10 7,700 Último mensaje 31 Julio 2012, 09:00 am
por Durk
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines