elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: (TUTORIAL) Aprende a emular Sentinel Dongle By Yapis


+  Foro de elhacker.net
|-+  Comunicaciones
| |-+  Redes
| | |-+  Problemas con localhost (No existe)
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problemas con localhost (No existe)  (Leído 1,392 veces)
aitorEG

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Problemas con localhost (No existe)
« en: 2 Octubre 2017, 11:44 am »

Buenos dias,

Tengo un servidor con WIN2016 (no azure), en el cual he instalado Dynamics NAV. Puedo acceder al clliente web desde una maquina en remoto sin problema, pero el asunto paarece al tratar de instalar el ClickOnce para la aplicacion.
Cuando trato de ejecutar el instalador en una maquina remota, me aparce el siguiente mensaje de error:


Código:
ORÍGENES
Dirección URL de la implementación : file:///C:/Users/aitor/Desktop/Microsoft.Dynamics.Nav.Client.application
Dirección URL del proveedor de la implementación : http://**.**.**.**/NAV/Deployment/Microsoft.Dynamics.Nav.Client.application

RESUMEN DEL ERROR
Abajo se muestra un resumen de los errores; los detalles de estos errores se incluyen en el registro.
* La activación de C:\Users\aitor\Desktop\Microsoft.Dynamics.Nav.Client.application dio como resultado una excepción. Se detectaron los siguientes mensajes de error:
+ No se realizó la descarga de http://**.**.***.**/NAV/Deployment/Microsoft.Dynamics.Nav.Client.application correctamente.
+ No se puede resolver el nombre remoto: '**.**.***.**'

RESUMEN DE ERRORES DE TRANSACCIÓN DEL ALMACÉN DE COMPONENTES
No se detectó ningún error de transacción.

ADVERTENCIAS
* El manifiesto para esta aplicación no tiene signatura. Se ignorará la validación de signatura.

ESTADO DE PROGRESO DE LA OPERACIÓN
* [02/10/2017 11:37:49] : Se ha iniciado la activación de C:\Users\aitor\Desktop\Microsoft.Dynamics.Nav.Client.application.

DETALLES DEL ERROR
Se detectaron los siguientes errores durante esta operación.
* [02/10/2017 11:37:49] System.Deployment.Application.DeploymentDownloadException (subtipo desconocido)
- No se realizó la descarga de http://**.**.***.**/NAV/Deployment/Microsoft.Dynamics.Nav.Client.application correctamente.

Al tratar de abrir en el IIS del servidor la aplicacion contra la que ataca el instalador, me redirige a localhost, pero me sale el siguiente mensaje en el navegador.

Código:
Invalid URI: The URI is empty.
  Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

 Exception Details: System.UriFormatException: Invalid URI: The URI is empty.

Source Error:

Line 21: {
Line 22:   GetCustomSettings();
Line 23:   var uri = new Uri(customSettings.SelectSingleNode("//appSettings/add[@key='PublicWebBaseUrl']").Attributes["value"].Value);
Line 24:   return uri.Host;
Line 25: }
 
 Source File:  c:\inetpub\wwwroot\http\Default.aspx    Line:  23

Stack Trace:

[UriFormatException: Invalid URI: The URI is empty.]
   System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind) +8609869
   ASP.default_aspx.getHost() in c:\inetpub\wwwroot\http\Default.aspx:23
   ASP.default_aspx.getPowerBiUrl(Boolean unsecure) in c:\inetpub\wwwroot\http\Default.aspx:47
   ASP.default_aspx.__Render__control1(HtmlTextWriter __w, Control parameterContainer) in c:\inetpub\wwwroot\http\Default.aspx:243
   System.Web.UI.Control.RenderChildrenInternal(HtmlTextWriter writer, ICollection children) +114
   System.Web.UI.Page.Render(HtmlTextWriter writer) +39
   System.Web.UI.Control.RenderControlInternal(HtmlTextWriter writer, ControlAdapter adapter) +79
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +8817
 

Hago ping a localhost, asi como a 127.0.0.1 desde el interior del servidor, y funciona correctamente.
Ambos oproblemas peuden tener algo que ver? Estoy un poco perdido en este asunto...
Muchas gracias de antemano por la ayuda, un saludo




En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Sin acceso al localhost
PHP
Sunny_Sayantan 2 1,942 Último mensaje 25 Septiembre 2009, 15:23 pm
por :ohk<any>
problemas con localhost
GNU/Linux
miadagio 0 1,122 Último mensaje 29 Mayo 2010, 20:20 pm
por miadagio
Netmeeting todavia existe? existe algo parecido?
Windows
Venom-newbie 2 3,698 Último mensaje 8 Noviembre 2011, 17:29 pm
por MauroMasciar
Localhost « 1 2 »
PHP
DickGumshoe 10 8,255 Último mensaje 31 Julio 2012, 09:00 am
por Durk
¿Por qué no me abre localhost en IE? « 1 2 »
PHP
javirk 12 12,348 Último mensaje 28 Diciembre 2012, 16:32 pm
por RedPhoenix18
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines