elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Recopilación Tutoriales y Manuales Hacking, Seguridad, Privacidad, Hardware, etc


  Mostrar Mensajes
Páginas: 1 ... 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 [19] 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 ... 172
181  Programación / Programación General / Re: El Tao de la Programación en: 8 Noviembre 2011, 22:53 pm
Es bueno el libro aunque bastante "geek", la mayoría de las cosas que cuenta son ciertas.

Citar
¿Por qué los programadores son improductivos?
 Porque pierden su tiempo en reuniones.
 
 ¿Por qué los programadores son rebeldes?
 Porque la gestión interfiere mucho.
 
 ¿Por qué los programadores reniegan unos de otros?
 Porque están quemados.
 
 Después de haber trabajado para un mal gestor, ya no valoran sus empleos.


182  Informática / Hardware / Re: Instalar segundo disco duro en: 8 Noviembre 2011, 22:44 pm
Exacto, el cable número 5 es un S-ATA. Es lo que necesitas para conectar el otro disco duro.

Y tu placa base tiene S-ATA (los azules aunque en algunos casos son amarillos).


183  Programación / Scripting / Re: [Script]Bat dedicado a redes LAN en: 8 Noviembre 2011, 22:39 pm
Tienes que usar el comando "ping".

Un ejemplo muy básico sería éste:

Código
  1. @echo off
  2. FOR /F "tokens=*" %%I in (c:\list.txt) do call :pinger %%I goto :eof
  3. :pinger
  4. echo %TIME% >> ping.txt
  5. ping -n 1 %1 >> ping.txt
  6. :: DONE

En el fichero c:\list.txt están las IPs que quieres comprobar (una IP por línea).

El resultado del script se guarda en otro fichero de texto, llamado ping.txt.

En definitiva, con una simple línea podrías hacerlo:

Código
  1. for /f %%a in (ruta_fichero_con_ips) do (ping %%a)

184  Foros Generales / Dudas Generales / Re: ¿PAra que se usa la ip 0.0.0.0? ¿cual es su significado? en: 8 Noviembre 2011, 00:37 am
La IP 0.0.0.0 es cuando un nodo no está conectado a ninguna red TCP/IP. Por tanto no puede comunicarse con ningún otro nodo.

Dependiendo del contexto, con 0.0.0.0 también nos referimos a todas las IPs de una máquina. Por ejemplo, si configuramos el demonio de
Apache para que escuche conexiones/peticiones en la IP 0.0.0.0, responderá a todas las peticiones, da igual a que IP va dirigida o el interfaz (esto es cuando un
nodo tiene más de una IP).

La IP 127.0.0.1 se refiere a la propia máquina, aunque los dos conceptos se parezcan, son distintos.

185  Comunicaciones / Redes / Re: Que hacer despues de un ataque DoS en el servidor? en: 7 Noviembre 2011, 22:55 pm
De hecho en la clasificación de los ataques DoS se mencionan los daños físicos:

Citar
Existen tres tipos básicos de denegación de servicio:
  • Consumo de recursos.
  • Destrucción o alteración de la configuración.
  • Destrucción o alteración física de los equipos.


Y te lo puedo confirmar por experiencia propia, por ejemplo, tarjetas de red rotas por culpa del incremento de peticiones (ni siquiera era un DoS).

186  Sistemas Operativos / Windows / Re: [LAN] Compartir una web ? en: 7 Noviembre 2011, 22:46 pm
Necesitas tener un servidor web en el equipo desde el que quieres compartir la web.

Lo más normal es instalar Apache (o el paquete XAMPP). Si quieres usar nombres (en vez de IPs) para acceder al servidor
web, lo más sencillo es modificar el fichero hosts.

Otra posibilidad es compartir una carpeta donde esté almacenada la web, el cliente accede a tu carpeta compartida y abre la web
en su navegador. Ojo: esto sólo funciona con web estáticas (html, css, js).


187  Comunicaciones / Redes / Re: Que hacer despues de un ataque DoS en el servidor? en: 7 Noviembre 2011, 22:40 pm
Pueden varias, aunque normalmente los discos duros son los primeros que se dañan (en un foro no muy amigo a éste, cómo consecuencia
de un ataque DoS, se rompió el disco duro debido al número de peticiones).


188  Comunicaciones / Redes / Re: Problemas con internet con 170 usuarios en: 7 Noviembre 2011, 21:29 pm
Deberías tener también un sistema de monitorización, de esta forma sabrás quien está haciendo mal uso del
ancho de banda. Sobre esto se ha hablado varias veces en este subforo, una posible solución es Cacti. Los usuarios que
descargan cosas, siempre suelen ser los mismos.

Con Mikrotik, también puedes aplicar una limitación por tamaño paquetes, sería algo así:

/ip firewall mangle
add action=mark-packet chain=prerouting comment=30M~ connection-bytes=30720001-0 disabled=no in-interface=WAN new-packet-mark=www_in_30M passthrough=no protocol=tcp src-port=80

/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=1M name=www_down_30M-~ packet-mark=www_in_30M parent=global-in priority=8 queue=default


Aunque, primero te recomendaría monitorizar la red en busca de cuellos de botella o usuarios "conflictivos". Tanto Cacti cómo Nagios te sirven.


Si al final te decides por limitar el tamaño de los paquetes, echa primero un vistazo a estos enlaces:

_Limitar Trafico Transparentemente con Mikrotik.
_Limitando p2p con Mikrotik.

Un suplemento todo esto podría ser la utilización de OpenDNS para empresas, filtra por defecto muchas páginas de descarga, sitios maliciosos y con
la opción "Business" puedes personalizar la lista de sitios.

 
189  Programación / Java / Re: Ejercicios prácticos Java en: 7 Noviembre 2011, 15:41 pm
Una posible solución:

Código
  1. package HojaEjercicios1;
  2. import java.io.*;
  3.  
  4. /**
  5.  *
  6.  * @author madpitbull
  7.  */
  8. public class Ejer10 {
  9.    public static void main (String args[]) throws IOException {
  10.  
  11.        BufferedReader in = new BufferedReader(new InputStreamReader(System.in));
  12.        System.out.print("Introduce un número: ");
  13.        int lim = Integer.parseInt(in.readLine());
  14.  
  15.  
  16.        if (lim > 0) {
  17.            for (int i=1; i<=lim; i++) {
  18.                int x;
  19.                for (x=2; x<=i; x++) {
  20.                   if (i%x == 0) {
  21.                       break;
  22.                   }
  23.                }
  24.                if (i == x) {
  25.                   System.out.print(" " + i + " ");
  26.                }
  27.            }
  28.  
  29.  
  30.        }else
  31.            System.out.println("[Error] Número no válido.");
  32.  
  33.  
  34.  
  35.    }
  36. }
  37.  

Otra alternativa es hacerlo usando una variable boolean. Puedes usar el mismo ejemplo,
sólo tendrás que cambiar el estado de la variable dentro del if que comprueba si el número es primo.

190  Seguridad Informática / Hacking Wireless / Re: Conseguir Ips en una red lan en: 6 Noviembre 2011, 21:27 pm
Con algún programa como AngryIP Scanner, puedes ver las IP activas de tu red.

También puedes hacer tu propio script, ya sea en Batch u otro lenguaje.

Páginas: 1 ... 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 [19] 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 ... 172
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines