elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a Git (Primera Parte)


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  [Solucionado] funcion de clase no imprime datos de la db
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [Solucionado] funcion de clase no imprime datos de la db  (Leído 1,460 veces)
gAb1


Desconectado Desconectado

Mensajes: 731


Ver Perfil
[Solucionado] funcion de clase no imprime datos de la db
« en: 26 Marzo 2016, 16:15 pm »

Hola, me ha pasado algo realmente raro y no consigo encontrar el problema.

Tengo una clase para los usuarios de una web, en esta clase tengo una funcion que devuelve el valor de una de las columnas de la tabla. Al principio todo funcionaba, pero tuve que añadir más columnas a la tabla y cambiar el nombre de un par de ellas, desde entonces hay una de las funciones (una de las dos a las que les tuve que cambiar el nombre) que no devuelve nada, las demás si que funcionan.

He comprobado varias veces por si fuera un error al escribir el nombre, pero todo parece estar en orden.

He grabado un video donde se puede ve claramente el código y el formulario donde se llama dicha función que debería imprimir el contenido de la columna pero nada...


« Última modificación: 26 Marzo 2016, 18:36 pm por gAb1 » En línea

xiruko


Desconectado Desconectado

Mensajes: 437


Ver Perfil
Re: funcion de clase no imprime datos de la db
« Respuesta #1 en: 26 Marzo 2016, 17:54 pm »

Hola,

Añade el código del formulario y de la función por favor, así como el trozo de código donde procesas el formulario y llamas a esta función. De esta manera será más fácil analizarlo. No sé si seré solo yo, pero mirar esto en un video es algo engorroso...

Saludos!


En línea

gAb1


Desconectado Desconectado

Mensajes: 731


Ver Perfil
Re: funcion de clase no imprime datos de la db
« Respuesta #2 en: 26 Marzo 2016, 18:08 pm »

Vale ya encontré el fallo  :P

Que vergüenza... el copia pega  :silbar:

Código
  1.    public function setPersonalPhone($personal_phone) {
  2.        $this->phone = $personal_phone;
  3.    }

Código
  1.    public function setPersonalPhone($personal_phone) {
  2.        $this->personal_phone = $personal_phone;
  3.    }
« Última modificación: 26 Marzo 2016, 18:31 pm por gAb1 » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines