elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: (TUTORIAL) Aprende a emular Sentinel Dongle By Yapis


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  Problema con PHPMailer
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con PHPMailer  (Leído 3,563 veces)
marko1985

Desconectado Desconectado

Mensajes: 46


Ver Perfil
Problema con PHPMailer
« en: 29 Marzo 2010, 17:15 pm »

Buenas tardes a todos, le estoy dando vueltas, buscando por foros y demás y no encuentro una respuesta concreta.

Alla va... El tema es que yo estoy creando un editor de mails online para, y para enviarlos quiero utilizar la librería PHPMailer v.5.1. , cuando configuro el correo con el siguiente código:


Código
  1. <?php
  2. //INCLUIMOS LIBRERIAS
  3. include("PHPMailer_v5.1/class.phpmailer.php");
  4. include("PHPMailer_v5.1/class.smtp.php");
  5.  
  6. //CONFIGURACION DEL ENVIO
  7. $envio=new PHPMailer();
  8. $envio->Mailer="smtp";
  9. $envio->Host="smtp.MISERVIDOR.com";
  10. $envio->From="MI MAIL";
  11. $envio->FromName="MI NOMBRE";
  12. $envio->AddAddress="MAIL DEL DESTINATARIO";
  13. $envio->Timeout=40;
  14. $envio->Subject="Prueba del PROGRAMA";
  15. $envio->AltBody = "Mensaje del Editor de MAILS , esto sólo es una prueba con texto.";
  16. //FIN DE CONFIGURACION
  17.  
  18. //COMPROBAMOS EL ESTADO
  19. $correcto=$envio->Send();
  20.  
  21. $reenvio=1;
  22.   while ((!$correcto) && ($reenvio < 5)) {
  23. sleep(7);
  24.            echo $mail->ErrorInfo;
  25.            $correcto = $envio->Send();
  26.            $reenvio=$reenvio+1;
  27.        }
  28.  
  29. if(!$correcto){
  30. echo "Problema enviando e-mail a ".$lista;
  31. echo "<br/>".$envio->ErrorInfo;
  32. }
  33. else{
  34. echo "Mensaje enviado correctamente";
  35. }    
  36. ?>


No me envía el mail, simplemente despues de pasar por el While, se mete en el if, y ya que la función Send() nunca me devuelve TRUE.

¿¿Teneis alguna sugerencia?? Tambien he mirado de configurar el PHP.ini, o el httpd.conf de Apache. ¿Podría ser tema de puertos del Router? ¿El timeout se queda corto?
 
La librería PHPMailer se puede encontrar en la siguiente dirección.
http://phpmailer.worxware.com/
Mi versión es la 5.1.
Cualquier dato adicional, me lo podeis pedir. Saludos.


En línea

KrossPock

Desconectado Desconectado

Mensajes: 208



Ver Perfil
Re: Problema con PHPMailer
« Respuesta #1 en: 29 Marzo 2010, 17:51 pm »

Este tema deberia ser movido a php....


En línea


Syphroot

Desconectado Desconectado

Mensajes: 268


All You Need To Do Is Follow The Worms


Ver Perfil WWW
Re: Problema con PHPMailer
« Respuesta #2 en: 31 Marzo 2010, 07:59 am »

No te faltan los destinatarios?????? o me pierdo de algo en tu código '?  :huh:  :silbar:

Si le quitas el while y lo envias una sóla vez te funciona??? Debería... a menos que esten mal los datos de conexión al server
« Última modificación: 31 Marzo 2010, 08:02 am por Syphroot » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
ayuda phpmailer
PHP
kakashi20 1 1,264 Último mensaje 4 Febrero 2011, 17:45 pm
por Nakp
No ve funciona el phpmailer!
PHP
elpirata15hd 3 2,823 Último mensaje 29 Abril 2011, 00:00 am
por elpirata15hd
Archivo adjunto en PHPMailer
PHP
sexto 2 3,290 Último mensaje 27 Enero 2012, 13:46 pm
por sexto
Enviar contenido PHPmailer
PHP
nahub96 0 812 Último mensaje 23 Marzo 2015, 18:42 pm
por nahub96
Problema con phpmailer
PHP
yoelrodguez 2 1,127 Último mensaje 2 Abril 2016, 17:10 pm
por yoelrodguez
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines