elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Los 10 CVE más críticos (peligrosos) de 2020


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  problema instalando gnome en arch linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: 1 [2] Ir Abajo Respuesta Imprimir
Autor Tema: problema instalando gnome en arch linux  (Leído 7,555 veces)
luinuz

Desconectado Desconectado

Mensajes: 239


Ver Perfil WWW
Re: problema instalando gnome en arch linux
« Respuesta #10 en: 13 Junio 2010, 13:06 pm »

Tenias puesto el gdm en el inittab y en los daemons? si lo tenias en los dos sitios seguramente el error fuera ese, con que lo tengas en los daemons basta. Si lo pones en los dos sitios es muy posible que gdm intentara arrancar dos veces, las dos ejecuciones entraran en conflicto; cada una ocupando unos recursos diferentes, por eso el gdm no te aparecia completo y veias el mensaje
Citar
gdm-binary[1723]: WARNING: could not set display org.gnome.DisplayManager: Display lasted 0.0341245 seconds

Tu log sigue sin mostrar problemas, ademas si me dices que gnome puedes arrancarlo con startx quiere decir que xorg funciona perfectamente. Esto corrobora aun mas el hecho que fuera un error con el gdm.

Si te va bien con ese xorg.conf sigue usando ese.

Espero que te haya servido la ayuda.

Saludos.


« Última modificación: 13 Junio 2010, 13:09 pm por luinuz » En línea

rastanthology

Desconectado Desconectado

Mensajes: 130


Ver Perfil
Re: problema instalando gnome en arch linux
« Respuesta #11 en: 13 Junio 2010, 21:19 pm »

gracias luinuz, sin tu ayuda no hubiese llegado a probar tantas cosas.

lo tenia puesto dos veces al gdm, igual probe no ponerlo, probe poner uno y no el otro y al revez y con todos anda exactamente igual.

Si lo arranco el daemon o arranco desde el inittab me arranca el login sin campos y aunque haga startx desde otra consola no me arranca el escritorio y sigue mostrando el mismo error  :-\

tambien probe poner el xorg.conf generado por arch y el tuyo y segui el mismo procedimiento y x no arrancaba, puede ser que los archivos que llama el modulo "Files" esten corruptos/ anden mal o algo?

si instalo el kdm y el xdm puede que haga alguna diferencia arrancar alguno de ellos como gestor de login? hay que configurarlos para que arranquen gnome en vez de sus respectivos escritorios?

en mis repos los paquetes kdm y xdm no estan, los mas parecidos que hay son:

xdm-archilinux
xorg-xdm
archlinux-themes-kdm  (el unico que incluye el nombre kdm :-\)

Saludos y gracias!!


En línea

luinuz

Desconectado Desconectado

Mensajes: 239


Ver Perfil WWW
Re: problema instalando gnome en arch linux
« Respuesta #12 en: 13 Junio 2010, 21:45 pm »

Citar
puede ser que los archivos que llama el modulo "Files" esten corruptos/ anden mal o algo?
Improbable, si no en el Xorg.0.log hubiera aparecido un error relacionado con eso, y tampoco hubieras conseguido hacerlo funcionar como ahora.

Citar
si instalo el kdm y el xdm puede que haga alguna diferencia arrancar alguno de ellos como gestor de login? hay que configurarlos para que arranquen gnome en vez de sus respectivos escritorios?
No hace falta configurarlos (por lo menos yo nunca lo he necesitado), detectaran los escritorios que esten instalados y te mostraran un menu donde tu puedas escojer cual quieres arrancar. Creo que tambien podras indicarles el que quieres que arranque por defecto.

Citar
en mis repos los paquetes kdm y xdm no estan
Ya, no te preocupes. El kdm creo que esta incluido en kdebase o alguno de los paquetes relacionados con kde. Esto es asi no por decision de la gente de Arch si no por que la gente de kde decidio empaquetarlo asi.
El xdm creo que esta en el paquete xorg-xdm pero no te lo puedo asegurar.

Otra cosa te voy a comentar, por que no pruebas a usar el paquete gdm-old del repositorio AUR?
Yo es el que uso, mas que nada por que esa version antigua de gdm te deja ponerle muchos temas de gnome-look.org. Quien sabe, a lo mejor esa version de gdm te va bien.
Para instalar el gdm-old antes desinstala gdm.

Siento mucho que no hayamos podido descubrir que le picaba. Lo que haria en tu lugar; esperaria a que sacaran una actualizacion del driver de intel y/o del servidor xorg y volveria a probar. Si depues de una actualizacion consigues ejecutar correctamente el gdm, querra decir que el fallo venia dado por un bug.

Consejillo: no es necesario que toques inittab; Arch tiene centralizada toda la configuracion del sistema en el rc.conf. Habituate a meter los daemons, modulos, configuracion de red, etc... que necesites ahi, luego acaba resultando todo mucho mas comodo.

Saludos.


EDITO
Se me olvidaba, por que no haces otra prueba intentando arracar gdm y pones lo que te saca el archivo ~/.xsession-errors? Estaria bien verlo.


« Última modificación: 13 Junio 2010, 22:07 pm por luinuz » En línea

rastanthology

Desconectado Desconectado

Mensajes: 130


Ver Perfil
Re: problema instalando gnome en arch linux
« Respuesta #13 en: 13 Junio 2010, 22:11 pm »

muchas gracias denuevo luinuz, la verdad que aprendi un monton en estos 2 dias y no hubiese podido encontrar la solucion de no ser por vos y google :P

bueno entre tantas pruebas y googleadas lo que soluciono el problema fue agregar a /etc/rc.local

esta linea:

/usr/sbin/console-kit-daemon

y a mi archivo ~/.xinitrc en vez de que diga exec gnome-session ahora dice

exec ck-launch-session gnome-session

despues de eso hice un killall Xorg y arranco correctamente con mi usuario en las opciones  ;D

al parecer el bug puede llegar a ser del consolekit, del hal, dbus o no se, hablaban de todos esos daemons en el foro, estos 3 links contenian la solucion/el problema:

http://bbs.archlinux.org/viewtopic.php?pid=723809
http://bbs.archlinux.org/viewtopic.php?id=87137
http://bbs.archlinux.org/viewtopic.php?id=87123

aunque los paquetes que yo tengo esten mas actualizados funciono igual


bueno ahora me puedo loguear, me falta pulir un par de cosas y va para adelante

Saludos
En línea

luinuz

Desconectado Desconectado

Mensajes: 239


Ver Perfil WWW
Re: problema instalando gnome en arch linux
« Respuesta #14 en: 13 Junio 2010, 22:25 pm »

Segun lo que me contabas, y sin que xorg o alguna otra cosa informara de errores, tenia la pinta de bug.
Me alegro haberte servido de ayuda. Gracias por comentarme como lo solucionastes.

Saludos.
En línea

Páginas: 1 [2] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines