elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: ¿Eres nuevo? ¿Tienes dudas acerca del funcionamiento de la comunidad? Lee las Reglas Generales


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Instalar este programa y no tengo ni idea en Linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 3 Ir Abajo Respuesta Imprimir
Autor Tema: Instalar este programa y no tengo ni idea en Linux  (Leído 7,968 veces)
Meta


Desconectado Desconectado

Mensajes: 3.279



Ver Perfil WWW
Instalar este programa y no tengo ni idea en Linux
« en: 1 Diciembre 2016, 12:20 pm »

Hola:

Quiero cambiar este programa encontrado en este enlace.
https://github.com/fbriere/linux-dexdrive

Aquí abajo te lo explica, aún así no tengo ni idea. Por lo que se ve, este programa funciona solo en modo consola.
https://github.com/fbriere/linux-dexdrive/blob/master/README

¿Alguna ayudita?

Yo de Linux muy poco, por algo se empieza.

Saludos.

PD: ¿Ya no hay intensión de sacar más versiones de openSUSE en el futuro?
Todavía siguen con lamisma versión 42.1


En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
MinusFour
Moderador Global
***
Conectado Conectado

Mensajes: 5.213


I'm fourth.


Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #1 en: 1 Diciembre 2016, 17:42 pm »

Solo tienes que hacer make install:

Código
  1. $ sudo make install

Vas a necesitar las cabeceras del kernel. No se como se instalen en openSUSE.


En línea

Meta


Desconectado Desconectado

Mensajes: 3.279



Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #2 en: 1 Diciembre 2016, 17:53 pm »

Hola:

He intentado hacerlo como dices, me da error indicado abajo.


Aquí hay una guía pero no entiendo ni papa.
http://www.forosuse.org/forosuse/showthread.php?t=32339

¿Alguna sugerencia?

Saludos.
En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
engel lex
Moderador Global
***
Desconectado Desconectado

Mensajes: 15.497



Ver Perfil
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #3 en: 1 Diciembre 2016, 17:59 pm »

tampoco recuerdo como es en suse, pero tienes que instalar por lo menos build-essential que son los programas basicos para compilar ("cc not found" no tiene compilador de c por la sintaxis que veo)
En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
Meta


Desconectado Desconectado

Mensajes: 3.279



Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #4 en: 1 Diciembre 2016, 20:54 pm »

Usé esto:
Código
  1. sudo zypper install patterns-openSUSE-devel_basis kernel-devel
  2. sudo zypper install kernel-`uname -r | cut -d "-" -f 3`-devel  

Luego.
Citar
Verifica que los kernels instalados sea de la MISMA VERSIÓN, lo puedes ver con el comando de abajo:
zypper search -si kernel | grep `uname -r | cut -d "-" -f -2`

Se ha instaladoy hice lo que indica abajo.

Citar
Si son librerías entonces es necesario instalar también los fuentes de dichas librerías, instala los paquetes que termina en -devel de la librería solicitada. Por ejemplo, pide instalar la librería gtk, entonces, también, el paquete a instalar es el llamado gtk-devel donde contiene sus fuentes


Hice el truco del make install y muestra la imagen de abajo.


Sigo por aquí abajo.


¿Alguna idea?

Saludos.
« Última modificación: 1 Diciembre 2016, 22:35 pm por Meta » En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
MinusFour
Moderador Global
***
Conectado Conectado

Mensajes: 5.213


I'm fourth.


Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #5 en: 2 Diciembre 2016, 02:17 am »

Uhm, yo creo que sigues teniendo problemas con las cabeceras del kernel. Por otro lado, hay algo en /usr/src/linux, ¿Pero es probable que no sean las cabeceras?

Revisa en /lib/modules tienes carpetas (o en /usr/lib/modules, en mi sistema /lib es un symlink de /usr/lib, pero no se en tu sistema).
En línea

Meta


Desconectado Desconectado

Mensajes: 3.279



Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #6 en: 2 Diciembre 2016, 10:18 am »

Hola:

En usr/src/linux.


Creo que es este, lib/modules.


Dentro de la carpteta 4.1.34-33-default se encuentra esto y lopongoen modo consola o shell:


Espero que te diga algo.

Saludos.
En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
MinusFour
Moderador Global
***
Conectado Conectado

Mensajes: 5.213


I'm fourth.


Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #7 en: 2 Diciembre 2016, 16:05 pm »

Cuando hiciste `uname -a` en las entradas anteriores, el sistema te dice que tienes un kernel con 4.1.12. Pero las fuentes que veo ahí son de 4.1.34. Lo más probable es que te hayas bajado las cabeceras del último kernel y no del kernel que tienes (4.1.12).

El paquete que instalaste `kernel-default-devel` basicamente apunta a:
Código:
kernel-default-devel-4.1.34-33.1.x86_x64

Quizás puedas simplemente hacer:

Código
  1. sudo zypper install kernel-default-devel-4.1.12-1

Y quizás esto instalara las cabeceras para tu kernel en especifico. La otra opción que puedes hacer es simplemente actualizar tu sistema (porque el kernel por defecto de momento es 4.1.34 y tu estas en 4.1.12).
En línea

Meta


Desconectado Desconectado

Mensajes: 3.279



Ver Perfil WWW
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #8 en: 2 Diciembre 2016, 21:52 pm »

Hola:

Te leí tarde.
El make y make install no me funcionaba ni a la de tres en el openSuse 42.1.

En el shell me sale esto. Acabo de instalar otra vez openSUSE 42.2.
meta@linux-2rqd:~> uname -r
4.4.27
-2-default
meta@linux-2rqd:~> 


Le puse s como un campeón. Salió esta imagen.


make en el directorio del controlador  del dexdrive.


make install da error.


Hasta aquí me quedé.

Gracias por tu ayudar mucho.
En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
engel lex
Moderador Global
***
Desconectado Desconectado

Mensajes: 15.497



Ver Perfil
Re: Instalar este programa y no tengo ni idea en Linux
« Respuesta #9 en: 2 Diciembre 2016, 22:02 pm »

normalmente los install se hacen con sudo porque requieren permisos
En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
Páginas: [1] 2 3 Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines