elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: AIO elhacker.NET 2021 Compilación herramientas análisis y desinfección malware


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Debian 4: Problemas de dependencias apt-get
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Debian 4: Problemas de dependencias apt-get  (Leído 2,761 veces)
Schaiden

Desconectado Desconectado

Mensajes: 97



Ver Perfil
Debian 4: Problemas de dependencias apt-get
« en: 2 Julio 2017, 05:54 am »

Que tal! Resulta que quería instalar metasploit en mi Debian 4.

Código
  1. cat /etc/issue
  2. Debian GNU/Linux 4.0 \n \l
  3.  
  4. uname -r
  5. 2.6.18-6-486
  6.  

Estaba siguiendo los pasos de éste enlace: https://fity666.wordpress.com/about/
que decía:

Citar
Lo primero sera instalar las dependencias de ruby las cuales son esenciales para su instalación

sudo apt-get install ruby libruby rdoc
sudo apt-get install libyaml-ruby
sudo apt-get install libzlib-ruby
sudo apt-get install libopenssl-ruby
sudo apt-get install libdl-ruby
sudo apt-get install libreadline-ruby
sudo apt-get install libiconv-ruby
sudo apt-get install rubygems *

apt-get install libgtk2-ruby libglade2-ruby

El paso siguiente es descargar metasploit desde su sitio oficial

http://www.metasploit.com/framework/download/

Cuanto empiezo por el primer comando:

Citar
apt-get install ruby libruby rdoc

Obtengo ésta salida:

Citar
apt-get install ruby libruby rdoc
Reading package lists...
Building dependency tree...
Reading state information...
ruby is already the newest version.
libruby is already the newest version.
rdoc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up cupsys-client (1.2.7-4+etch9) ...
Adding group `lpadmin' (GID 110) ...
groupadd: unable to lock group file
addgroup: `/usr/sbin/groupadd -g 110 lpadmin' returned error code 10. Exiting.
dpkg: error processing cupsys-client (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cupsys-bsd:
 cupsys-bsd depends on cupsys-client (= 1.2.7-4+etch9); however:
  Package cupsys-client is not configured yet.
dpkg: error processing cupsys-bsd (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 cupsys-client
 cupsys-bsd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Como ven, los paquetes de ruby que necesito para instalar metasploit no se pudieron instalar como corresponde. Tengo muchos problemas con el apt-get. Mi sources.list contiene lo siguiente:

Citar

Ya hice un apt-get update, y luego probé también apt-get upgrade y aquí obtengo problemas parecidos al que compartí aquí arriba...

Me gustaría que me dieran alguna idea para resolver mi problema. Si necesitan algo más de información, avisenme. Saludos y gracias!



En línea

engel lex
Moderador Global
***
Desconectado Desconectado

Mensajes: 15.514



Ver Perfil
Re: Debian 4: Problemas de dependencias apt-get
« Respuesta #1 en: 2 Julio 2017, 07:02 am »

le atribuiré el problema a que tienes un OS con 10 años de antigüedad y no es compatible con algún paquete... actualmente vamos por el 9

igual a los sources colocales no solo "etch main" sino "etch main contrib non-free"


En línea

El problema con la sociedad actualmente radica en que todos creen que tienen el derecho de tener una opinión, y que esa opinión sea validada por todos, cuando lo correcto es que todos tengan derecho a una opinión, siempre y cuando esa opinión pueda ser ignorada, cuestionada, e incluso ser sujeta a burla, particularmente cuando no tiene sentido alguno.
MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.463


I'm fourth.


Ver Perfil WWW
Re: Debian 4: Problemas de dependencias apt-get
« Respuesta #2 en: 2 Julio 2017, 19:23 pm »

Los paquetes están instalados:

Citar
ruby is already the newest version.
libruby is already the newest version.
rdoc is already the newest version.

El error es un paquete que todavia no termina de instalarse bien una dependencia de cupsys. No puede crear un grupo necesario por alguna razón.

De todas formas, debian etch es viejisimo, es del 2007.
En línea

Schaiden

Desconectado Desconectado

Mensajes: 97



Ver Perfil
Re: Debian 4: Problemas de dependencias apt-get
« Respuesta #3 en: 2 Julio 2017, 23:59 pm »

Buenas! Muchas gracias. Al final esa parte del problema la resolví agregando manualmente al usuario/grupo lpadmin en /etc/passwd, /etc/group y /etc/shadow. Luego los 2 paquetes se pudieron instalar satisfactoriamente... Luego quise instalar otras cosas necesarias, empezando x build-essential por ejemplo, y ahí si tenía otros errores de dependencias pero ahora estoy utilizando aptitude en lugar de apt-get y me parece que ahora si voy a poder instalar todo lo que necesito. Si surge algo actualizo éste mensaje. Saludos y gracias nuevamente
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problemas de dependencias...
GNU/Linux
do-while 3 4,552 Último mensaje 15 Febrero 2011, 14:52 pm
por do-while
Dependencias de los paquetes de cdrom debian rotas
GNU/Linux
lucaslopez0000 0 1,091 Último mensaje 13 Mayo 2013, 19:01 pm
por lucaslopez0000
problemas con las dependencias de los paquetes
GNU/Linux
ccrunch 2 1,515 Último mensaje 26 Julio 2013, 21:14 pm
por ccrunch
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines