elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Los 10 CVE más críticos (peligrosos) de 2020


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Problemas de dependencias...
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problemas de dependencias...  (Leído 4,579 veces)
do-while


Desconectado Desconectado

Mensajes: 1.276


¿Habra que sacarla de paseo?


Ver Perfil
Problemas de dependencias...
« en: 15 Febrero 2011, 06:42 am »

¡Buenas!

Estoy intentando instalar Code::Blocks en gNewSense. Despues de descargar el package (no se me ocurre ninguna traduccion, ando espeso) correspondiente a debian (gNewSense esta basado en Ubuntu y usa paquetes .deb (por si a caso)),

Despues de extraer los ficheros, accedo mediante el terminal al directorio en el en el que  los he extraido y ejecuto

sudo dpkg -i *.deb 2> unfichero

para recoger los errores en un fichero. El resultado es el siguiente

Código:
dpkg: problemas de dependencias impiden la configuración de codeblocks:
 codeblocks depende de libwxbase2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxbase2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
 codeblocks depende de libwxgtk2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxgtk2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
dpkg: error al procesar codeblocks (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de codeblocks-contrib:
 codeblocks-contrib depende de libwxbase2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxbase2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
 codeblocks-contrib depende de libwxgtk2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxgtk2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
 codeblocks-contrib depende de codeblocks (= 10.05-1); sin embargo:
 El paquete `codeblocks' no está configurado todavía.
dpkg: error al procesar codeblocks-contrib (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libcodeblocks0:
 libcodeblocks0 depende de libwxbase2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxbase2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
 libcodeblocks0 depende de libwxgtk2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxgtk2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
dpkg: error al procesar libcodeblocks0 (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libwxsmithlib0:
 libwxsmithlib0 depende de libcodeblocks0 (= 10.05-1); sin embargo:
 El paquete `libcodeblocks0' no está configurado todavía.
 libwxsmithlib0 depende de libwxbase2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxbase2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
 libwxsmithlib0 depende de libwxgtk2.8-0 (>= 2.8.10.1); sin embargo:
  La versión de `libwxgtk2.8-0' en el sistema es 2.8.7.1-0ubuntu3.
dpkg: error al procesar libwxsmithlib0 (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de wxsmith-dev:
 wxsmith-dev depende de libcodeblocks0 (= 10.05-1); sin embargo:
 El paquete `libcodeblocks0' no está configurado todavía.
dpkg: error al procesar wxsmith-dev (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de codeblocks-dev:
 codeblocks-dev depende de libcodeblocks0 (= 10.05-1); sin embargo:
 El paquete `libcodeblocks0' no está configurado todavía.
dpkg: error al procesar codeblocks-dev (--install):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libwxsmithlib0-dev:
 libwxsmithlib0-dev depende de wxsmith-dev (= 10.05-1); sin embargo:
 El paquete `wxsmith-dev' no está configurado todavía.
dpkg: error al procesar libwxsmithlib0-dev (--install):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 codeblocks
 codeblocks-contrib
 libcodeblocks0
 libwxsmithlib0
 wxsmith-dev
 codeblocks-dev
 libwxsmithlib0-dev

Lo que observo es que al parecer hace falta actualizar unos cuantos paquetes (ya me ha salido el palabro) o ficheros, pero antes de intentar instalar codeblocks he realizado un update y un dist-upgrade.

Una ultima informacion. Tengo instalado codeblocks en Ubuntu y no he tenido ningun problema (venia en el repositorio)

¿Puedo forzar la actualizacion de los paquetes anticuados aunque no se pueda hacer con apt-get update + apt-get dist-upgrade?

Y sobre todo, ¿que herramientas (comandos) me hace falta conocer para poder instalar paquetes que no esten en los repositorios de Debian, Ubuntu, gNewSense u otra distribucion basada en Debian?

¡Un saludo y perdon por las molestias!

PD: Si hace falta mas informacion o informacion mas especifica avisas.

¡Saludos de nuevo!


« Última modificación: 15 Febrero 2011, 06:59 am por do-while » En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
Diabliyo


Desconectado Desconectado

Mensajes: 1.441


shell# _


Ver Perfil WWW
Re: Problemas de dependencias...
« Respuesta #1 en: 15 Febrero 2011, 07:13 am »

Prueba esto en la consola:

Código:
perl -MCPAN -e'CPAN::Shell->install("Code::Blocks")'


En línea

leogtz
. . .. ... ..... ........ ............. .....................
Colaborador
***
Desconectado Desconectado

Mensajes: 3.069


/^$/


Ver Perfil WWW
Re: Problemas de dependencias...
« Respuesta #2 en: 15 Febrero 2011, 07:18 am »

Cuando no estén en los repositorios, tendrás que descargar el código fuente, leer los archivos de instalación y proceder normalmente.

Recuerdo que también tuve problemas con codeblocks en ubuntu, pero bueno, lo resolví instalando lo que me pedía.
En línea

Código
  1. (( 1 / 0 )) &> /dev/null || {
  2. echo -e "stderrrrrrrrrrrrrrrrrrr";
  3. }
  4.  
http://leonardogtzr.wordpress.com/
leogutierrezramirez@gmail.com
do-while


Desconectado Desconectado

Mensajes: 1.276


¿Habra que sacarla de paseo?


Ver Perfil
Re: Problemas de dependencias...
« Respuesta #3 en: 15 Febrero 2011, 14:52 pm »

¡Muchas gracias!

Probare primero compilando.

¡Saludos!
En línea

- Doctor, confundo los números y los colores.
- Vaya marrón.
- ¿Marrón? ¡Por el culo te la hinco!
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
problemas con las dependencias de los paquetes
GNU/Linux
ccrunch 2 1,542 Último mensaje 26 Julio 2013, 21:14 pm
por ccrunch
Debian 4: Problemas de dependencias apt-get
GNU/Linux
Schaiden 3 2,790 Último mensaje 2 Julio 2017, 23:59 pm
por Schaiden
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines