elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: AIO elhacker.NET 2021 Compilación herramientas análisis y desinfección malware


+  Foro de elhacker.net
|-+  Informática
| |-+  Electrónica
| | |-+  Problema en mi programa (PIC)
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema en mi programa (PIC)  (Leído 3,453 veces)
laluchi

Desconectado Desconectado

Mensajes: 11


Ver Perfil
Problema en mi programa (PIC)
« en: 24 Octubre 2008, 02:03 am »

Hola!
Estoy con un proyecto y utilizo un PIC 16F627A.
Necesito usar 10 entradas y 3 salidas.
Pero el programa por alguna razon no me funciona cuando seteo 12 entradas y 4 salidas. Por el contrario el programa SI funciona cuando pongo 8 entradas y 8 salidas.
Aca les paso el comienzo de los dos programas. El primero anda Perfecto, pero el segundo no funciona. Y lo unico que cambio es lo que se ve distinto.

;CON ESTE COMIENZO EL PROGRAMA que ANDA BIEN
         org     0x00
INI:   
         CLRF 0x05;
         MOVLW   0x07;
         MOVWF 0x1F;
         BCF 0x03,6;
         bsf 0x03,5;
      movlw   0x00      ;0000 0000 en w
         movwf   0x05      ;Port A Salida
      movlw   0xFF      ;0000 0000 en w
         movwf   0x06      ;Port B entrada
     bcf     0x03,5    ;a banco 0
    movlw   0x00      ;0000 0000 en w
         movwf   0x05      ;inicializo portA todo en 0
         bcf     0x05,0    ;inicializo RA0 en 0
         bsf     0x05,3         ; RA3 en 1     
         bsf     0x05,2         ; RA2 en 1
         bsf     0x05,1         ; RA1 en 1     
COMIENZO:

.................................................
ahora publico el comienzo del programa que no funciona correctamente:

;aca comienza el prog q anda mal
         org     0x00
INI:   
         CLRF    0x05;
         MOVLW   0x07;
         MOVWF   0x1F;
         BCF     0x03,6;
         bsf     0x03,5;
      movlw   0x0F      ;0000 1111 en w
         movwf   0x05      ;Pongo RA0-RA3 a salidas
                           ; RA4-RA7 entradas
      movlw   0xFF      ;1111 1111 en w
         movwf   0x06      ;Pongo RB0-RB7 en entradas
     bcf     0x03,5    ;a banco 0
         bcf     0x05,0    ;inicializo RA0 en 0
         bsf     0x05,3         ; RA3 en 1 (SYNC) ENVIO   
         bsf     0x05,2         ; RA2 en 1 (DATOS)ENVIO
         bsf     0x05,1         ; RA1 en 1 (CLK)    ENVIO
..............................................

Eso es todo
Alguien sabe cual puede ser el prob? Muchas Gracias


En línea

Meta


Desconectado Desconectado

Mensajes: 3.273



Ver Perfil WWW
Re: Problema en mi programa (PIC)
« Respuesta #1 en: 24 Octubre 2008, 03:19 am »

Porque tienes que usar en cada entrada BSF. Porque te pasas más de 8 bits.


En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
laluchi

Desconectado Desconectado

Mensajes: 11


Ver Perfil
Re: Problema en mi programa (PIC)
« Respuesta #2 en: 24 Octubre 2008, 07:13 am »

como,¿?
perdona la ignorancia, pero no entendi
En línea

Meta


Desconectado Desconectado

Mensajes: 3.273



Ver Perfil WWW
Re: Problema en mi programa (PIC)
« Respuesta #3 en: 30 Octubre 2008, 19:38 pm »

NEcesitas 12 entradas y 3 salidas.

Pues, utiliza.

bsf 12 veces, 8 del puerto A y 4 para puerto B sólo como entradas.
bcf para las tres salidas.
En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
Freeze.


Desconectado Desconectado

Mensajes: 2.732



Ver Perfil WWW
Re: Problema en mi programa (PIC)
« Respuesta #4 en: 30 Octubre 2008, 19:39 pm »

Perdon que no vaya a aportar nada pero me da curiosidad saber con que compilan ese codigo y como lo meten al artefacto :xD
En línea

Meta


Desconectado Desconectado

Mensajes: 3.273



Ver Perfil WWW
Re: Problema en mi programa (PIC)
« Respuesta #5 en: 30 Octubre 2008, 20:01 pm »

Bueno, te dejo esta Web y mira los manuales en pdf a ve si te da ideas.

http://usuarios.lycos.es/electronicapic/
En línea

Tutoriales Electrónica y PIC: http://electronica-pic.blogspot.com/
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con programa.
Programación C/C++
Daniel Contreras 6 1,905 Último mensaje 31 Agosto 2017, 08:03 am
por Daniel Contreras
Problema con programa
PHP
elbrujo20 1 944 Último mensaje 27 Septiembre 2017, 11:23 am
por bluff4value
problema programa c++
Programación C/C++
dilanf57 6 807 Último mensaje 2 Octubre 2018, 01:18 am
por Beginner Web
Problema con programa
.NET (C#, VB.NET, ASP)
mby 1 555 Último mensaje 13 Junio 2020, 01:02 am
por Tachikomaia
Problema con programa
Ingeniería Inversa
eko84 2 1,414 Último mensaje 13 Septiembre 2020, 10:52 am
por eko84
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines