elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Entrar al Canal Oficial Telegram de elhacker.net


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  Bases de Datos (Moderador: Carloswaldo)
| | | |-+  [SOLUCIONADO] Select en OLEDB
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [SOLUCIONADO] Select en OLEDB  (Leído 1,295 veces)
1mpuls0


Desconectado Desconectado

Mensajes: 1.186


Ver Perfil
[SOLUCIONADO] Select en OLEDB
« en: 1 Marzo 2013, 00:36 »

Hola, estoy trabajando con visual basic .net, oledb y excel.

Tengo un problema al realizar un select cuando el nombre del campo es un número

Hago la consulta

Código
  1. SELECT tabla.campo1, tabla.campo2, tabla.campo3 FROM tabla
  2.  

es decir en mi caso
Código
  1. SELECT prueba$.Sexo, prueba$.Edad, prueba$.1991 FROM [prueba$]
  2.  

Se muestra el siguiente mensaje:

Citar
Uso de '.', '!' o '()' no válido. en la expresión de consulta 'prueba$.199'.

Si en mi archivo de excel coloco una letra antes de 1991 y en la consulta tambien la modifico no tengo problema, pero el punto es que necesito leer la tabla con esos tres campos Sexo, Edad y Año sin alterar la estructura del excel.

Entiendo que el error está en el '.' pero si quito la referencia de la tabla en el resultado para ese campo todos los valores serán 1991


Alguna idea?

EDITO: Ya intenté con alias a la tabla y al campo y sigue tirando el mismo error.

Gracias


« Última modificación: 1 Marzo 2013, 17:04 por Darhius » En línea

abc
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema, ¿como recogeriais estos datos de un select option?(SOLUCIONADO)
PHP
Littl3 4 4,029 Último mensaje 28 Mayo 2009, 14:33
por Spider-Net
'Microsoft.Jet.OLEDB.4'
.NET (C#, VB.NET, ASP)
novalida 3 8,327 Último mensaje 5 Marzo 2010, 03:19
por elmaro
Microsoft.Jet.OLEDB.4.0
.NET (C#, VB.NET, ASP)
SγиtαxEяяoя 2 1,105 Último mensaje 6 Agosto 2013, 20:01
por Maurice_Lupin
Problema en OleDb Open
.NET (C#, VB.NET, ASP)
1mpuls0 0 1,157 Último mensaje 1 Mayo 2014, 01:33
por 1mpuls0
Error al conectar OleDb 0x8004005
Bases de Datos
SlayerBur 0 223 Último mensaje 21 Mayo 2019, 19:05
por SlayerBur
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines