elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  Windows
| | |-+  (SOLUCIONADO) Simbolo de sistema no reconoce los comandos. Windows 7
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: (SOLUCIONADO) Simbolo de sistema no reconoce los comandos. Windows 7  (Leído 10,011 veces)
guillem2000

Desconectado Desconectado

Mensajes: 3


Ver Perfil
(SOLUCIONADO) Simbolo de sistema no reconoce los comandos. Windows 7
« en: 9 Noviembre 2012, 00:11 »

Hola,

Tengo un problema, y es que el simbolo de sistema no reconoce los comandos, me sale este mensaje:

"ping" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.

tengo dos archivos takeown, son: takeown en C:\Windows\System32 y takeown.exe.mui en C:\Windows\System32\es-ES

ya e pasado el antivirus, ccleaner y el SUPERAntisSpyware.

En windows XP he visto que el error puede ser:
Mi PC -> boton derecho -> Propiedades -> Opciones Avanzadas -> Variables de Entorno, en Variables de Sistema, la variable Path

Poner en Path: %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\system32\WBEM

Pero no se en windows 7 la ruta del path.

Saludos.
 


« Última modificación: 12 Noviembre 2012, 03:16 por guillem2000 » En línea

Eleкtro


Conectado Conectado

Mensajes: 5.631



Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #1 en: 9 Noviembre 2012, 01:28 »

Hola,

No encuentro el razonamiento de porqué has mezclado el tema del "takeown" con el "ping" xD, cada uno es un comando externo distinto.

Tampoco hay razonamiento para haberle pasado antivirus, un antispyware, ni usar un limpiador del sistema que precisamente lo que hace es limpiar, no arreglar problemas, pero bueno, si sientes inseguridad en tu PC nunca viene mal un escaneo con un AV por si acaso.

Voy al tema:



Paso 1 - Para ver el contenido de la variable PATH es tán sencillo como escribir "PATH" en la consola. Comprueba que en la variable PATH tienes la siguiente ruta:
Código:
C:\windows\system32


Paso 2 - Si no tienes la ruta mencionada puedes reestablecer el PATH volviendo a crear la variable, en consola:
Código
  1. SETX /M PATH "%WINDIR%\system32;%WINDIR%\syswow64;%WINDIR%\system32\Wbem"
  2. SETX PATH "%WINDIR%\system32;%WINDIR%\syswow64;%WINDIR%\system32\Wbem"



Paso 3 - Si tienes la ruta mencionada, entonces sencillamente no existe la utilidad ping.exe en tu Windows.

> ¿Posibles causas?

1. Que estés usando una versión modificada de Windows (Por modificada me refiero a Windows black edition, windows superlite, windows supermierda, etc) con lo cual en este foro no damos soporte a este tipo de Windows, precisamente porque le eliminan herramientas útiles como ping.exe para ahorrar espacio en la instalación del sistema.

2. Que hayas eliminado el ejecutable, ya que ping.exe no se elimina él solo por arte de mágia, y un virus tendría cosas mejores que hacer que eliminarte el ping.exe...

> ¿Posibles soluciones?

1. En la carpeta winsxs se guardan copias de todos los ejecutables de la instalación de Windows, usa el buscador de Windows en esa carpeta para buscar "ping.exe" y copialo a system32, si no dispones de la copia en la carpeta WINSXS ya podemos dar por hecho que usas un Windows modificado.

2. Instala una máquina virtual con Windows 7 ORIGINAL y copia el ping.exe y el archivo .mui a tu otro windows 7.





PD: El CCLeaner es bueno pero algunos otros limpiadores de registro eliminan el PATH (Verguenza de limpiadores).

Saludos.


« Última modificación: 9 Noviembre 2012, 01:30 por EleKtro H@cker » En línea

Como insertar un código:

 

-> Reglas del foro <-
guillem2000

Desconectado Desconectado

Mensajes: 3


Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #2 en: 9 Noviembre 2012, 02:27 »

El comando ping, el ipconfig, ..., lo he puesto como ejemplo y lo de takeown lo he puesto porque en otros foros salia que el error podia ser eso en el XP.

Yo tengo el Windows 7 Home Premium de 64 bits.

Diferencia en el PASO 1. He puesto el comando "PATH" en consola y sale este mensaje:

PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Windows Live\Shared


El Paso 2 no me funciona, cuando pongo el codigo que me has pasado me pone:
"SETX" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.

Y tengo la carpeta winsxs  en C:\Windows
« Última modificación: 9 Noviembre 2012, 10:04 por guillem2000 » En línea

dato000


Desconectado Desconectado

Mensajes: 2.628


Pasando el rato


Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #3 en: 9 Noviembre 2012, 06:50 »

> ¿Posibles causas?

1. Que estés usando una versión modificada de Windows (Por modificada me refiero a Windows black edition, windows superlite, windows supermierda, etc) con lo cual en este foro no damos soporte a este tipo de Windows, precisamente porque le eliminan herramientas útiles como ping.exe para ahorrar espacio en la instalación del sistema.

Saludos.

 :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD :xD Jamás hay que usar veneno como ese, jamás.

Realmente, con una herramienta tan vital como el ping, yo simplemente reinstalo. sin dudarlo, si no esta ese habran problemas peores en el futuro con un SO tan incompleto.
En línea


Sonic Rules!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Para pasar el tiempo: http://daleradioblog.blogspot.com/
Eleкtro


Conectado Conectado

Mensajes: 5.631



Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #4 en: 9 Noviembre 2012, 16:31 »

El Paso 2 no me funciona, cuando pongo el codigo que me has pasado me pone:
"SETX" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.

Ups, error mío, perdón, claro con el PATH corrupto tampoco te encuentra el SETX.exe...  :xD


Abre la consola y escribe:
Código:
pushd "%WINDIR%\system32"

Y ahora sí, escribe los comandos del paso 2:
Código:
SETX /M PATH "%WINDIR%\system32;%WINDIR%\syswow64;%WINDIR%\system32\Wbem"
SETX PATH "%WINDIR%\system32;%WINDIR%\syswow64;%WINDIR%\system32\Wbem"


PD: Todo el mundo tiene la carpeta WINSXS, lo que intenté explicar es que si usas un Windows original, en esa carpeta debes tener el "ping.exe" y los comandos externos que te falten.

un saludo
« Última modificación: 9 Noviembre 2012, 16:37 por EleKtro H@cker » En línea

Como insertar un código:

 

-> Reglas del foro <-
guillem2000

Desconectado Desconectado

Mensajes: 3


Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #5 en: 9 Noviembre 2012, 21:28 »

Ya esta solucionado ;)

Aqui no se como se cierran los temas, y si hay puntos para los que dan con el problema.

Si saves como dilo. :)
En línea

Eleкtro


Conectado Conectado

Mensajes: 5.631



Ver Perfil
Re: Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #6 en: 9 Noviembre 2012, 22:29 »

Aqui no se como se cierran los temas, y si hay puntos para los que dan con el problema.

Si saves como dilo. :)

Aquí los temas los cierran los moderadores :xD, y un tema no se debe cerrar por el motivo que supones, pero sería conveniente que modificases el título de tu comentario principal añadiendo al principio un: "(SOLUCIONADO)".

Puntos, eso lo he visto en VBullletin pero en un foro en SMF como este no se si se puede, puedes proponer esa interesante idea aquí: http://foro.elhacker.net/sugerencias_y_dudas_sobre_el_foro-b10.0/

Saludos!
En línea

Como insertar un código:

 

-> Reglas del foro <-
cabeto2

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Re: (SOLUCIONADO) Simbolo de sistema no reconoce los comandos. Windows 7
« Respuesta #7 en: 1 Agosto 2014, 18:43 »

Hola quiero agradecerles por que me funciono a la perfección
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
problemas con simbolo del sistema
Windows
etsaia 10 1,752 Último mensaje 22 Diciembre 2005, 13:10
por etsaia
Problemas con Simbolo de Sistema
Windows
Leonhearth 6 1,342 Último mensaje 2 Julio 2006, 10:22
por Leonhearth
error con el simbolo del sistema
Windows
Dahmer 8 1,089 Último mensaje 13 Septiembre 2006, 22:48
por Dahmer
problemas con simbolo de sistema
Programación General
sergio_guti 0 581 Último mensaje 9 Mayo 2007, 21:38
por sergio_guti
duda del símbolo del sistema
Windows
Quake-man 4 1,368 Último mensaje 7 Junio 2010, 21:58
por Randomize
Powered by SMF 1.1.19 | SMF © 2006-2008, Simple Machines