elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: [Aporte] Mejores practicas en Java


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  ASM (Moderador: Eternal Idol)
| | | |-+  Duda usando macros en GAS
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Duda usando macros en GAS  (Leído 429 veces)
0and6

Desconectado Desconectado

Mensajes: 45


Ver Perfil
Duda usando macros en GAS
« en: 2 Junio 2017, 21:00 »

Hola, buen dia estoy aprendiendo a usar las macros en ensamblador, utilizo en compilador GAS, en su version 2.26.1, encontre un ejemplo el caso es que no me lo convierte en codigo fuente, me aparecen los mensajes
Error: unsoported instrucction 'mov'
en las lineas donde mando a llamar a las macros
escribir_cadena  $mensaje1  $longuitud1

He buscado otros ejemplos y al parecer estoy bien, pero a mi no me sale
Les anexo el codigo

Código
  1. # COMPILAR
  2. # as -o macros.o macros.s
  3. # ls -o macros macros.o
  4.  
  5. .macro terminar
  6. movl $1,%eax
  7. movl $0,%ebx
  8. int $0x80
  9. .endm
  10.  
  11. # espera ECX=cadena ; EDX=longuitud
  12. .macro escribir_cadena cadena longuitud
  13. movl $4,%eax
  14. movl $1,$ebx
  15. movl \cadena,%ecx
  16. movl \longuitud,%edx
  17. int $0x80
  18. .endm
  19.  
  20. # espera ECX=cadena ; EDX=longuitud
  21. .macro leer_cadena cadena longuitud
  22. movl $3,%eax
  23. movl $0,%ebx
  24. movl \cadena,%ecx
  25. movl \longuitud,%edx
  26. int 0x80
  27. .endm
  28.  
  29.  
  30. .section .data
  31. retorno: .byte 0x0A
  32. mensaje1: .ascii "\nIntroduce una cadena: "
  33. longuitud1 = . - mensaje1
  34. buffer: .ascii "           "
  35.  
  36.  
  37. .section .text
  38. .globl _start
  39.  
  40. _start:
  41. escribir_cadena $mensaje1 $longuitud1
  42. leer_cadena $buffer $10
  43.  
  44. escribir_cadena $retorno $1
  45. escribir_cadena $buffer $10
  46.  
  47. escribir_cadena $retorno $1
  48. terminar
  49.  


En línea

ivancea96


Desconectado Desconectado

Mensajes: 3.201


ASMático


Ver Perfil WWW
Re: Duda usando macros en GAS
« Respuesta #1 en: 3 Julio 2017, 23:49 »

El error es la llamada en sí o una instrucción dentro del macro? Verifícalo (puedes comentar todas las instrucciones del amcro a ver si sigue dando el problema?
De ser una instrucción, averigua exactamente cual.


PD: longitud es sin 'u' entre la g y la i :o


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Duda, Valores usando EQU
ASM
x64core 2 1,423 Último mensaje 27 Noviembre 2011, 18:01
por x64core
Esta vez duda usando libc « 1 2 »
Bugs y Exploits
pianista 16 4,419 Último mensaje 14 Febrero 2012, 00:11
por Ivanchuk
Duda sobre los macros
Programación C/C++
amchacon 4 779 Último mensaje 24 Mayo 2013, 02:02
por amchacon
[Duda] Usando Reflector y Reflexil
Ingeniería Inversa
LukaCrosszeria 3 1,119 Último mensaje 1 Octubre 2013, 17:24
por .:UND3R:.
Duda acerca de macros
Programación C/C++
Kaxperday 9 830 Último mensaje 27 Octubre 2015, 19:38
por ivancea96
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines