elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: ¿Eres nuevo? ¿Tienes dudas acerca del funcionamiento de la comunidad? Lee las Reglas Generales


+  Foro de elhacker.net
|-+  Seguridad Informática
| |-+  Hacking Wireless
| | |-+  Wireless en Linux
| | | |-+  Creando un script me sale [-] Failed to initialize interface 'mon0'
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Creando un script me sale [-] Failed to initialize interface 'mon0'  (Leído 3,031 veces)
l_s_h_s

Desconectado Desconectado

Mensajes: 12


Ver Perfil
Creando un script me sale [-] Failed to initialize interface 'mon0'
« en: 17 Enero 2015, 23:07 pm »

Hola.
  Estoy haciendo un scripts en bash, y me he estancado en el último paso (según se mire). Lo primero que hace el scripts es escanear las redes que hay con "iw", esto me las muestra sin problemas y sin estar en modo monitor.  Una vez se sale con Control+C, da a elegir la red y paso a crear el adaptador de red virtual y ponerlo en modo monitor (tambien con "iw") de esta forma
Código:
$ sudo iw phy phy2 interface add mon0 type monitor
miro con "iwconfig" y ahí está creado y en modo monitor, y por último ejecuto el reaver así:
Código:
$ sudo reaver -i mon0 -b <mac> -c <canal> -vv

Reaver v1.4 WiFi Protected Setup Attack Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[+] Switching mon0 to channel 1
[-] Failed to initialize interface 'mon0'
[-] Failed to recover WPA key
[+] Nothing done, nothing to save.

  No me inicializa, llevo poco tiempo y por mucho que busco no encuentro información al respecto, ¿alguna idea?

Salu2 y gracias

PD: Si creo y pongo el modo monitor con airmon-ng al usar el reaver funciona correctamente.





« Última modificación: 17 Enero 2015, 23:11 pm por l_s_h_s » En línea

l_s_h_s

Desconectado Desconectado

Mensajes: 12


Ver Perfil
Re: Creando un script me sale [-] Failed to initialize interface 'mon0'
« Respuesta #1 en: 18 Enero 2015, 00:03 am »

Vaya, torpeza de novato, solo había que levantarla:
Código:
$ sudo ifconfig mon0 up

Salu2
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Wlan0 - mon0 ?? « 1 2 »
GNU/Linux
KoFeRo 10 16,438 Último mensaje 19 Mayo 2010, 19:21 pm
por Festor
mon0
Hacking Wireless
What? 4 2,742 Último mensaje 22 Septiembre 2011, 10:11 am
por ChimoC
[AYUDA] dbforge error creando relaciones en la base de datos, sale: (errno: 150)
Bases de Datos
Graphixx 1 2,856 Último mensaje 26 Agosto 2014, 22:51 pm
por Graphixx
creando un script
Scripting
danny920825 0 1,782 Último mensaje 1 Junio 2015, 18:46 pm
por danny920825
[PowerShell] Creando un script PS1 para crear nueva VPN
Scripting
agus0 0 2,041 Último mensaje 4 Abril 2020, 01:13 am
por agus0
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines