elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  Windows (Moderador: Randomize)
| | |-+  [SOLUCIONADO] Problema con certificado SSL en IIS - Windows Server
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [SOLUCIONADO] Problema con certificado SSL en IIS - Windows Server  (Leído 2,521 veces)
motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
[SOLUCIONADO] Problema con certificado SSL en IIS - Windows Server
« en: 21 Diciembre 2014, 23:55 pm »

Buenas a todos, no sé si este tipo de problema va aquí exactamente.

Hace poco adquiri un certificado SSL para mi web lo instalé correctamnte desde IIS y en la web principal funciona perfectamente, pero cuando me logeo en mi cuenta aparece un aviso diciendo lo siguiente:


En los apartados de la web principal funciona perfectamente incluso logeado, donde esta el problema es cuando son dos apartados en la url, por ejemplo, https://miweb.com y https://miweb.com/test funcionan perfectamente, pero cuando es https://miweb.com/test/hola es cuando aparece lo de la imagen y no es nada agradable que no funcione el SSL correctamente.

el cifrado es de 2048Bits Microsoft RSA SChannel Cryptographic Provider.

Gracias de antemano, saludos.


Añado: Por lo que veo parece un error del código en la página en si, ya que en un subdominio me funciona perfectamente y en algunos otros apartados también, a ver si consigo solucionarlo y comparto la solución, saludos.


« Última modificación: 23 Diciembre 2014, 00:20 am por motocros_elche » En línea

djkamal

Desconectado Desconectado

Mensajes: 64


Todo un mundo por descubrir


Ver Perfil
Re: Problema con certificado SSL en IIS - Windows Server
« Respuesta #1 en: 22 Diciembre 2014, 04:48 am »

Eso es que se están bajando CSS y JS o fotos desde un protocolo no seguro (HTTP).


En línea


Somos los artistas de la tecnologia de la informacion y no somos unos frikis solo unos Expertos en informatica
motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: Problema con certificado SSL en IIS - Windows Server
« Respuesta #2 en: 22 Diciembre 2014, 05:16 am »

Eso es que se están bajando CSS y JS o fotos desde un protocolo no seguro (HTTP).
Entiendo, lo que no se exactamente es que debería de hacer, si editar los enlaces y reemplazar http por https u otra cosa, gracias por la ayuda.
En línea

djkamal

Desconectado Desconectado

Mensajes: 64


Todo un mundo por descubrir


Ver Perfil
Re: Problema con certificado SSL en IIS - Windows Server
« Respuesta #3 en: 22 Diciembre 2014, 05:33 am »

En chrome con F12 puedes ver lo que se baja por HTTP , suele ser una configuración de la aplicación web (CMS) (no confundir con servidor web) y debe tener opción usar HTTPS para estáticos , en el HTML veras que hay includes de CSS y JS o imágenes por HTTP .
En línea


Somos los artistas de la tecnologia de la informacion y no somos unos frikis solo unos Expertos en informatica
motocros_elche


Desconectado Desconectado

Mensajes: 897


Yona http://www.youtube.es/YonaTutorials


Ver Perfil WWW
Re: [SOLUCIONADO] Problema con certificado SSL en IIS - Windows Server
« Respuesta #4 en: 23 Diciembre 2014, 00:21 am »

En chrome con F12 puedes ver lo que se baja por HTTP , suele ser una configuración de la aplicación web (CMS) (no confundir con servidor web) y debe tener opción usar HTTPS para estáticos , en el HTML veras que hay includes de CSS y JS o imágenes por HTTP .
Solucionado, muchas gracias por la ayuda, al final era simplemente una imagen de una web externa no https, saludos.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines