elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: ¿Eres nuevo? ¿Tienes dudas acerca del funcionamiento de la comunidad? Lee las Reglas Generales


+  Foro de elhacker.net
|-+  Programación
| |-+  Scripting
| | |-+  [Batch]No consigo que funcione una variable dentro de un for
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: [Batch]No consigo que funcione una variable dentro de un for  (Leído 2,402 veces)
teamcpc

Desconectado Desconectado

Mensajes: 1


Ver Perfil
[Batch]No consigo que funcione una variable dentro de un for
« en: 15 Enero 2011, 15:12 »

Quiero hacer un script en batch (windows XP) para sacar una serie de capturas de un programa de renderizado lego/tente 3D y necesito que exista un contador dentro del for pero no se actualiza esa variable, pongo el trozo de código problemático:
Código
  1. @echo off
  2. # definicion de variables
  3. set RUTA_DE_LDVIEW=C:\Archivos de programa\LDView\
  4. set RUTA_MODELO=C:\tente\models\
  5. set MODELO=autobusurbano
  6. set EXTENSION=.ldr
  7. set SALIDA=graficos\
  8. mkdir %SALIDA%
  9. mkdir %SALIDA%%MODELO%
  10. echo "Procesando %MODELO%"
  11. set /a contador=1
  12. FOR /L %%y IN (0,1,8) DO (
  13.   set /a contador+=1
  14.   echo %contador%
  15.   "%RUTA_DE_LDVIEW%LDView.exe" "%RUTA_MODELO%%MODELO%%EXTENSION%" -SaveWidth=300 -SaveHeight=300 -DefaultLatLong=75,%%y0 -SaveSnapshot=%SALIDA%%MODELO%\frame000%contador%.jpg
  16. )
  17. FOR /L %%y IN (9,1,35) DO (
  18.   set /a contador+=1
  19.   echo %contador%
  20.   "%RUTA_DE_LDVIEW%LDView.exe" "%RUTA_MODELO%%MODELO%%EXTENSION%" -SaveWidth=300 -SaveHeight=300 -DefaultLatLong=75,%%y0 -SaveSnapshot=%SALIDA%%MODELO%\frame00%contador%.jpg
  21. )


« Última modificación: 15 Enero 2011, 19:08 por Leo Gutiérrez. » En línea

leogtz
. . .. ... ..... ........ ............. .....................
Colaborador
***
Desconectado Desconectado

Mensajes: 3.069


/^$/


Ver Perfil WWW
Re: No consigo que funcione una variable dentro de un for
« Respuesta #1 en: 15 Enero 2011, 18:06 »

Código
  1. @echo off
  2. setlocal enabledelayedexpansion
  3. rem definicion de variables
  4. set RUTA_DE_LDVIEW=C:\Archivos de programa\LDView\
  5. set RUTA_MODELO=C:\tente\models\
  6. set MODELO=autobusurbano
  7. set EXTENSION=.ldr
  8. set SALIDA=graficos\
  9. mkdir %SALIDA%
  10. mkdir %SALIDA%%MODELO%
  11. echo "Procesando %MODELO%"
  12. set /a contador=1
  13. FOR /L %%y IN (0,1,8) DO (
  14.   set /a contador+=1
  15.   echo !contador!
  16.   "!RUTA_DE_LDVIEW!LDView.exe" "!RUTA_MODELO!!MODELO!!EXTENSION!" -SaveWidth=300 -SaveHeight=300 -DefaultLatLong=75,% style="color: #448888;">%y0 -SaveSnapshot=!SALIDA!!MODELO!\frame000!contador!.jpg
  17. )
  18. FOR /L %%y IN (9,1,35) DO (
  19.   set /a contador+=1
  20.   echo !contador!
  21.   "!RUTA_DE_LDVIEW!LDView.exe" "!RUTA_MODELO!!MODELO!!EXTENSION!" -SaveWidth=300 -SaveHeight=300 -DefaultLatLong=75,% style="color: #448888;">%y0 -SaveSnapshot=!SALIDA!!MODELO!\frame00!contador!.jpg
  22. )

Dentro del bucle FOR hay que cambiar las variables a !var! para una correcta expansión.

Los comentario en batch se hacen con el comando "rem".


« Última modificación: 15 Enero 2011, 18:20 por Leo Gutiérrez. » En línea

Código
  1. (( 1 / 0 )) &> /dev/null || {
  2. echo -e "stderrrrrrrrrrrrrrrrrrr";
  3. }
  4.  
http://leonardogtzr.wordpress.com/
leogutierrezramirez@gmail.com
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Variable incremental dentro de un FOR
Scripting
Stati98 2 2,659 Último mensaje 22 Julio 2009, 20:48
por Stati98
ayuda,no consigo juntar dos codigos y que funcione
PHP
soru13 0 1,084 Último mensaje 9 Febrero 2010, 22:26
por soru13
[RUBY] Es posible variable distinta dentro de for?
Scripting
tbgio 7 1,964 Último mensaje 27 Julio 2011, 21:54
por tbgio
[BATCH] Variable dentro de for [SOLUCIONADO]
Scripting
DameBanda 2 1,600 Último mensaje 8 Abril 2012, 18:25
por DameBanda
Amigos no consigo que funcione bettercap AYUDA!
Wireless en Linux
ptkchap 0 273 Último mensaje 20 Noviembre 2018, 01:27
por ptkchap
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines