elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Análisis del vídeo del hackeo al Sindicato de los Mossos de Esquadra


+  Foro de elhacker.net
|-+  Comunicaciones
| |-+  Redes (Moderador: HdM)
| | |-+  limitar ancho de banda en un router o en un switch cisco
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: limitar ancho de banda en un router o en un switch cisco  (Leído 35,049 veces)
exeny

Desconectado Desconectado

Mensajes: 17



Ver Perfil
limitar ancho de banda en un router o en un switch cisco
« en: 18 Mayo 2011, 05:18 »


Hola quisiera saber si se puede limitar ancho de banda en un router 2811 o en un switch cisco parece ser 2800 por puerto me explico mejor quisiera dividir la red en 3 vlans 1 vlans a server otra a admin y a ventas cuento con 3 megas entonces quisiera dividir la red con las vlans y 1 mega cada uno no sé si se puede por puertos. investigue un poco pero creo q solo se puede QoS por protocolos con acls dándole prioridad a protocolos no sé si me equivoco pero me interesaría de esa forma por puertos muchas gracias de antemano por cualquier info q me puedan brindar.   :D :D


En línea

De la ignorancia nos equivocamos, de la equivocación aprendemos
BlydexMaster


Desconectado Desconectado

Mensajes: 484


HACK OR DIE.!


Ver Perfil WWW
Re: limitar ancho de banda en un router o en un switch cisco
« Respuesta #1 en: 18 Mayo 2011, 07:00 »

si ya creaste las vlans a cada sub-interfaz del router le puedes asignar cierto ancho de banda no lo e probado como tal pero en packet tracer me funciono ejemplo:
intentalo asi con cada interfaz no se si te funcione pero como te digo en packet tracer funciona..
o lo puedes hacer con las ACLs.. tambien creo q todo esto se te aria mas facil con SDM.. si no sabes muxo de cisco contrata un experto no sea q metas la pata y despues se ponga fea la cosa..

Para configurar el rate-limit necesitaremos también dos valores más que se recomienda calcular con la formula proporcionada por Cisco. Estos valores son el "normal burst" y el "extended burst".

Según Cisco estos valores se calcula por:

"normal burst" = rate * (1 byte)/(8 bits) * 1.5 seconds

"extended burst" = 2 * "normal burst"


Lo que haremos es limitar el ancho de banda a estos servicios. Lo primero que haremos es especificar cuanto ancho de banda quiero para cada servicio teniendo en cuenta los 1mbps/512kbps.

Para entrada de correo una limitación de 256kbps (respecto los 1mbps).
Para salida de correo una limitación de 128kbps (respecto los 512kbps).
Para salida de contenido Web una limitación de 256kbps (respecto los 512kbps).

Para restringir el ancho de banda a los servicios se utilizara una ACL.

Configuración:


Router(config)# access-list 10 permit tcp any eq www any
(limitamos el trafico Web saliente)

Router(config)# access-list 11 permit tcp any any eq smtp
(limitamos el trafico smtp entrante)

Router(config)# access-list 12 permit tcp any eq smtp any
(limitamos el trafico smtp saliente)

Implementar el comando rate-limit en la interfaz que conecta a internet o cualquier otro Router:
Router(config)# interface GigabitEthernet0/0

Router(config-if)#
rate-limit output access-group 10 256000 48000 96000 conform-action transmit exceed-action drop
(liminado el ancho de banda del trafico Web saliente)

Router(config-if)#
rate-limit input access-group 11 256000 48000 96000 conform-action transmit exceed-action drop
(limitamos el ancho de banda del correo entrante)

Router(config-if)#
rate-limit output access-group 12 128000 24000 48000 conform-action transmit exceed-action drop
(limitamos el ancho de banda del correo saliente)

Comandos para verificación

show interfaces rate-limit
(Para Muestra información sobre un determinado rate-limit en la interfaz)


« Última modificación: 18 Mayo 2011, 07:17 por dj-blydex » En línea

<·$<·$<·$ *Nata Te Amo MDI* ·$ >·$ >·$ >
                     Anthony Marin
               Consultor I.T Venezuela
   Cisco Certified Network Associate (CCNA®)
                D-Link Basic  Certified
exeny

Desconectado Desconectado

Mensajes: 17



Ver Perfil
Re: limitar ancho de banda en un router o en un switch cisco
« Respuesta #2 en: 18 Mayo 2011, 16:54 »


hola dj-bllydex muchas gracias por tu respuesta lo intentare y primero Dios funcione ahora asi solo por curiosidad se podra hacer eso de limitar el ancho de banda de un switch cisco ya propiamente en el puerto ejem interface fa0/10 que solo tenga a 128 kbps de velocidad y los demas todo el ancho de banda digamos Muchas gracias de antemano  ??
En línea

De la ignorancia nos equivocamos, de la equivocación aprendemos
madpitbull_99
Colaborador
***
Desconectado Desconectado

Mensajes: 1.912



Ver Perfil WWW
Re: limitar ancho de banda en un router o en un switch cisco
« Respuesta #3 en: 18 Mayo 2011, 21:09 »

Lo que necesitas se llama QoS. Puedes aplicarle restricciones de velocidad a una VLAN o un puerto en concreto:

_Enabling Per-Port Per-VLAN QoS.
_Configuring QoS and Per Port Per VLAN QoS - Cisco.
_

Para aplicar la restricción solo a un puerto podrías hacer algo así:
Código:
mls qos
!
interface fa0/10
bandwidth 1000 !

Para aplicarle un limite de 15% del total del ancho de banda:
Código:
srr-queue bandwidth limit 15 !


Si te decides por usar políticas ACL intenta algo así:

Código:
ip access-list extended DEPT_V
permit ip any any

class-map match-all BW_512
match access-group name DEPT_V

policy-map 1024Kb
description 1024 kbps
class BW_512
police 512000 64000 exceed-action drop

interface FastEthernet0/5
desc DEPARTAMENTO_VENTAS 512 Kbps
service-policy input 1024Kb
service-policy output 1024Kb

Con este ejemplo limitarías al "Departamento Ventas" a 1024 kbps. Los ejemplos que te he dejado son para Switch Catalyst.

En línea



«Si quieres la paz prepárate para la guerra» Flavius Vegetius

[Taller]Instalación/Configuración y Teoría de Servicios en Red
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Limitar Ancho de Banda en Router SpeddStream 5200
Redes
eligiuz 4 7,471 Último mensaje 20 Enero 2005, 02:48
por scrngs
Limitar ancho de banda de cada ip en un router Xavi
Redes
Sagman 2 2,126 Último mensaje 25 Agosto 2005, 10:08
por Sagman
Limitar ancho de banda
Redes
ossel 2 1,646 Último mensaje 5 Mayo 2006, 05:34
por smurfmix
Como limitar ancho de banda en pc´s conectados al mismo router?
Redes
Banker25 1 4,605 Último mensaje 17 Febrero 2010, 22:13
por lr1912
Limitar ancho de banda por IP en router Cisco DPC2425R2
Redes
Amerikano|Cls 2 3,698 Último mensaje 7 Abril 2014, 03:35
por Amerikano|Cls
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines