elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Guía rápida para descarga de herramientas gratuitas de seguridad y desinfección


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  .NET (C#, VB.NET, ASP)
| | | |-+  Programación Visual Basic (Moderadores: LeandroA, seba123neo)
| | | | |-+  Reproducción .WAV durante reproducción proyecto en VBA de Excel
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Reproducción .WAV durante reproducción proyecto en VBA de Excel  (Leído 1,694 veces)
LuzBlanca

Desconectado Desconectado

Mensajes: 30


Ver Perfil
Reproducción .WAV durante reproducción proyecto en VBA de Excel
« en: 31 Mayo 2007, 14:29 pm »

Buenas a todos, actualmente estoy haciendo un programa con la herramienta de Visual Basic de Excel (no es por elección propia sino porque el curso que hago trata sobre esta herramienta de Excel, es decir, no puedo cambiar el programa). El caso es que quiero meterle al proyecto música, he conseguido, pasando previamente el archivo MP3 a WAV y creando un módulo donde he introducido una codificación que he encontrado por la red, que me aparezca al presionar F5 una posibilidad de reproducir el sonido pero... el problema es que el sonido empieza y luego tengo que seleccionar reproducir el proyecto y me gustaría que el sonido apareciera con la apertura del proyecto y terminará con éste. Y de ser posible que se reproduciera tantas veces como fuera necesario hasta que el usuario termine de usar el programa.

Aprovecho para dejarles otra pregunta que los tutores del curso no han sabido solucionarme aún y es como hacer para que al presionar un botón, commandbutton, que hace de enlace a una web se abra la web. La codificación que me han facilitado ha sido usando .hiperlynk (1) pero no me funciona sólo en uno de los casos y cuando la reproducción de la UserForm es independiente, es decir, cuando el proyecto entero está reproduciéndose y el usuario llega a esa UserForm no funciona pero si cierro el proyecto y le doy a reproducir únicamente esa UserForm me enlaza correctamente con el sitio web, aunque la verdad sólo ocurre con una de los commandbutton de enlaces que tengo, el resto no funciona en ninguno de los casos.

Muchas gracias ante todo. Quedo abierta a todo tipo de sugerencias que tengáis para solucionar este problemilla. Gracias de nuevo.


« Última modificación: 31 Mayo 2007, 14:35 pm por LuzBlanca » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Los routers que vienen incorporarán salida HDMI para reproducción multimedia
Noticias
wolfbcn 0 528 Último mensaje 5 Mayo 2014, 18:16 pm
por wolfbcn
Reproducción fragmentada de videos
Programación Visual Basic
scaramux 0 864 Último mensaje 23 Mayo 2014, 07:53 am
por scaramux
Lista de reproducción en Android
Dudas Generales
wiluxion 0 926 Último mensaje 7 Agosto 2014, 16:04 pm
por wiluxion
El nuevo Chromecast vendrá con una mejor conexión WiFi y modo de reproducción...
Noticias
wolfbcn 0 481 Último mensaje 19 Septiembre 2015, 14:55 pm
por wolfbcn
Problema reproduccion microfono
Multimedia
sutove 2 1,220 Último mensaje 22 Abril 2016, 18:18 pm
por sutove
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines