elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Guía actualizada para evitar que un ransomware ataque tu empresa


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  Pseudocodigo
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Pseudocodigo  (Leído 2,967 veces)
Pedrinchi27

Desconectado Desconectado

Mensajes: 20



Ver Perfil
Pseudocodigo
« en: 24 Mayo 2011, 03:09 am »

Hola no se si este sea el foro adecuado para colocar esto pero si no es asi les ruego me disculpen y lo hagan saber, y decirme o moverlo al foro correcto. Resulta uq la profesora de progrmacion nos pidio que hicieramos un prog en seudocodigo para calcular la edad exacta ne dias mese y años de una persona. Yo hice mas o menos este, creoe sta bastante bien por lo creo sirve de referencia para otras personas.
a ver sis se entiende jjajaj

Proceso sin_titulo
   Escribir "Escriba su fecha de nacimiento en formato de DD/MM/AAAA"
   leer dv, mv, av;
   Escribir "Ahora escriba la fecha actual";
   leer da, ma, aa;
   
   
   si dv<=31 y mv<=12 y da<=31 y ma<=12
      resAv<-av mod 4;
      resAa<-aa mod 4;
      mes<-ma-mv;
      ano<-aa-av;
      si resAv=0 o resAa=0
         dias<-(da-dv)+1;
         si dv>da
            dias<-30+da-dv;
            mes<-mes-1;
         FinSi
      Sino
         dias<-da-dv;
         si dv>da
            dias<-30+da-dv;
            mes<-mes-1;
         FinSi
      FinSi
   escribir "la persona tiene ",dias," dias , ", mes, " meses y ", ano;
   sino
      Escribir "FECHA INCORRECTA";
   finsi

esta hecho en PSint un programa que interpreta pseudocodigos.

GRACIAS DESDE YA! :silbar: :silbar:


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Ejercicios en Pseudocódigo
Ejercicios
DaRLeK 3 5,380 Último mensaje 29 Octubre 2010, 01:57 am
por Psyke1
Ejercicios de pseudocódigo
Ejercicios
Saberuneko 2 17,842 Último mensaje 30 Octubre 2010, 12:49 pm
por Saberuneko
Pseudocodigo
Programación C/C++
Ronkof 2 999 Último mensaje 25 Abril 2013, 01:55 am
por Ronkof
pseudocodigo
Programación C/C++
vivianfes 1 871 Último mensaje 13 Noviembre 2014, 03:40 am
por engel lex
¿Cómo es un pseudocódigo que varíe una afirmación?
Programación General
Tachikomaia 0 279 Último mensaje 12 Agosto 2019, 13:06 pm
por Tachikomaia
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines