elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Sigue las noticias más importantes de seguridad informática en el ttwitter! de elhacker.NET


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  Ayuda para intercalar elementos de un arreglo en un tercer vector dado 2 vectore
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Ayuda para intercalar elementos de un arreglo en un tercer vector dado 2 vectore  (Leído 6,115 veces)
sebastian2012

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Ayuda para intercalar elementos de un arreglo en un tercer vector dado 2 vectore
« en: 23 Julio 2012, 02:56 am »

Hola estaba haciendo este problema en PSeint y me encuentro con un problemilla, a ver si alguien me puede echar una mano
aqui el enunciado

diseñar un algoritmo que permita almacenar cinco numeros
en el arreglo a y b.Visualizar los valores del arreglo a
y b en forma intercaladaal arreglo c

estos vectores ya estan definidos

a[5]->10,20,30,40,50,
b[5]->60,70,80,90,100
un elemnto de a y otro de b
El nuevo arreglo seria -->c[10]->10,60,20,70,30,80,40,90,50,100
yo estuve haciendo esto pero me bota fuera de indice en el PSeint
lo que si hice fue llenar el arreglo c[10] pero primero con  los elemntos de a y luego con los b de esta manera
para i<-1 hasta 5 hacer
    c<-a;
finpara
para i<-1 hasta 5 Hacer
    c[i+5]<-b;
finpara

Pero esto bota ----->10,20,30,40,50,60,70,80,90,100


Proceso Ejercicio1
   //Otra manera de solucion
   //Declarar variables
   na<-0;nb<-0;i<-0;j<-0;k<-0;n<-0;
   Dimension a[5];
   Dimension b[5];
   Dimension c[10];
   
//entrada de datos
   para i<-1 hasta 5 Hacer//leer el arreglo a
      escribir 'Ingrese elemento [',i,'] de A:';
      Leer na;
      a<-na;
   FinPara
   
Escribir '-------------------------';   
para j<-1 hasta 5 Hacer//leer el arreglo b
      escribir 'Ingrese elemento [',j,']de B:';
      Leer nb;
      b[j]<-nb;
   FinPara

   //proceso de datos
   
   //Leer los dos arreglos
   Escribir 'Estos son los arreglos';
   para i<-1 hasta 5 Hacer
      Escribir a,'<-->',b;
   FinPara
   
//Intercala los valores de lo arreglos
   
   //proceso de datos
   para i<-1 hasta 10 con paso 2 Hacer
      c<-a;
      
   FinPara   
   para i<-1 hasta 10 con paso 2 Hacer
      c[i+1]<-b;
   FinPara   
   //para i<-1 hasta 5 hacer
      //c<-a;
    //finpara
  
    //para i<-1 hasta 5 Hacer
   //   c[i+5]<-b;
   // finpara
   //salida de datos
   para i<-1 hasta 10 Hacer
      Escribir c;
   FinPara
   
   
   
   //salida de datos
   //Para i<-1 hasta 10 Hacer
      //Escribir c;
   //FinPara
   
FinProceso

Gracias amigos de antemano


« Última modificación: 23 Julio 2012, 03:05 am por sebastian2012 » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Eliminar elementos repetidos de un vector
Programación General
GaLaN GaLaNaSo 3000 2 59,522 Último mensaje 16 Noviembre 2011, 06:44 am
por osolmm
Problema para contar elementos de un vector
Java
_SainT_ 4 6,306 Último mensaje 24 Agosto 2011, 20:02 pm
por _SainT_
Llenar un vector con 10 elementos no repetidos en Ruby
Scripting
hack289z 0 3,377 Último mensaje 25 Octubre 2011, 02:24 am
por hack289z
arreglo de n elementos
Programación C/C++
sanchez2011 6 5,384 Último mensaje 29 Abril 2012, 02:14 am
por sanchez2011
Buscar controls dado un arreglo (Ayuda)
Programación Visual Basic
dunz712 1 973 Último mensaje 2 Septiembre 2013, 07:40 am
por dunz712
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines