elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Sigue las noticias más importantes de seguridad informática en el ttwitter! de elhacker.NET


  Mostrar Mensajes
Páginas: [1] 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 ... 21
1  Programación / PHP / Re: Problema al modificar datos - Jquery Ajax PHP en: 16 Noviembre 2017, 11:59 am
Creo que he avanzado algo, me di cuenta que el
Código
  1. $('#formEditarNoticia').serialize();

No hacia nada, porque mi formulario #formEditarNoticia no tenía ningún atributo name.
Ahora al darle enviar. Me arroja los errores:

Código:
Notice: Undefined index: idNoticia in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 34

Notice: Undefined index: imagenNoticia-guardada in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 35

Notice: Undefined index: imagenNoticia in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 36

Notice: Undefined index: tituloNoticia in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 37

Notice: Undefined index: noticiaCorta in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 38

Notice: Undefined index: noticiaCompleta in C:\MAMP\htdocs\Web\admin\subirNoticia.php on line 39
.

La verdad no se porque me dice eso si yo lo tengo asi:

Código
  1. elseif ($accion == 'modificar') {
  2.  
  3.        $idNoticia = $_POST['idNoticia']; //linea 34
  4.        $imagenNoticia_guardada = $_POST['imagenNoticia-guardada'];//linea 35
  5.        $imagenNoticia = $_FILES['imagenNoticia'];//linea 36
  6.        $tituloNoticia = $_POST['tituloNoticia'];//linea 37
  7.        $noticiaCorta = $_POST['noticiaCorta'];//linea 38
  8.        $noticiaCompleta = $_POST['noticiaCompleta'];//linea 39

Me esta volviendo loco esto! :(
2  Programación / PHP / Problema al modificar datos - Jquery Ajax PHP en: 16 Noviembre 2017, 09:53 am
Buenos días gente, Tengo un sistema de noticias implementado. Al listar las noticias y clickear en el boton editarNoticia. Aparece la noticia con todos los campos para editar junto con un input "file" que si se edita una noticia, junto con su imagen, reemplaza a la anterior imagen que estaba subida cuando se creo la noticia.

El problema yo creo que está en el AJAX, no se que estoy haciendo mal o como llamar al ID de la noticia correspondiente. Yo ya hice el BORRAR y me funciona correctamente pero no se porque no me sale con el editar que es casi parecido.

Con esto traigo las noticias. (Esto funciona correctamente). No pongo el codigo anterior, pq no es necesario supongo.

Código
  1. elseif ($accion == 'editarNoticias'){
  2.  
  3. $id = $_POST['id'];
  4.  
  5. //Consulta BD Editar Noticia segun el ID.
  6. $statement2 = $conexion->prepare("SELECT * FROM noticias WHERE idNoticia = $id");
  7. $statement2->execute();
  8. $noticias = $statement2->fetchAll();
  9.  
  10. //MODIFICAR DESDE ACA
  11. echo "<h1 class='text-center m-5'>Editar noticias SB</h1>
  12. <form id='formEditarNoticia' class='text-center' method='post' enctype='multipart/form-data'>";
  13.  
  14. foreach ($noticias as $noticia) {
  15. echo "<div class='form-group mt-5'>
  16. <input type='text' id='". $noticia['idNoticia'] ."' value='" . $noticia['idNoticia'] . "' name='idNoticia' >
  17. <input type='text' name='imagenNoticia-guardada' value='" . $noticia['imagenNoticia'] . "'>
  18. <input type='file' class='form-control-file mx-auto' name='imagenNoticia' id=' placeholder=' aria-describedby='fileHelpId'>
  19. <small id='fileHelpId' class='form-text text-muted text-center'>Seleccione la imagen que quiere subir...</small></div>
  20.  
  21. <div class='col mx-auto mb-3'>
  22.    <input name='tituloNoticia' type='text' class='form-control' value='" . $noticia['tituloNoticia'] . "'>
  23. </div>
  24.  
  25. <div class='col mx-auto mb-3'>
  26. <input name='noticiaCorta' type='text' class='form-control' value='" . $noticia['noticiaCorta'] . "'>
  27. </div>
  28.  
  29. <div class='col mb-3'>
  30.    <textarea name='noticiaCompleta' rows='20' cols='50' type='text' class='form-control'>"
  31.    . $noticia['noticiaCompleta'] . "</textarea>
  32. </div>
  33.  
  34. <div class='d-inline-block'>
  35.    <button class='enviarEditarNoticia btn btn-success'>EDITAR NOTICIA</button>
  36.    <a href='index.php'><button type='button' class='btn btn-warning'>VOLVER</button></a>
  37. </div>
  38. </form>";
  39. }
  40.  
  41. }

Una vez que visualizo la noticia, la edito y le doy al botón EDITAR NOTICIA (que su clase es enviarEditarNoticia) y su AJAX el siguiente (A MI PARECER EL PROBLEMA ES AQUÍ... No se como enviarle el ID de la noticia ya que en DATA estoy usando el formData.":

Código
  1.        $("#seccionEditarNoticia").on("click", ".enviarEditarNoticia", function()
  2.     {
  3.        $('#formEditarNoticia').serialize();
  4.        $.ajax({
  5.            type: "POST",
  6.            url: "subirNoticia.php?p=modificar",
  7.            data: new FormData($('#formEditarNoticia')[2]),
  8.            contentType: false,
  9.            processData:false,
  10.            success: function(datos) {
  11.                $('#mensaje').empty();
  12.                $('#mensaje').append(datos);
  13.            }
  14.        });
  15.    });  

Y bueno al clickear .enviarEditarNoticia debería hacer esto:

Código
  1. }elseif ($accion == 'modificar') {
  2.  
  3. if (isset($_POST['id'])) {
  4.    $id = $_POST['id'];
  5. }
  6.  
  7.    $idNoticia = $_POST['idNoticia'];
  8.    $imagenNoticia_guardada = $_POST['imagenNoticia-guardada'];
  9.    $imagenNoticia = $_FILES['imagenNoticia'];
  10.    $tituloNoticia = $_POST['tituloNoticia'];
  11.    $noticiaCorta = $_POST['noticiaCorta'];
  12.    $noticiaCompleta = $_POST['noticiaCompleta'];
  13.  
  14.    if (empty($imagenNoticia['name'])) {
  15.        $imagenNoticia = $imagenNoticia_guardada;
  16.    } else {
  17.        $carpeta_destino = '../img/noticias/';
  18.        $archivo_subido = $carpeta_destino . $_FILES['imagenNoticia']['name'];
  19.        move_uploaded_file($_FILES['imagenNoticia']['tmp_name'], $archivo_subido);
  20.        $imagenNoticia = $_FILES['imagenNoticia']['name'];
  21.    }
  22.  
  23.        $statement = $conexion->prepare(
  24.        "UPDATE noticias SET tituloNoticia = :tituloNoticia, noticiaCorta = :noticiaCorta, noticiaCompleta = :noticiaCompleta, imagenNoticia = :imagenNoticia WHERE idNoticia = $idNoticia"
  25.    );
  26.  
  27.    $statement->execute(array(
  28.        ':tituloNoticia' => $tituloNoticia,
  29.        ':noticiaCorta' => $noticiaCorta,
  30.        ':noticiaCompleta' => $noticiaCompleta,
  31.        ':imagenNoticia' => $imagenNoticia
  32.    ));
  33.  
  34.        echo "La noticia ha sido editada correctamente.";
  35.  
  36.     }

No puse el codigo completo del IF con el agregar o borrar porque eso funciona correctamente.

He intentado muchas cosas, puedo insertar y borrar pero no puedo modificar porque no se como enviar mis nuevos valores ingresados en los input. En el insertar y borrar yo usaba el data: pero ahora en el modificar en el data tengo el data: new FormData, entonces no se como implementarlo.

Otra cosa que he notado es que cuando escribo en los input para modificar, he mirado con firebug y el atributo value= no cambia. O sea el input en el navegador ingresa mi texto, pero miro internamente y el value sigue igual que como llegó.

Espero que me puedan dar una mano, debe ser una tonteria... pero me tiene loco hace 2 dias! :(

Muchas gracias por leer!


3  Media / Diseño Gráfico / Re: Colores diferentes fotos/videos en Movil/Ordenador en: 16 Mayo 2017, 10:06 am

Gracias, al final he encontrado una "solución".
Modifiqué mi pantalla de la notebook subiendole la saturación a 50 y jugando apenas con el Rojo, verde y Azul y aunque se nota bastante un poco saturado en algunos colores, ahora cuando diseño y lo envio al móvil o algo no se ve demasiado saturado como antes.

Es la única forma q pude solucionarlo. No se si será la correcta, pero por ahora me sirve.

Saludos y gracias a los q se tomaron el tiempo de leer y ayudarme
4  Media / Diseño Gráfico / Re: Colores diferentes fotos/videos en Movil/Ordenador en: 13 Mayo 2017, 17:35 pm
Tambien puedes ajustar el monitor a traves de windows; si es en windows 10 vas a Configuracion-> Configuración avanzada de visualización->Administración de color->
Luego siguiendo las intrucciones intentar ajustar.

Hola, disculpa la demora. Gracias por responder.
Eso es lo que hice y comenté arriba justamente. Calibrar la pantalla. Intenté ajustarla lo más parecido posible, bajé muchísimo el GAMMA, estaba por la mitad y lo baje casi a un 20%. Y creo que todo lo demás lo hice acorde a lo que decía, pero aún así creo que no esta muy bien....

Alguna otra forma? Es la primera vez que me sucede algo asi con una notebook. Incluso empiezo a pensar que quizas sea mi Samsung Galaxy S6 EDGE que cualquier foto que abres, le da más color, saturacion, constraste y la hace ver más "bonita" quizás.

Espero que a alguien se le ocurra algo más para ayudarme.
Nuevamente mil gracias a todos!
5  Media / Diseño Gráfico / Re: Colores diferentes fotos/videos en Movil/Ordenador en: 10 Mayo 2017, 08:48 am
Buenos dias KaOs,

Lo que mencionas me ha pasado anteriormente. Más que editar las fotos para que se vean bien en ambos sitios, te recomiendo ajustar la configuración de tu monitor para mostrar brillo/contraste/color tal como lo haría tu móvil.

Puedes usar esta imagen como referencia para el brillo y contraste:


Estoy bastante seguro de que tu monitor tienen probablemente el brillo y contraste muy bajos. En toda edición gráfica/visual es recomendable ajustar el monitor todo lo posible para que coincida con el color, brillo y contraste reales.

Un Saludo

Buenas, gracias por responder. No se si lo he mirado bien o en el lugar correcto pero creo que el brillo de mi monitor esta perfectamente.
Incluso haciendo una prueba hice coincidir bastante los tonos que me presentaba como ejemplos.
Donde decías que modifique eso?
Nuevamente muchas gracias
6  Media / Diseño Gráfico / Colores diferentes fotos/videos en Movil/Ordenador en: 9 Mayo 2017, 10:46 am
Hola buenas gente... disculpen por la pregunta, quizás es básica, pero busqué en Google y no me convenció ni me quedé muy conforme.
Mi problema es el siguiente...

Cuando edito unas fotos y/o videos en el ordenador, al sumarle contraste, brillo, saturación, etc... llega un momento que las veo PERFECTAS. El problema llega luego cuando las veo en el móvil resulta que tiene DEMASIADA SATURACIÓN, CONTRASTE, BRILLO, ETC...

Lo mismo me pasa al reves obviamente, cuando la veo perfecta en el móvil, en el ordenador la veo casi "sin fuerza" en los colores. O sea, se ve bien, pero no como se aprecia en el móvil.

Hay alguna forma de poder realizar una edición tanto de fotos o videos en un "punto intermedio" de los dos? Me pone loco tener que subir unos videos/fotos de una forma para el ordenador y luego subir otros diferentes para el movil...

No se si se entendió espero que si. Nuevamente muchas gracias por su tiempo.

Saludos!
7  Sistemas Operativos / Windows / Re: Problema con Fast Boot en BIOS // Como instalar UEFI otra vez? en: 6 Noviembre 2016, 20:28 pm
No sabemos que BIOS es ni como son sus menús, así que con esos pocos datos que das poco podemos hacer al respecto. Eso si te aconsejo que restaures la BIOS a sus valores por defecto. Esto seguramente te solucionará el problema.
Saludos...

Songoku

Buenas Songoku, gracias por intentar ayudarme.
Ya despues de mucho probar encontré cual era el problema.

Mi pendrive estaba en NTFS por lo tanto EFI no lo detectaba.
Lo he convertido con el Aomei NTFS to FAT32 sin perder absolutamente nada de los datos y funcionó perfectamente. Me lo detecto en EFI y ahora estoy escribiendo desde el Windows 10 instalado perfectamente.

Dejo la solución por si a alguien le sucede.
Nuevamente gracias a todos!
8  Sistemas Operativos / Windows / Problema con Fast Boot en BIOS // Como instalar UEFI otra vez? en: 5 Noviembre 2016, 19:10 pm
Buenas gente, nuevamente aquí con un problema q me ha surgido.

He comprado un portatil y venía con Windows 10 Home. Decidí formatearlo y ponerle el Windows 10 Pro. Ya lo había hecho antes en otro ordenador y todo resultó bien.

Pero esta vez al formatear me aparecían las particiones y el típico error de que no se puede instalar porque el sistema es GPT.
He vistó miles de tutoriales y encontré uno que lo que hizo es LIMPIAR las particiones (diskpart, disk list, clean, etc...)
Recién ahí me dejó instalar el Windows 10 Pro.

Cual es el problema? Que me di cuenta que entrando a la BIOS es como que me ha quitado el Modo UEFI.
Antes cuando booteaba me aparecía "Boot Manager: Windows" algo así, y ahora me aparece la marca de mi disco duro y cuando habilito FAST BOOT con secure boot, NO ME FUNCIONA. Vuelve a entrar a la BIOS.

Como puedo instalar UEFI otra vez? Ya ni se si estoy haciendo las preguntas correctas, nunca me pasó esto y como dije antes, lo hice en otro ordenador IGUAL A ESTE MISMO, y no me sucedió eso, metí el USB, seleccione partición y listo.

He leído que para UEFI hay que convertir particiones a GPT, tambien lo he hecho, pero luego tampoco me dejaba instalar el Windows ahí.

Espero que me puedan dar una mano, ya formatié 2 veces, probando cosas y no logro resolver el problema.

Muchas gracias!
9  Seguridad Informática / Hacking Wireless / Re: Algunas ideas para detectar más ¿Es posible? en: 27 Octubre 2016, 20:21 pm
como te han dicho, prolongadores hasta 5 mts, pero ya que compras uno, que sea de usb a mini usb y te ahorras la conexión intermedia

https://www.pccomponentes.com/cable-usb-2-0-a-mini-usb-3m-m-m?gclid=CI7nmN_G-88CFewy0wod9TMOdw

sobre la antena, la ganancia que vas a obtener es relativa y depende varios factores como te han dicho, entiendo que el alargador es para sacar el adaptador por la ventana, ya solo con eso vas a notar mejoria.

ahora, los problemas de inestabilidad navegando que da la alfa 1W, no los solucionas ni con un milagro  ;)

Ok, lo tendré en cuenta eso del mini usb a usb. El que me pasaste es de 3m, voy a ver si lo consigo de 5. Y no te equivocas, la idea es la que dices, llevarla lo más cerca posible de la otra señal, sacandola por la ventana jaja.

Con respecto a lo de la antena, mientras que me confirmen que se puede conectar perfectamente y que funciona en la AWUS036H me conformo, luego que detecte o no por las cosas que hay de por medio no me preocupa, pero si que funcione ya que si no me ayuda en mi conexión se la venderé a un amigo que quiere detectar más redes, pero tenemos esa duda si se adapta o no a la AWUS036H.

Muchas gracias a ti tambien por responder!
10  Seguridad Informática / Hacking Wireless / Re: Algunas ideas para detectar más ¿Es posible? en: 27 Octubre 2016, 18:19 pm
Hola ka0s, yo esos prolongadores los he probado con una aqprox appUSB300HP y en una Net Way NW581, que son muy similares a la que tú tienes y en las dos ha funcionado sin ningún problema, eso si, para más de 5 mts de cable yo te recomendaría que el prolongador sea activo, pero para unos 3 mts. con el que tu dices será suficiente.

Respecto a la antena de varilla, yo personalmente no la compraría, creo que la que trae la AWUS036H es suficientemente proporcionada para ese tipo de tarjeta de red inalámbrica.

Nuevamente muchas gracias por responder y aclararme esto.
Qué indeciso me has dejado, me hace dudar mucho lo del prolongador USB. Además no hay muchas opiniones de eso al respecto.

Y con respecto a lo de la varilla, lo mismo. Me sentía "confiado" que alguno me iba a decir que quizás poniendole uno de 12, iba a intensificar más la señal, pero no.

Tendré que jugarmela y ver que sucede.
Ojalá que alguien de alguna idea más de todo esto.

Nuevamente muchas gracias Hacelo por responder.

Saludos!
Páginas: [1] 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 ... 21
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines