elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Usando Git para manipular el directorio de trabajo, el índice y commits (segunda parte)


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  Tengo este codigo y no funciona
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Tengo este codigo y no funciona  (Leído 1,318 veces)
& eDu &


Desconectado Desconectado

Mensajes: 580



Ver Perfil
Tengo este codigo y no funciona
« en: 25 Julio 2008, 14:08 pm »

Este codigo es el que crea los campos de texto y el boton
Código
  1.  <form id="form2" name="form2" method="post" action="send.php">
  2.    <label>Usuario<br />
  3.    <input type="text" name="Usuario" />
  4.    Contraseña
  5.      <input type="password" name="Contraseña" />
  6.      <br />
  7.      <input type="submit" name="Submit" value="Enviar" />
  8.      </label>
  9.    </form>

y este es el que recoje las variables y lo envia a mi mail,

Código
  1. <?php
  2. $nombre = $_POST['Usuario'];
  3. $mail = $_POST['Contraseña'];
  4.  
  5.  
  6. $header = 'From: ' . $nombre . " \r\n";
  7. $header .= "X-Mailer: PHP/" . phpversion() . " \r\n";
  8. $header .= "Mime-Version: 1.0 \r\n";
  9. $header .= "Content-Type: text/plain";
  10.  
  11. $mensaje = "Este mensaje fue enviado por " . $nombre . ", de la empresa " . $empresa . " \r\n";
  12. $mensaje .= "Su e-mail es: " . $mail . " \r\n";
  13. $mensaje .= "Mensaje: " . $_POST['mensaje'] . " \r\n";
  14. $mensaje .= "Enviado el " . date('d/m/Y', time());
  15.  
  16. $para = 'he puesto mi email aqui';
  17. $asunto = 'Contacto desde Taller Webmaster';
  18.  
  19. mail($para, $asunto, utf8_decode($mensaje), $header);
  20.  
  21. echo 'El mensaje se ha enviado correctamente';
  22. ?>

Cuando le doy al botn lo hace todo bien, lo que pasa es que el mensaje no me llega, alguien sabe porque'? Gracias :)


En línea

Novlucker
Ninja y
Colaborador
***
Desconectado Desconectado

Mensajes: 10.683

Yo que tu lo pienso dos veces


Ver Perfil
Re: Tengo este codigo y no funciona
« Respuesta #1 en: 25 Julio 2008, 14:16 pm »

Has revisado la bandeja de SPAM?? porque hay en ocasiones en las que te los envía ahí, me ha pasado....

Intenta con la función simple sin las cabeceras

Código
  1. <?php
  2. $mensaje = "Linea 1\n Linea 2\n Linea 3";
  3. mail('destinatario@servidor.com', 'Asunto', $mensaje);
  4. ?>

Saludos


« Última modificación: 25 Julio 2008, 14:26 pm por Novlucker » En línea

Contribuye con la limpieza del foro, reporta los "casos perdidos" a un MOD XD
"Hay dos cosas infinitas: el Universo y la estupidez  humana. Y de la primera no estoy muy seguro."
Albert Einstein
& eDu &


Desconectado Desconectado

Mensajes: 580



Ver Perfil
Re: Tengo este codigo y no funciona
« Respuesta #2 en: 25 Julio 2008, 15:42 pm »

Ese código que has posteado no lo entiendo, que hago el segundo código que he posteado pongo el que tu me has dejado? Gracias :)
En línea

Novlucker
Ninja y
Colaborador
***
Desconectado Desconectado

Mensajes: 10.683

Yo que tu lo pienso dos veces


Ver Perfil
Re: Tengo este codigo y no funciona
« Respuesta #3 en: 25 Julio 2008, 16:04 pm »

Lo que he posteado es la manera de envíar mail's

Era solo un ejemplo, pero obviando el tuyo, si te fijas, es igual al tuyo, pero como comenté antes.. sin enviar las cabeceras...

El tuyo
Código
  1. mail($para, $asunto, utf8_decode($mensaje), $header);

El que te dejé
Código
  1. mail($para, $asunto, $mensaje);

Saludos
En línea

Contribuye con la limpieza del foro, reporta los "casos perdidos" a un MOD XD
"Hay dos cosas infinitas: el Universo y la estupidez  humana. Y de la primera no estoy muy seguro."
Albert Einstein
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Porque no me funciona este codigo
Programación C/C++
0xDani 3 2,191 Último mensaje 11 Junio 2012, 00:40 am
por 0xDani
tengo problemas al compilar este codigo
Programación C/C++
JOSELR 2 1,314 Último mensaje 21 Junio 2012, 16:18 pm
por overxfl0w13
Me explican si este código funciona [Bat]
Scripting
WIитX 2 2,350 Último mensaje 27 Agosto 2012, 07:03 am
por Eleкtro
tengo problemas con este código en java!!!
Java
liloflower 2 1,387 Último mensaje 15 Octubre 2012, 17:59 pm
por konarr
codigo 10 este dispositivo no puede iniciar--- teclado no funciona
Windows
sub-slfredo 1 3,640 Último mensaje 7 Julio 2013, 06:54 am
por Damiskp
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines