elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: [AIO elhacker.NET 2015] Compilación herramientas análisis y desinfección malware


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  incompatibilidad con php 5
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: incompatibilidad con php 5  (Leído 2,062 veces)
UNFORMAT

Desconectado Desconectado

Mensajes: 40


Vaya torito ay torito guapo tiene botines y no v..


Ver Perfil
incompatibilidad con php 5
« en: 8 Agosto 2010, 12:34 »

Hola buenas!, tengo un script que hice hace ya algún tiempo (soy bastante novato) para php 4 y funcionaba bien. Ahora he actualizado a php 5 y ha dejado de funcionar.

Código
  1. <?
  2. $numero = "11";
  3.  
  4. if ($ver >= $numero)
  5. {
  6. echo "ok";
  7. }
  8.  
  9. else
  10. {
  11. echo "no";
  12. }
  13. ?>


en php 4 al poner archivo.php?ver=10 me daba "no" y al poner 11 o mayor me daba "ok" pero ahora no se lo que ha pasado que en php 5.2.8 da problemas....

a ver si me podeis ayudar jejej, desde ya muchas gracias!


En línea

Todos somos ignorantes, lo que pasa es que no todos ignoramos las mismas cosas...
UNFORMAT

Desconectado Desconectado

Mensajes: 40


Vaya torito ay torito guapo tiene botines y no v..


Ver Perfil
Re: incompatibilidad con php 5
« Respuesta #1 en: 8 Agosto 2010, 13:36 »

buenas... he estado investigando un poco más y he llegado a la conclusión que no es problema del script. Creo que más bien va a ser de PHP o Apache, porque me he instalado la última versión de php en mi equipo y funciona correctamente.

Parece ser alguna configuración del servidor, que no admite el envío de datos a través de URL. Pero que apartado de la configuración será¿?

gracias!


En línea

Todos somos ignorantes, lo que pasa es que no todos ignoramos las mismas cosas...
UNFORMAT

Desconectado Desconectado

Mensajes: 40


Vaya torito ay torito guapo tiene botines y no v..


Ver Perfil
Re: incompatibilidad con php 5
« Respuesta #2 en: 8 Agosto 2010, 13:46 »

Bueno ya podéis cerrar el tema  ;D

El problema estaba en que no estaba activado en la configuración de PHP register_globals


Saludos!!
En línea

Todos somos ignorantes, lo que pasa es que no todos ignoramos las mismas cosas...
#!drvy
Moderador
***
Desconectado Desconectado

Mensajes: 5.523



Ver Perfil WWW
Re: incompatibilidad con php 5
« Respuesta #3 en: 8 Agosto 2010, 13:52 »

Yo no te recomiendo nada el register_globals... es una de las mayores cagadas de PHP..
Por algo lo han desactivado de PHP 5 XD


Saludos
En línea

UNFORMAT

Desconectado Desconectado

Mensajes: 40


Vaya torito ay torito guapo tiene botines y no v..


Ver Perfil
Re: incompatibilidad con php 5
« Respuesta #4 en: 8 Agosto 2010, 13:54 »

entonces que puedo utilizar??
mucho de los scripts que utilizo necesitan esto para funcionar


saludos!
En línea

Todos somos ignorantes, lo que pasa es que no todos ignoramos las mismas cosas...
#!drvy
Moderador
***
Desconectado Desconectado

Mensajes: 5.523



Ver Perfil WWW
Re: incompatibilidad con php 5
« Respuesta #5 en: 8 Agosto 2010, 14:24 »

Pues eso es un error..si tu tienes una variable con la contraseña de algo por ejemplo yo mediante la url te la puedo cambiar :P
para las variables GET(via url) utiliza $_GET['nombrevariable'] y para los POST (via header) utiliza $_POST['nombrevariable'] para las cookies utiliza $_COOKIE['nombrecookie'] etc..

aqui tienes una lista de las predefinidas. http://www.php.net/manual/en/reserved.variables.php
y aqui el porque no utilizar register_globals. http://ca.php.net/manual/en/security.globals.php



Saludos
En línea

~ Yoya ~
Wiki

Desconectado Desconectado

Mensajes: 1.125



Ver Perfil
Re: incompatibilidad con php 5
« Respuesta #6 en: 8 Agosto 2010, 17:52 »

Código
  1. <?php
  2. $numero = "11";
  3.  
  4. if ($_GET['ver'] >= $numero)
  5. {
  6. echo "ok";
  7. }
  8.  
  9. else
  10. {
  11. echo "no";
  12. }
  13.  
  14. ?>

Uso:
Código:
http://127.0.0.1/a.php?ver=Valor

Solo tienes que leer un poco sobre los cambios de php4 a php5...
En línea

Mi madre me dijo que estoy destinado a ser pobre toda la vida.
Engineering is the art of balancing the benefits and drawbacks of any approach.
UNFORMAT

Desconectado Desconectado

Mensajes: 40


Vaya torito ay torito guapo tiene botines y no v..


Ver Perfil
Re: incompatibilidad con php 5
« Respuesta #7 en: 8 Agosto 2010, 18:14 »

Hola!
he leído los dos enlaces que me has enviado y ya todo me ha quedado más claro. La verdad que no tenia idea de que era un poco "inseguro".
Ahora me pondré y actualizaré todos los scripts que tengo con esto :-D
También me ha quedado claro la diferencia que hay entre POST y GET


Muchas gracias a am@s!
En línea

Todos somos ignorantes, lo que pasa es que no todos ignoramos las mismas cosas...
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Incompatibilidad con adaptador y la BIOS
Hardware
gAb1 5 1,848 Último mensaje 20 Noviembre 2012, 20:19
por simorg
Incompatibilidad C# con Windows
Dudas Generales
Alias17899 0 222 Último mensaje 16 Diciembre 2019, 17:15
por Alias17899
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines