elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a Git (Primera Parte)


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web
| | |-+  PHP (Moderador: #!drvy)
| | | |-+  Codificación y robots
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Codificación y robots  (Leído 860 veces)
sexto

Desconectado Desconectado

Mensajes: 200


Ver Perfil
Codificación y robots
« en: 13 Abril 2015, 13:53 pm »

Hola que tal. Estoy teniendo un problema con una web.
La web se hizo hace como 10 años, y ha ido arrastrando ***** desde entonces, ahora yo he terminado de que funcione de manera más o menos decente, pero hay una cosa que no consigo.
La web tiene (y tenía) un buscador. Si yo busco una palabra con tilde, me busca en la BD correctamente y me muestra todos los resultados, incluso cuando se busca una palabra que tiene tilde pero se busca sin tilde.
Pero el problema viene por otro sitio: La web tiene una tabla de búsquedas, donde se van guardando todas las búsquedas que hace la gente y con un contador y tal. Después de corregir algunos fallos que tenía me he fijado en que muchas búsquedas se guardaban con una codificación muy rara, pero no es que sustituyera una tilde por un par de símbolos raros, sino una tilde por un montón de símbolos raros, por ejemplo:
Cursos de BÃ?Æ?Ã?â??Ã?â? ââ?¬â?¢Ã?Æ?ââ?¬Å¡Ã?â??Ã?¡sico de Productos Derivados a distancia en Asturias
Como no conseguía saber por qué pasaba, he puesto para que se guarde también la IP de la persona que busca, y resulta que en todos los casos que pasa eso, es el robot de Google o el de Bing.
¿Por qué pasa eso?
¿Hay alguna manera de evitarlo o solucionarlo?

Muchas gracias.


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Televicion-Codificacion
Electrónica
lindowOS 0 1,874 Último mensaje 20 Enero 2006, 08:40 am
por lindowOS
robots.txt o indexado
Desarrollo Web
Mr.Blue 7 2,823 Último mensaje 8 Noviembre 2010, 07:04 am
por WebMonster
Codificacion
Criptografía
nelsec 3 3,082 Último mensaje 3 Octubre 2012, 18:41 pm
por nelsec
'No a los robots asesinos'
Noticias
wolfbcn 0 746 Último mensaje 25 Abril 2013, 02:07 am
por wolfbcn
duda con archivo robots
Desarrollo Web
General Dmitry Vergadoski 0 847 Último mensaje 24 Diciembre 2015, 16:03 pm
por General Dmitry Vergadoski
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines