elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: ¿Eres nuevo? ¿Tienes dudas acerca del funcionamiento de la comunidad? Lee las Reglas Generales


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  .NET (C#, VB.NET, ASP) (Moderador: kub0x)
| | | |-+  Problema con visual studio
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con visual studio  (Leído 1,981 veces)
Xephiro

Desconectado Desconectado

Mensajes: 239



Ver Perfil WWW
Problema con visual studio
« en: 6 Marzo 2016, 23:46 pm »

Me encuentro con el siguiente problema en Visual Studio, cuando compilo una aplicación puedo ejecutarla sólo desde el modo de depuración dentro de visual studio, pero al momento de ser compilada y ejecutada fuera de este, el programa no correo y tampoco arroja algún error.

¿alguna idea de que puedo hacer?. Ya he probado reinstalando por completo Visual Studio 2 veces y el error persiste.


En línea

tincopasan


Desconectado Desconectado

Mensajes: 1.287

No es lo mismo conocer el camino que recorrerlo.


Ver Perfil
Re: Problema con visual studio
« Respuesta #1 en: 7 Marzo 2016, 00:27 am »

como primera medida debo preguntarte  ¿has hecho una aplicación con un form básico y ver si la compila correctamente o todas las aplicaciones te dan problemas?


En línea

Xephiro

Desconectado Desconectado

Mensajes: 239



Ver Perfil WWW
Re: Problema con visual studio
« Respuesta #2 en: 7 Marzo 2016, 00:30 am »

Sí, hice un hola mundo. El problema es que puedo ejecutar la aplicación desde dentro del mismo Visual Studio, pero cuando trato de ejecutar la aplicación abriendo directamente el ejecutable compilado, esta no corre.

Esto pasa con todos los proyectos que tengo creados, incluso con algunos que antiguamente sí me funcionaban.
En línea

tincopasan


Desconectado Desconectado

Mensajes: 1.287

No es lo mismo conocer el camino que recorrerlo.


Ver Perfil
Re: Problema con visual studio
« Respuesta #3 en: 7 Marzo 2016, 01:14 am »

te diría que revises de tener las rutinas de los vc como primera medida, no vaya a ser que alguna esté corrupta.
En línea

Eleкtro
Ex-Staff
*
Desconectado Desconectado

Mensajes: 9.701



Ver Perfil
Re: Problema con visual studio
« Respuesta #4 en: 7 Marzo 2016, 08:27 am »

1. ¿Una aplicación en modo Release también se compila y se inicia correctamente dentro de Visual Studio?.

2. ¿Bajo que versión de .Net Framework estás compilando las aplicaciones que no se inician fuera de Visual Studio?.

3. ¿Has probado con otra versión de .Net Framework?, ¿ocurre lo mismo?.
 
4. ¿Qué versión de Windows, y de Visual Studio usas?, ¿y qué lenguaje y tecnología de interfaz de usuario (WinForms, WPF, etc)? ( esta pregunta no es relevante, pero cualquier dato adicional podría ayudar. )

5. ¿Has probado algo tan simple como iniciar la app en modo Administrador? (click derecho sobre el executable -> Ejecutar como Adminisrador).

6. ¿Has probado a iniciar la misma aplicación desde un nuevo perfil de usuario en Windows?, ¿ocurre lo mismo?.

7. ¿Has probado a iniciar la aplicación desactivando primero el JIT-debugger de Visual Studio?:

8. ¿Has analizado los registros de fallos de aplicaciones en el Visor de Eventos de Widnows?, hazlo, y comenta si aparece algún error relacionado con el inicio de la app que no te funciona fuera de Visual Studio.

Estos serían los pasos a seguir :
  • Iniciar los servicios del visor de eventos si los tuvieses desactivados por algún motivo.
  • Abrir el visor de eventos.
  • Limpiar todos los repositorios de registros anteriores para facilitar el rastreo de fallos de tu app.
  • Iniciar tu app.
  • Localizar el registro de la excepción de tu app en el visor de eventos, y comentarnos la información de depuración del mismo.

Info:

9. ¿Has probado a desinstalar (no reinstalar) Visual Studio para poder iniciar la aplicación?. (esto podría tener una relación con la pegunta nº4, y en ese caso, ¿has probado instalando una versión actualizada de Visual Studio?)

10. Si todo lo anterior falla o da unos resultados de diagnostico inseguros, prueba a realizar una comprobación de errores sobre el sistema de archivos de Windows, con el siguiente comando en la consola:
Código:
SFC.exe /SCANNOW



Son bastantes más cosas las que puedes probar, te formulé al rededor de 10 preguntas para no hacer esto demasiado largo, tómate tu tiempo e intenta probarlo y responder a todo para volver con datos que puedan ayudar a localizar la causa del problema que tienes.

Saludos!
« Última modificación: 7 Marzo 2016, 09:01 am por Eleкtro » En línea


Lekim

Desconectado Desconectado

Mensajes: 268



Ver Perfil
Re: Problema con visual studio
« Respuesta #5 en: 7 Marzo 2016, 13:02 pm »

Puedes ser por algo tan tonto como que el antivirus te lo bloquee. Hay antivirus como Norton que tienen protección Inshight que bloquean la ejecución de aplicaciones sospechosas o poco conocidas. Lo normal es que aparezca un mensaje que advierta de la supuesta peligrosidad.

Prueba también a ejecutarlo como administrador como ya te ha comentado Elektro.

Si has metido mano al manifiesto, también un error de declaración en el mismo también podría ser la causa.



Curiosamente ayer mismo por la tarde actualicé el Framework en un PC con XP y ahora no funcionan mis aplicaciones, tengo que cambiar al compatibilidad a Windows 95 y 98 para que funcionen. Eso si, con aplicaciones compiladas con VB6 y de las cuales agregué un manifiesto para que utilice el estilo visual de Windows XP,  con soporte para cambiar la apariencia de los controles en XP, ComCtl32.dll V6.

No se si es que se me olvidó añadir esto al código original o que :P

(en Visual Basic 6)
Código
  1. Private Declare Sub InitCommonControls Lib "comctl32.dll" ()
  2.  
  3. Private Sub Form_Initialize()
  4.    InitCommonControls
  5. End Sub

 lo tengo que comprobar...

« Última modificación: 8 Marzo 2016, 11:22 am por Lekim » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con Visual Studio 2008, Visual Source Safe 2005.
.NET (C#, VB.NET, ASP)
davidesgt 0 3,961 Último mensaje 14 Octubre 2009, 17:32 pm
por davidesgt
problema con Visual Studio
Programación General
Nikoxx99 0 1,104 Último mensaje 26 Abril 2014, 19:27 pm
por Nikoxx99
problema con visual studio 2015
.NET (C#, VB.NET, ASP)
snakeboy 1 1,527 Último mensaje 9 Mayo 2016, 19:20 pm
por Eleкtro
Problema al usar el patrón MVC en Visual Studio con IIS
.NET (C#, VB.NET, ASP)
KaneOneR 6 2,460 Último mensaje 16 Febrero 2017, 06:14 am
por Novlucker
Problema en Visual Studio.
Programación C/C++
lSources 1 833 Último mensaje 11 Abril 2017, 14:51 pm
por MAFUS
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines