elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Introducción a la Factorización De Semiprimos (RSA)


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  .NET (C#, VB.NET, ASP) (Moderador: kub0x)
| | | |-+  Problema con el acceso a una base de datos tras haber transladado su ubación
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema con el acceso a una base de datos tras haber transladado su ubación  (Leído 1,630 veces)
Thumderson

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Problema con el acceso a una base de datos tras haber transladado su ubación
« en: 17 Mayo 2011, 16:33 pm »

Buenas, estoy creando una aplicación que necesita acceso a datos, la cual suplo creando una base de datos con visual studio, creo una palntilla ado.netEntity data model, hasta aquí todo correcto, el fichero de la base de datos está en la ubicación C\program files\microsoft sql server\ mssql1\mssql\data, con este fichero en esta ubicación no tengo ningún problema me permite el acceso a los datos así como la modificación o adicción de nuevas entradas a la base de datos.

El problema surge cuando desplazo ese fichero de esa ubicación a la localización del proyecto (lo coloco en el escritorio \desktop), lo reañado a la aplicación cambiando su ruta siguiendo agregar nueva conexión, Archivo de base de datos de microsoft sql server(con su provveodor correspondiente), y en unicación del archivo de base de datos selecciono el del escritorio, ya lo tengo añadido al proyecto, Elimino la pantalla antigua y creo una nueva creo una palntilla ado.netEntity data model la cual asocio con la base de datos creada que ahora se encuentra en el escritorio, tras asociarla a la base de datos, me da la opción de colocarla en mi proyecto acepto. Bien ya esta añadido el acceso de datos, aquí es donde viene el problema

puedo recuperar datos

pero no puedo ni modificarlos ni añadir nuevos, creo que se trata de un problema de permisos pero no se como solventarlos, alguien me puede echar un cable



Error en si del programa o compilación del mismo no me presenta ninguno

al acceder a los datos tras haber transladado la base de datos y haberla añadido ninguno

el problema es que al invocar al método Savechanges(); los datos  solo se quedan almacenado en el contexto de objetos del modelo relacional pero nunca quedan volcado en la base de datos

Un ejemplo del código que uso:

using (bdd_RecomasterEntities contextoDeObjs1 = new bdd_RecomasterEntities())
                {
 
                    usuarios nuevouser = usuarios.Createusuarios(tlogin.Text, tpassword.Text, tdni.Text, Convert.ToInt32(trol.Text));
                    contextoDeObjs1.AddTousuarios(nuevouser);
                    try
                    {
                        contextoDeObjs1.SaveChanges();
                        MessageBox.Show("Nuevo usuario correctamente almacenado");

                       
                    }
                    catch (Exception ex)
                    {
                        MessageBox.Show(ex.InnerException.Message);
                    }

                }

 

Tras hacer esto y cerrar el programa, mediante el explorador de servidores localizo la tabla usuarios y al  mostrar su contenido no ha quedado grabado en la misma, pero en la ejecución no me presenta ninguna excepción  o error.

 

Sin embargo  cuando no había desplazado el fichero  (cuando se encontraba  en C\program files\microsoft sql server\ mssql1\mssql\data\basedatos.mdf no presentaba problema alguno en almacenaje), pero ahora que sita en el directorio del proyecto y está agregado(creo que correctamente), me permite el acceso a los datos pero no escritura o modificación de los mismos


gracias por anticipado

salu2 Thumderson


En línea

neoncyber

Desconectado Desconectado

Mensajes: 90



Ver Perfil WWW
Re: Problema con el acceso a una base de datos tras haber transladado su ubación
« Respuesta #1 en: 18 Mayo 2011, 00:14 am »

bueno, tal vez deberias ver si no tiene el atributo readonly del archivo. Segundo, deberias ver quienes son los usuarios que tenian permisos sobre ese archivo mdf mientras estaba en la ruta por defecto de sqlserver. Para eso vas a la ruta por defecto seleccionas el archivo original le haces clic derecho y en la pestaña "Seguridad" verificas que los usuarios que esten en el archivo original sean los mismos que en los que tu archivo en el escritorio

Saludos


En línea

Código
  1. #!/usr/bin/python
  2. print "Visit:"
  3. print "http:\\donkeysharp.blogspot.com"
  4.  
Thumderson

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Re: Problema con el acceso a una base de datos tras haber transladado su ubación
« Respuesta #2 en: 18 Mayo 2011, 10:18 am »

No he probado de esa forma añadiendo dos usuarios que faltaban que eran "servicio de red" y "SQLServer2005MSSQLUSer$EQUIPO$SQLEXPRESS(EQUIPO\SQLServer2005MSSQLUSer$EQUIPO$SQLEXPRESS)"

Así como que los atributos solo lectura  del fichero.mdf no se encuentran clickeados

Luego en el proyecto la base de datos(fichero.mdf) agregada se encuentra con la propiedad copiar si es posterior.

Uff no se que más hacer...

gracias de todos modos


Esto me ocurre tanto con esa base de datos que mento como si hago un nuevo proyecto, añado una base de datos nueva(ya no empieza en la ubicación que empezaba la otra), al crearla se crea en el proyecto, credo el ADO.NET model y me ocurre lo mismo puedo recuperar pero no almacenar
« Última modificación: 22 Mayo 2011, 11:38 am por Thumderson » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
acceso a la base de datos ...????
Programación Visual Basic
satan69 8 1,729 Último mensaje 8 Octubre 2006, 10:11 am
por soplo
Facil Sobre acceso a base de datos
.NET (C#, VB.NET, ASP)
David Vans 3 2,408 Último mensaje 22 Agosto 2007, 19:12 pm
por shargon
Java: JDBC acceso a base de datos
Java
yovaninu 1 2,383 Último mensaje 20 Septiembre 2007, 22:48 pm
por alvk4r
problema placa base tras actualizar bios
Hardware
tAySeR 4 4,038 Último mensaje 31 Julio 2010, 16:41 pm
por Aprendiz-Oscuro
Archivos desaparecidos disco duro tras haber cancelado su desfragmentacion
Dudas Generales
bryan90 4 6,743 Último mensaje 8 Julio 2011, 00:06 am
por crisy074
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines