elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Guía actualizada para evitar que un ransomware ataque tu empresa


+  Foro de elhacker.net
|-+  Programación
| |-+  Programación General
| | |-+  .NET (C#, VB.NET, ASP) (Moderador: kub0x)
| | | |-+  No carga datos en ComboBox
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: No carga datos en ComboBox  (Leído 2,227 veces)
mscarlosc

Desconectado Desconectado

Mensajes: 1


Ver Perfil
No carga datos en ComboBox
« en: 31 Mayo 2016, 20:42 »

Tengo un DropDownButton y un ComboBox que no carga información, en cuanto al segundo ComboBox si lo hace y ambos tienen el mismo código. Si alguien puede indicarme cual es la razón que no funciona ?
Uso VB - FrameWork 4.50 - Visual Studio Enterprise 2015




Código
  1. Private Sub FrmPersonal_Selecciona_Load(sender As Object, e As EventArgs) Handles MyBase.Load
  2.        ToolStripComboBox1.ComboBox.DataSource = CNTTipoTraba.TTipoTraba_ListaCB.Tables("SQL_Lista")
  3.        ToolStripComboBox1.ComboBox.ValueMember = "CodTipTra"
  4.        ToolStripComboBox1.ComboBox.DisplayMember = "Descripcion"
  5.  
  6.        ToolStripComboBox2.ComboBox.DataSource = CNTTipoTraba.TTipoTraba_ListaCB.Tables("SQL_Lista")
  7.        ToolStripComboBox2.ComboBox.ValueMember = "CodTipTra"
  8.        ToolStripComboBox2.ComboBox.DisplayMember = "Descripcion"
  9.  
  10. End Sub


« Última modificación: 6 Junio 2016, 20:59 por Eleкtro » En línea

hectornunezrivas

Desconectado Desconectado

Mensajes: 28


Ver Perfil
Re: No carga datos en ComboBox
« Respuesta #1 en: 4 Julio 2016, 05:50 »

Hola buenas noches.
Bueno algun error que puedes tener al tratar de hacer esta conexion es que se esta instanciando la misma conexion, la misma tabla y los mismos datos al mismo tiempo. por lo tanto el primer combo box sin problema lo llena pero el segundo es posible que no lo llene por el problema que la conexion a base de datos esta abierta, entonces, no se puede generar la conexion.
Saludos


En línea

Eleкtro
Ex-Staff
*
Desconectado Desconectado

Mensajes: 9.709



Ver Perfil
Re: No carga datos en ComboBox
« Respuesta #2 en: 4 Julio 2016, 06:44 »

¿Has probado a hacer lo siguiente?:

Código
  1. ToolStripComboBox1.ComboBox.DataSource = CNTTipoTraba.TTipoTraba_ListaCB.Tables("SQL_Lista")
  2. ToolStripComboBox1.ComboBox.ValueMember = "CodTipTra"
  3. ToolStripComboBox1.ComboBox.DisplayMember = "Descripcion"
  4.  
  5. ToolStripComboBox2.ComboBox.DataSource = ToolStripComboBox1.ComboBox.Items

Saludos!
En línea


hectornunezrivas

Desconectado Desconectado

Mensajes: 28


Ver Perfil
Re: No carga datos en ComboBox
« Respuesta #3 en: 7 Agosto 2016, 20:41 »

Hola.
Yo lo eh hecho de la siguiente manera
Código
  1.        Dim MyCommand As OleDb.OleDbCommand
  2.        Dim MyAdapter As New OleDb.OleDbDataAdapter
  3.        Dim MyConexion As New OleDb.OleDbConnection
  4.        MyConexion.ConnectionString = "provider=microsoft.ACE.OLEDB.12.0;DATA SOURCE=" & RutaBD & " ;persist security info=false"
  5.        MyCommand = MyConexion.CreateCommand
  6.        MyCommand.CommandText = "SELECT * FROM Clientes"
  7.        MyAdapter.SelectCommand = MyCommand
  8.        Dim Dt_Cliente As New DataTable
  9.        MyAdapter.Fill(Dt_Cliente)
  10.        MicomboBox.DataSource = Dt_Cliente
  11.        MicomboBox.DisplayMember = "Nombre"
  12.        MicomboBox.ValueMember = "ID"
  13.  
Saludos. espero te sea de ayuda.
« Última modificación: 7 Agosto 2016, 20:54 por Eleкtro » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines