elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.


 


Tema destacado: Píldoras formativas en seguridad de la información


+  Foro de elhacker.net
|-+  Seguridad Informática
| |-+  Hacking Avanzado
| | |-+  Hacking Linux/Unix (Moderadores: toxeek, berz3k)
| | | |-+  SSLStrip no funciona correctamente
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: SSLStrip no funciona correctamente  (Leído 7,275 veces)
sakun-ice

Desconectado Desconectado

Mensajes: 4


Ver Perfil
SSLStrip no funciona correctamente
« en: 15 Noviembre 2013, 04:00 »

Estoy usando la última suite de Wifislax y estoy usando los scripts que vienen para crear AP falsos, y para usar SSLStrip con MITM: el AirSSL/GOYScript SSL y Yamas.

No sé que hago mal pero no funciona correctamente. Tengo 2 tarjetas de red USB funcionando.

Para AirSSL y GOYScript SSL sigo los pasos y todo bien, crea el punto (a excepción de un fallo del AirSSL que no me cambia el SSID, pero no es relevante en esto) y se abren varias ventanas, password y ettercap entre ellas. El caso es que he probado a conectarme y funciona, y da conexión a internet al cliente, pero no captura correctamente las páginas. Algunas van bien y otras no. Paso a decir los errores:

- Al acceder a cualquier página me da fallo al conectarme con el host (como si no tuviera conexión), pero al conectarme una segunda vez a esa misma página ya me deja.
- Algunas páginas con HTTPS no accede. Tuenti por ejemplo.
- Las páginas HTTPS que accede no lo hace con HTTP, parece ser que no cambiar HTTPS por HTTP y obviamente no captura las contraseñas (Facebook por ejemplo). En las páginas sin SSL si captura bien las contraseñas, pero como he dicho hay que acceder 2 veces a la página para que funcione, el primer intento de conexión no funciona.

Estoy haciendo algo mal? El SSLStrip funciona a dia de hoy o no?

Gracias!


En línea

sanson


Desconectado Desconectado

Mensajes: 466


Ver Perfil
Re: Re: SSLStrip no funciona correctamente
« Respuesta #1 en: 15 Noviembre 2013, 12:26 »

Hola

Por lo que comentas, esta todo correcto.

Lo de recargar la pagina es cierto que aveces pasa (no siempre, pero si a menudo). Y lo de las paginas con ssl https como faceboock es por que han corregido el problema y se da cuenta que estas redirigiendo el trafico a una pagina no segura y aparte de no dejarte autentificarte, te lana un aviso de que estas siendo redirigido

Eso seria lo normal en todas las https pero por desgracia no todas cumplen. 

Simplemente esas paginas son mas seguras y estos script no pueden con ellas

Saludos


En línea

Es más difícil desaprender conocimientos inútiles, que aprender cosa nuevas.

MANUAL BÁSICO DE WIFISLAX Y SUS HERRAMIENTAS DE AUDITORIA WIRELESS
sakun-ice

Desconectado Desconectado

Mensajes: 4


Ver Perfil
Re: SSLStrip no funciona correctamente
« Respuesta #2 en: 15 Noviembre 2013, 17:28 »

Me temía que fuera eso....

A dia de hoy hay algo que funcione bien para hacer este tipo de técnicas? Es que por mas que busco todo ha sido corregido: Nessus+Metasploit, MITM+SSLTrip, CookiesMonster... y parece que lo único que funcionan son exploits privados y demas bugs que tienen muy poca gente y no hace público.
En línea

sakun-ice

Desconectado Desconectado

Mensajes: 4


Ver Perfil
Re: SSLStrip no funciona correctamente
« Respuesta #3 en: 18 Noviembre 2013, 16:36 »

nadie?
En línea

shellb_c0de

Desconectado Desconectado

Mensajes: 99


el software es como el sexo, mejor cuando es libre


Ver Perfil
Re: SSLStrip no funciona correctamente
« Respuesta #4 en: 26 Noviembre 2013, 04:10 »

pues a mi en mis experimentos me ha funcionado mejor el  Toolkit social engenering (SET),  utilizando Mitm, y el dns Spoofing con el ettercap o el Cain y Abel, pero  mientras se haya iniciado una comunicacion SSL, si se encuentra establecida no funcionara el Sslstrip, tocaria buscar la forma de interrumpir esa session redirigiendo hacia un script que limpia las cookies o algo asi,  porque a nivel de capa 2 no te deja  al menos que cierre sesion, cierre el navegador y vuelva a ingresar.

Saludos
En línea

“Tu vida solo es la suma del resto de una ecuación no balanceada, connatural a la programación de Matrix. Eres el producto eventual de una anomalía, que no se ha logrado suprimir de esta armonía de precisión matemática. Aunque sigues siendo una incomodidad que evito con frecuencia, es previsible y no escapa a unas medidas de control que te han conducido inexorablemente aquí.
_ka0x_

Desconectado Desconectado

Mensajes: 3


Ver Perfil
Re: SSLStrip no funciona correctamente
« Respuesta #5 en: 25 Junio 2015, 15:24 »

Hola,  me temo que sslstrip ya no funciona porque los navegadores están utilizando el protocolo  HSTS en vez de HTTPS.

Busca sslstrip2

Saludos


 


Enviado desde mi iPhone utilizando Tapatalk
En línea

Kaxperday


Desconectado Desconectado

Mensajes: 704


The man in the Middle


Ver Perfil WWW
Re: SSLStrip no funciona correctamente
« Respuesta #6 en: 25 Junio 2015, 16:32 »

No funciona si usan HSTS, pero la mayoría de las webs no lo usan. De todas formas hay una manera de spoffearlo con sslstrip2, que usa dns2proxy.

Saludos.
En línea

Cuando el poder económico parasita al político ningún partido ni dictador podrá liberarnos de él. Se reserva el 99% ese poder.
Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Por que mi PC no funciona correctamente????
Hardware
eriko 1 1,270 Último mensaje 9 Julio 2007, 18:03
por Snipersnake
Teclado no funciona correctamente
Windows
jhon antoni 4 2,393 Último mensaje 25 Agosto 2009, 18:01
por Madestro
SSLstrip 0.9 no funciona...
Hacking Linux/Unix
alpha015 8 5,694 Último mensaje 4 Febrero 2013, 17:56
por Bl4ckP0i7
no me funciona sslstrip
Redes
daryo 0 617 Último mensaje 25 Agosto 2013, 19:48
por daryo
aun funciona SSLStrip
Dudas Generales
RedZer 5 1,914 Último mensaje 30 Octubre 2014, 22:29
por RedZer
Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines