elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Guía rápida para descarga de herramientas gratuitas de seguridad y desinfección


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  ventilador del portatil a tope siempre (en linux)
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: ventilador del portatil a tope siempre (en linux)  (Leído 12,098 veces)
jorgebr

Desconectado Desconectado

Mensajes: 52



Ver Perfil
ventilador del portatil a tope siempre (en linux)
« en: 31 Enero 2010, 19:33 pm »

Buenas;

Desde hace ya mucho tiempo me pasa lo siguiente:
    - Al iniciar Ubuntu o cualquier otra distro (backtrack, wifislax...) el ventilador está siempre encendido y a maximas revoluciones, y el aire sale frio, es decir, no hay nada que esté saturando la cpu.

    La solución hasta el momento: Al iniciar ubuntu, suspendo el portatil, y lo vuelvo a iniciar, y ya funciona bien. También otra solución a esto es tras cargar la cpu unos minutos a tope y calentarla, lo dejo que se enfrie y a partir de ahi funciona bien.

Por supuesto, esto en windows no me pasa, tiene que ser problema de los drivers o más bien de configuración, puesto que de alguna manera llega a funcionar bien.

Mi portatil es un fujitsu-siemens amilo m7440, pentium M760 @ 2,00Ghz y la placa madre una fujitsu-siemens amilo M series...

Aver si alguien sabe algo, o algun link,  :)Gracias!


En línea

Knowledge is power !!!
LastDragon


Desconectado Desconectado

Mensajes: 847


Usuario Baneado (troll)


Ver Perfil WWW
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #1 en: 1 Febrero 2010, 00:09 am »

activa el modulo de fanspeed y el de ciclos del cpu, que realmente no recuerdo como se llaman exactamente, pero google te puede decir


En línea

jorgebr

Desconectado Desconectado

Mensajes: 52



Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #2 en: 1 Febrero 2010, 00:43 am »

activa el modulo de fanspeed y el de ciclos del cpu, que realmente no recuerdo como se llaman exactamente, pero google te puede decir

Muchas gracias! lo acabo de probar, pero antes tengo que configurar lm-sensors con pwdconfig y un script.... y por desgracia no me detecta nada el lm-sensors (en ubuntu 9.04 si funcionaba), así que me instalaré una version mas nueva, ahora tengo la 8.10, por lo visto así debe de funcionar bien, cargando el programa al inicio.
En línea

Knowledge is power !!!
Festor
Ex-Staff
*
Desconectado Desconectado

Mensajes: 1.955


Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #3 en: 1 Febrero 2010, 15:01 pm »

(en ubuntu 9.04 si funcionaba), así que me instalaré una version mas nueva, ahora tengo la 8.10, por lo visto así debe de funcionar bien, cargando el programa al inicio.

Ubuntu 8.10 < Ubuntu 9.04

Supongo que querías decir Ubuntu 9.10, no?
« Última modificación: 1 Febrero 2010, 17:18 pm por Festor » En línea

jorgebr

Desconectado Desconectado

Mensajes: 52



Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #4 en: 1 Febrero 2010, 15:40 pm »

No, me refiero a la 9.04 (Ubuntu 9.04 Jaunty Jackalope). Está entre la 8.10 y la 9.10.
En línea

Knowledge is power !!!
^Tifa^


Desconectado Desconectado

Mensajes: 2.804


Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #5 en: 1 Febrero 2010, 16:10 pm »

Si lm-sensors no te detecta nada... haz verificado si el modulo I2C en tu kernel esta cargado??? o compilado??? sin esto, me parece que lm-sensors no funciona del todo.

Creo que a los modulos que te refieres Last_Dragon son cpufreq en el kernel.
En línea

Songoku
Supersayan y
CoAdmin
***
Desconectado Desconectado

Mensajes: 15.371


Supersayan


Ver Perfil WWW
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #6 en: 1 Febrero 2010, 19:32 pm »

El lm-sensors por desgracia ESTA MUY ANTICUADO. Para hardware mas o menos antiguo va bien pero para el nuevo deja mucho que desear. A mi por ejemplo en el pc viejo me detecta TODO pero en cambio en el nuevo solo detecta la tarjeta grafica y el HD y pasa de los ventiladores asi como del cpu y demas.
Saludos...

Songoku
En línea

jorgebr

Desconectado Desconectado

Mensajes: 52



Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #7 en: 1 Febrero 2010, 19:54 pm »

Gracias ^TiFa^

Ya teniendo esas referencias me puedo defender. Ahora ando liado con los examenes pero lo probaré en cuanto pueda.
He encontrado este pdf www.bulma.net/pdf.phtml?nIdNoticia=964 donde explica como instalar lm-sensors y el driver del bus i2c que comentas.
Una vez que funcione bien el lm-sensors, sería mira el cpufreq y el fanspeed...
De todas formas es posible que me instale una distro nueva de ubuntu, y quizás el lm-sensors me funcione, ya sería solo el cpufreq y el fanspeed...

Muchas gracias a todos  ;D
En línea

Knowledge is power !!!
jorgebr

Desconectado Desconectado

Mensajes: 52



Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #8 en: 1 Febrero 2010, 19:56 pm »

El lm-sensors por desgracia ESTA MUY ANTICUADO. Para hardware mas o menos antiguo va bien


Gracias, pero para mi caso que el portatil acaba de cumplir 4 años... debería ir bien, sino lo tendré en cuenta.  ;)
En línea

Knowledge is power !!!
^Tifa^


Desconectado Desconectado

Mensajes: 2.804


Ver Perfil
Re: ventilador del portatil a tope siempre (en linux)
« Respuesta #9 en: 1 Febrero 2010, 19:57 pm »

Bueno... no llego hasta saber el hardware mas nuevo que el modulo I2C del kernel junto a Sensors soporte. Pero al menos en PC domesticas y portatiles no tan antiguos (llamese no tan antiguos a procesadores 2.0 Ghz e inferiores) pues me ha ido bien. Creo que puede influir mucho el soporte de lm-sensors y el hardware en cuanto a la version del kernel que tengas (Si el kernel es muy antiguo o tiene compilado muy poco soporte a este tipo de cosas, es logico que no vaya muy bien lm-sensors en algun hardware) y si tiene o no soporte este para I2C.

Checa en un servidor con Centos que hay aca con un kernel medio antiguo :

Citar



[root@localhost ~]# sensors
max1617-i2c-0-18
Adapter: SMBus I801 adapter at 1100

Board:       +29°C  (low  =   -55°C, high =  +127°C)
CPU:         +32°C  (low  =   -55°C, high =   +78°C)

w83627hf-i2c-0-2d
Adapter: SMBus I801 adapter at 1100

VCore 1:   +1.47 V  (min =  +1.42 V, max =  +1.57 V)
VCore 2:   +3.33 V  (min =  +1.42 V, max =  +1.57 V)       ALARM
+3.3V:     +3.34 V  (min =  +3.14 V, max =  +3.46 V)
+5V:       +5.00 V  (min =  +4.73 V, max =  +5.24 V)
+12V:     +12.04 V  (min = +10.82 V, max = +13.19 V)
-12V:     -12.03 V  (min = -13.18 V, max = -10.88 V)
-5V:       -2.03 V  (min =  -5.25 V, max =  -4.75 V)       ALARM
V5SB:      +5.56 V  (min =  +4.73 V, max =  +5.24 V)       ALARM
VBat:      +1.15 V  (min =  +2.40 V, max =  +3.60 V)       ALARM
fan1:     4821 RPM  (min = 1430 RPM, div = 8)
fan2:     4560 RPM  (min = 1430 RPM, div = 8)
fan3:        0 RPM  (min = 1430 RPM, div = 8)              ALARM
temp1:       +30°C  (high =   +65°C, hyst =   +60°C)   sensor = thermistor                                                                                
temp2:     +28.5°C  (high =   +75°C, hyst =   +70°C)   sensor = thermistor                                                                                
temp3:     +29.5°C  (high =   +75°C, hyst =   +70°C)   sensor = thermistor                                                                                
vid:      +1.500 V  (VRM Version 9.0)
alarms:
beep_enable:
          Sound alarm enabled

w83627hf-isa-0290
Adapter: ISA adapter
VCore 1:   +1.47 V  (min =  +1.42 V, max =  +1.57 V)
VCore 2:   +3.36 V  (min =  +1.42 V, max =  +1.57 V)       ALARM
+3.3V:     +3.34 V  (min =  +3.14 V, max =  +3.46 V)
+5V:       +5.00 V  (min =  +4.73 V, max =  +5.24 V)
+12V:     +12.04 V  (min = +10.82 V, max = +13.19 V)
-12V:     -11.95 V  (min = -13.18 V, max = -10.88 V)
-5V:       -1.98 V  (min =  -5.25 V, max =  -4.75 V)       ALARM
V5SB:      +5.48 V  (min =  +4.73 V, max =  +5.24 V)       ALARM
VBat:      +1.15 V  (min =  +2.40 V, max =  +3.60 V)       ALARM
fan1:     4687 RPM  (min = 1430 RPM, div = 8)
fan2:     4560 RPM  (min = 1430 RPM, div = 8)
fan3:        0 RPM  (min = 1430 RPM, div = 8)              ALARM
temp1:       +31°C  (high =   +65°C, hyst =   +60°C)   sensor = thermistor                                                                                
temp2:     +28.5°C  (high =   +75°C, hyst =   +70°C)   sensor = thermistor                                                                                
temp3:     +30.0°C  (high =   +75°C, hyst =   +70°C)   sensor = thermistor                                                                                
vid:      +1.500 V  (VRM Version 9.0)
alarms:
beep_enable:
          Sound alarm enabled





Que conste estoy consciente que hay ventiladores apagados y sobrecalentamiento de algunos Cores...pero, a pesar que he avisado del hecho aca, la empresa hace caso omiso al tema, por ende lo he dejado asi
« Última modificación: 1 Febrero 2010, 19:59 pm por ^TiFa^ » En línea

Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[SOLUCIONADO] Ventilador siempre funcionando, bateria de corta duracion...
GNU/Linux
mordiskos 3 8,858 Último mensaje 6 Diciembre 2011, 01:36 am
por mordiskos
ventilador a tope « 1 2 »
Hardware
fileas 18 8,208 Último mensaje 13 Junio 2013, 12:13 pm
por Randomize
Los 5 smartphones tope de gama con mayor autonomía
Noticias
wolfbcn 0 704 Último mensaje 2 Noviembre 2014, 21:34 pm
por wolfbcn
Portátil, cambio del ventilador
Hardware
yoka 3 1,839 Último mensaje 4 Febrero 2015, 13:54 pm
por yoka
¿Hay peligro si dejo mi portátil siempre conectado?
Noticias
wolfbcn 0 804 Último mensaje 18 Septiembre 2016, 18:55 pm
por wolfbcn
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines