elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Security Series.XSS. [Cross Site Scripting]


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Ubuntu 13.04 no crea el Grub
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Ubuntu 13.04 no crea el Grub  (Leído 2,134 veces)
bl4ckc0nd0r

Desconectado Desconectado

Mensajes: 9


Ver Perfil
Ubuntu 13.04 no crea el Grub
« en: 28 Septiembre 2013, 14:49 pm »


Antes de nada hola a todos... hacia tiempo que no posteaba (he tenido problemas hasta para recordar la contraseña de mi cuenta en el foro  :P), pero me ha surgido un porblema.

El problema es el siguiente:

Tengo un disco duro particionado en 3 unidades:
 C:(win7) 443gb
 D:(documentos varios)464gb
 M:(reservado para el sistema) 99.9mb

Y por ultimo tengo otra unidad virtual de unos 25gb donde tenia instalado backtrack.
Con el tiempo y algunos problemas que he tenido con el he decidido instalar ubuntu 13.04 en esos 25gb que me sobran.

Use herramientas administrativas<administracion de equipos<almacenamientos, para eliminar toda la particion con backtrack dentro (no se si es correcto hacerlo asi, pero la ultima vez funciono) y dejo esos 25gb libres. Metí el pendrive con ubuntu, cargó y todo bien... empiezó la guia de instalación y cuando me preguntan donde instalarlo le di al espacio vacio y cree una nueva particion con el formato que me viene predefinido y en la otra opcion escojo "/" (directorio raiz o algo asi)... todo instala correcto y reinicio, pero cuando lo hago, me salta a windows 7 directamente.... es un poco raro... al parecer ubuntu no me instala el grub... (o eso creo) he intentado arreglarlo buscando por internet algun tutorial para reparar el grub o volverlo a copiar, pero siempre me sale algun error (ya que estoy en el liveCD...)

Conclusion: No puedo entrar en ubuntu, que se supone, ya esta instalado y me envia directamente a windows. Y antes con Backtack consegui configurar el grub correctamente y me preguntaba siempre con que iniciar...

He intentado recuperar el grub con Boot Repair, pero sigue sin funcionar...

¿Alguien puede decirme que le pasa y como arreglarlo?

Muchas gracias de antemano ;)
Modificar mensaje


En línea

Songoku
Supersayan y
CoAdmin
***
Desconectado Desconectado

Mensajes: 15.516


Supersayan


Ver Perfil WWW
Re: Ubuntu 13.04 no crea el Grub
« Respuesta #1 en: 28 Septiembre 2013, 20:41 pm »

Lo que pasa es que por algun motivo el ubuntu no te a instalado el grub en el sector de arranque si no en su propia particion donde esta instalado el ubuntu. Usa el programa llamado easybcd desde el win7 para crear una entrada en el gestor de arranque del win7 para el ubuntu. El programa tiene la opcion de buscar automaticamente donde esta instalado el ubuntu asi que practicamente te lo hará todo el solo.
Saludos...

Songoku


En línea

topomanuel


Desconectado Desconectado

Mensajes: 945


Isla de Margarita / Venezuela


Ver Perfil
Re: Ubuntu 13.04 no crea el Grub
« Respuesta #2 en: 28 Septiembre 2013, 21:03 pm »

Eso pasa por instalar el Ubuntu en una partición pre-hecha, pues lo normal para instalar el Ubuntu junto a Windows, es no hacer ninguna partición por anticipado sino empezar la instalación y luego cuando el programa pregunte, asignarle uno la cantidad de Gigas que necesita para el Ubuntu y así el instalador creara las particiones necesarias para el funcionamiento de Ubuntu y dejara el Grub instalado donde debe ser... o sea... creara el Grub en el inicio del disco duro.

Pero intenta lo que te dijo Songoku, que es una buena opción para cuando suceden estas cosas...

Saludos.
En línea

bl4ckc0nd0r

Desconectado Desconectado

Mensajes: 9


Ver Perfil
Re: Ubuntu 13.04 no crea el Grub
« Respuesta #3 en: 28 Septiembre 2013, 22:36 pm »

Hum... pude ser lo que dices, pero cuando lo uso solo me detecta el windows 7 y no el ubuntu...  :-\
esto me desespera por momentos vv''

Edito: al parecer no tengo instalado ubuntu, porque lo he borrado y instalado 20000 veces... cuando lo vuelva a instalar y a probar con el EasiBCD os digo algo ;)
« Última modificación: 28 Septiembre 2013, 22:37 pm por bl4ckc0nd0r » En línea

bl4ckc0nd0r

Desconectado Desconectado

Mensajes: 9


Ver Perfil
Re: Ubuntu 13.04 no crea el Grub
« Respuesta #4 en: 29 Septiembre 2013, 13:52 pm »

Muchas gracias a todos, al final lo he conseguido solucionar:

1.Instalaba ubuntu

2.Me volvía a conectar con el livecd e instalaba http://blog.desdelinux.net/como-recuperar-grub-facilmente/ este programita (me dio algún problema pero lo puede solucionar)

3.Creaba un grub nuevo, y no se porque aveces lo hacia y otras no (lo sabia porque cuando si me salían textos explicando lo que tenia que ir haciendo en la terminal)

4.Y ya lo tenia grub correcto.

Problema: El grub se configuraba para iniciar con ubuntu (y yo no quería) a demás al instalar easybcd se me creo otro arranque en windows a demás del que ya tenia (en el disco M:)... por lo tanto me volvía a dar elegir entre windows y ubuntu (que este ultimo no me funcionaba)...

1.fui a ubuntu y me instale un editor de grub (como el StartUp Manager, pero no estaba para la 13.04 me tuve que instalar otro que no me acuerdo de donde lo saque).

2.Edite el grub y puse como opción primaria windows... pero resulta que ahora tenia dos opciones para arrancar windows... seleccione una y me dirigí a windows para eliminar la otra (que estaba en el disco local C:)

3.Borre todos los documentos que se habian creeado ese mismo dia y que antes no estabaan (los guarde en un .rar por si las moscas) y desinstale easyBCD.

Ahora todo iba perfecto... si no fuera porque el "Iniciando" de windows que siempre me había salido había cambiado de idioma... y me preocupe un poco... Entre en las carpetas ocultas de la unidad M: y me di cuenta de que el boot tenia carpetas de idiomas... me acorde de una de las opciones de EasyBCD que te daba a elegir un idioma del SO que querías...

1. Volví a instalar EasyBCD cambie el idioma y lo volví a borrar....

Y por ahora todo va como la seda... muchas gracias por la ayuda ya que me servisteis de guía a la hora de saber lo que me pasaba

Un saludo


p.d: dejo toda el periplo este por si alguien le pasara lo mismo ;)
En línea

Songoku
Supersayan y
CoAdmin
***
Desconectado Desconectado

Mensajes: 15.516


Supersayan


Ver Perfil WWW
Re: Ubuntu 13.04 no crea el Grub
« Respuesta #5 en: 29 Septiembre 2013, 19:12 pm »

Juassss! menuda forma mas tonta de complicarte la vida. En fin bien esta lo que bien acaba.

A y comentar que el echo de que la particion ya este echa a la hora de instalar el ubuntu no es la causa de ningun problema, yo lo hago asi siempre y jamas tuve el menor problema con el grub que por supuesto le pongo en la particion que a mi me apetece y que si no lo hago se instala en el sector de arranque.
Saludos...

Songoku
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
[Ubuntu] Personalizar grub 2 en Ubuntu 10.04
GNU/Linux
La Muertع Blancα 0 6,923 Último mensaje 19 Junio 2010, 23:02 pm
por La Muertع Blancα
Grub de Ubuntu desconfigura Mac OS X 10.6.3
GNU/Linux
wakas 2 4,651 Último mensaje 5 Diciembre 2010, 06:19 am
por wakas
No me aparece GRUB con Ubuntu « 1 2 »
GNU/Linux
Kurolox 10 4,979 Último mensaje 3 Octubre 2012, 11:13 am
por Kurolox
Grub DualBoot Ubuntu y W10
GNU/Linux
Eivissenc28 4 1,287 Último mensaje 2 Julio 2020, 13:29 pm
por Songoku
MOVIDO: Grub DualBoot Ubuntu y W10
Software
Songoku 0 430 Último mensaje 1 Julio 2020, 00:24 am
por Songoku
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines