elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Problema instalando WifiWay 2.0.1
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Problema instalando WifiWay 2.0.1  (Leído 6,743 veces)
mmsouto

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Problema instalando WifiWay 2.0.1
« en: 23 Diciembre 2010, 17:57 pm »

Buenas a todos, estoy tratando de instalar esta distro en mi portatil con Win7, para poder utilizar linuz de forma normal y no andar dependiendo de live-cd y demas y no soy capaz a instalarlo, otras veces con el antiguo mandrake, suse o ubuntu nunca tuve problema no se que me pasa con esta... El caso es que arranco con el live CD correspondiente y me puse a particionar e instalar wifiway y me dio error el grub, he vuelto a empezar de 0 y me pasa lo siguiente:

En la shell ejecuto:
fdisk -l .................y veo que el disco duro es /dev/sda
Como habia intentado instalarlo y me dio un error quite las particiones reinicio y sigo
cfdisk /dev/sda.................Creo un particion de 1gb Swap y le doy tipo 82 y la pongo al principio, creo una logica con el resto de espacio asignado.
Me da las rutas /dev/sda5 para la swap, /dev/sda6 para la logica
Le doy a write y me dice que realizado pero da error de lectura y que tengo que reiniciar ok, reboot y lo dejo de nuevo y aqui empieza el problema.

mkswap /dev/sda5 ...............Me dice "Device or resource busy"
mkfs -t ext3 /dev/sda6.............Me dice "Mounted; will not make a filesystem here"


¿Que tengo que hacer ahora? Paso del tema y arranco el entorno grafico de la distro y vuelvo a intentar instalar todo?

Gracias


« Última modificación: 24 Diciembre 2010, 05:46 am por mmsouto » En línea

mmsouto

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Re: Problema instalando WifiWay 2.0.1
« Respuesta #1 en: 24 Diciembre 2010, 05:43 am »

A ver he vuelto a empezar de cero, cree una particion en windows 7, la formatee y la elimine y luego arranque el live cd de wifiway y en la shell escribo:

fdisk -l
       Devuelve como nombre del disco /dev/sda, y como particiones que hay /dev/sda1 que es particion de arranque HPFS/NTFS, otra particion /dev/sda2 HPFS/NTFS y otra mas /DEV/SDA3 tipo extendida

cfdisk /dev/sda
       Aparecen primero 1.05MB de espacio libre, una particion sda1 Boot de 104.86MB, la sda2 NTFS de 110GB (la de windows 7) y otro espacio libre de 10GB que usare para la swap y la principal.
       Creo una particion swap de 1GB al principio y otra de tipo Logica de 9GB
       Selecciono escribir, confirmo y me dice [k]wrote partition table, but re-read table failed. Reboot to update table. [/k] Reinicio y seguimos


Aqui empiezo a formatear:
fdisk-l
       Me devuelve que estan creadas las particiones /DEV/SDA5 para la swap y /DEV/SDA6 para la Linux
mkswap /dev/sda5
       Me devuelve [k]/dev/sda5: Device or resource busy
mkfs -t ext3 /dev/sda6
       Esta me la formatea bien y reinicio

Me voy en el a la instalacion del wifiway y selecciono en español y instalarla en /dev/sda6 y pulso instalar. Se pone a copiar los ficheros y pulsamos en siguiente para configurar el GRUB; en particion pongo /dev/sda6 y en device-MBR pongo /dev/sda, pulso en "Ejecutar Grubconfig" y en la ventana escogo modo simple y standard, le indico que quiero instalar los archivos en /DEV/SDA6 y me dice The partition /dev/sda6 is mounted read-only, either unmount it or mount it read-write Como me da error de montaje en la shell ejecuto mount y veo que los /dev se montan como /mnt asi que reinicio y vuelve a hacer la instalacion pero selecciono como destino para copiar los ficheros /MNT/SDA6 en lugar del /dev/sda6 y aqui ya tarda un tiempo digamos mas normal en copiar (antes era un segundo escaso), me vuelvo a configurar el GRUB con los parametros /mnt/sda6 para la particion y /dev/sda para el MBRy pulso en Ejecutar Grubconfig
selecciono que se instale en /dev/sda6 y en la MBR

Y aqui llega  el problema que me da y no se me instala el GRUB:
Filesystem type is ext2fs, partition type 0x83
grub > setup (hd0)
Checking if "/boot/grub/stage1" exists...no
Checking if "/grub/stage1" exits...no
Error 2: Bad file or directory type
grub>quit



¿Alguna idea de que me pasa o que tengo que hacer?


En línea

Magius

Desconectado Desconectado

Mensajes: 140


Solo se que no se nada


Ver Perfil
Re: Problema instalando WifiWay 2.0.1
« Respuesta #2 en: 24 Diciembre 2010, 13:32 pm »

A ver he vuelto a empezar de cero, cree una particion en windows 7, la formatee y la elimine y luego arranque el live cd de wifiway

Hola! no entiendo porque primero la creas, la formateas y luego la eliminas... creo que tus problemas empiezan por ahi; coje una herramienta de terceros, que hay muchas, crea la particion y formateala en ext y empieza despues la instalación... de todas formas, la mayoria de las distribuciones te permiten gestionar el disco duro en su instalación.

Si tienes windows instalado sera desde el boot ini por donde gestiones el s.o a arrancar.

Suerte y ya nos diras.  :o
En línea

mmsouto

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Re: Problema instalando WifiWay 2.0.1
« Respuesta #3 en: 24 Diciembre 2010, 22:14 pm »

Buenas, hice eso porque como me habia dado el error de mano pues fue la forma mas rapida que se me ocurrio para borrar los datos posibles de esa parte del disco  :xD

Ahora estoy en casa por navidad :P Mañana al llegar donde tengo el portatil probare ¿Algun soft recomendado? ¿Uso el Partition magic de toda la vida?
En línea

Magius

Desconectado Desconectado

Mensajes: 140


Solo se que no se nada


Ver Perfil
Re: Problema instalando WifiWay 2.0.1
« Respuesta #4 en: 26 Diciembre 2010, 13:17 pm »

El partition magic esta bien, sencillo y fiable  :rolleyes:
En línea

mmsouto

Desconectado Desconectado

Mensajes: 10


Ver Perfil
Re: Problema instalando WifiWay 2.0.1
« Respuesta #5 en: 26 Diciembre 2010, 14:48 pm »

El partition magic no soporta windows 7 :S, estoy creando un usblive de ubuntu para iniciar con el y gestionar las particiones desde el mismo, ya contare como va.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Error instalando wifiway 1.0 final
Wireless en Linux
Migue_lito 4 4,606 Último mensaje 11 Junio 2010, 17:31 pm
por tarkker
Problema instalando
GNU/Linux
aquisgran 2 2,887 Último mensaje 4 Mayo 2010, 10:10 am
por aquisgran
Instalando wifiway
Wireless en Linux
Fastolfe 3 3,397 Último mensaje 30 Abril 2011, 02:25 am
por pianista
Problema instalando WifiWay
Wireless en Linux
wifX 0 2,114 Último mensaje 25 Septiembre 2011, 13:49 pm
por wifX
problema instalando xp en portatil
Windows
DaVinci4 2 4,098 Último mensaje 8 Junio 2022, 13:38 pm
por Serapis
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines