elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  No puedo instalar un canon pixma ip1600 en linux mint [solucionado]
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: No puedo instalar un canon pixma ip1600 en linux mint [solucionado]  (Leído 4,702 veces)
dato000


Desconectado Desconectado

Mensajes: 3.033



Ver Perfil
No puedo instalar un canon pixma ip1600 en linux mint [solucionado]
« en: 27 Enero 2012, 16:16 pm »

Por favor ayuda, ya probe de todo y no puedo instalar esta impresora

por favor ayudenme  :rolleyes: :rolleyes: :rolleyes: :rolleyes: :o :( :( :( :rolleyes: :rolleyes: :-\ :-\

estoy usando linux Mint-Debian, asi que me sirve todo el material de ubuntu y debian, pero no he podido instalar la impresora por más que intento.


« Última modificación: 4 Mayo 2012, 05:40 am por dato000 » En línea


dato000


Desconectado Desconectado

Mensajes: 3.033



Ver Perfil
Re: No puedo instalar un canon pixma ip1600 en linux mint
« Respuesta #1 en: 3 Mayo 2012, 20:40 pm »

Hace mucho deje este mensaje y nadie respondio, desafortunadamente, encontre la respuesta buscando por ahi y jodiendome la vida durante muchos horas, días y semanas. Dejo un metodo que me funciono por si llega alguien que quiera probar un driver de Canon Pixma iP1600 en un linux.


---------------------------------------------------------------------------------------------------------------------------------------
Como instalar una Canon PIXMA iP1600?

1. Abrir una terminal (puede abrirse con CTRL + ALT + T)

2. Conectar la impresora al computadora pero NO LO ENCIENDAS!!!

3. En la terminal digita los siguientes comandos:

Citar
sudo apt-get install libpng3 alien libxml2


4. Ahora descarga el controlador/driver para tu impresora y la instalas con los comandos:

Citar
cd ~/
wget http://files.canon-europe.com/files/soft24301/software/24301.tgz
tar -xvf 24301.tgz
mkdir iP2200_Linux_260
mv iP2200_Linux_260.tar.gz iP2200_Linux_260
cd iP2200_Linux_260
tar -xzf iP2200_Linux_260.tar.gz
sudo alien --to-deb --scripts *i386.rpm
sudo dpkg -i *.deb


5. Y luego:

Citar
cd /usr/lib
sudo ln -s /usr/lib/i386-linux-gnu/libpng.so.3 libpng.so.3
sudo ln -s /usr/lib/i386-linux-gnu/libtiff.so.4 libtiff.so.3
sudo ln -s libxml2.so.2 libxml.so.1
sudo ldconfig


6. Ahora hay que editar el archivo del driver, /usr/share/cups/model/canonip2200.ppd
Asi que escribimos en la terminal:

Citar
sudo gedit /usr/share/cups/model/canonip2200.ppd


7. Y agregamos estas lineas al final del archivo

Citar
*OpenUI *CNQuality/Quality: PickOne
*DefaultCNQuality: 3
*CNQuality 2/High: "2"
*CNQuality 3/Normal: "3"
*CNQuality 4/Standard: "4"
*CNQuality 5/Economy: "5"
*CloseUI: *CNQuality


8. Ahora en el mismo archivo (/usr/share/cups/model/canonip2200.ppd) con un editor de texto, ubicamos las siguientes lineas:

Citar
*OpenUI *Resolution/Output Resolution: PickOne
*DefaultResolution: 600
*Resolution 600/600 dpi: "<>setpagedevice"
*CloseUI: *Resolution


9. Y cambiamos todo eso con las siguientes lineas:

Citar
*OpenUI *Resolution/Output Resolution: PickOne
*DefaultResolution: 600
*Resolution 600/600 dpi: "<</HWResolution[600 600]>>setpagedevice"
*Resolution 1200/1200 dpi: "<</HWResolution[1200 1200]>>setpagedevice"
*Resolution 2400/2400 dpi: "<</HWResolution[2400 2400]>>setpagedevice"
*Resolution 4800/4800 dpi: "<</HWResolution[4800 4800]>>setpagedevice"
*CloseUI: *Resolution


10. Ahora solo falta reiniciar el demonio cups con el siguiente comando en la terminal:

Citar
sudo service cups restart

11. Y por ultimo, encender la impresora.

En la instalación de la impresora, cuando vayamos a agregar la impresora, el sistema buscara automaticamente el driver. Solo hace falta seleccionar “Canon” como el fabricante de la marca, y seleccionar “iP2200 Ver.2.60” para el modelo del printer, también podemos seleccionar el archivo que editamos del driver ubicado en “/usr/share/cups/model/canonip2200.ppd”. Con eso ya tenemos exitosamente (o eso espero, porque me mate mucho buscando y después de horas de fracaso finalmente este metodo SI funciono).
---------------------------------------------------------------------------------------------------------------------------------------

Ya les dije, a mi me funciono, les dejo la fuente: How to install Canon PIXMA iP1600?



« Última modificación: 3 Mayo 2012, 21:25 pm por dato000 » En línea


portaro


Desconectado Desconectado

Mensajes: 1.065



Ver Perfil WWW
Re: No puedo instalar un canon pixma ip1600 en linux mint
« Respuesta #2 en: 3 Mayo 2012, 23:45 pm »

A ver si esto te sirve?

-> http://www.turboprint.info/printers_Canon.html

y aqui a ver si te da unas ideas->
http://forums.linuxmint.com/viewtopic.php?f=51&t=85626
En línea


dato000


Desconectado Desconectado

Mensajes: 3.033



Ver Perfil
Re: No puedo instalar un canon pixma ip1600 en linux mint
« Respuesta #3 en: 4 Mayo 2012, 05:40 am »


mmmm ya esta solucionado, además turboprint es de cobro...y naaaaa

voy a marcarlo como solucionado
En línea


Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Canon Pixma MP150 (Ayuda)
Materiales y equipos
heaviloto 0 1,238 Último mensaje 2 Agosto 2008, 14:05 pm
por heaviloto
Linux Mint 9
Noticias
wolfbcn 0 1,013 Último mensaje 19 Mayo 2010, 13:30 pm
por wolfbcn
Linux Mint 9 KDE
Noticias
wolfbcn 0 1,267 Último mensaje 28 Julio 2010, 13:18 pm
por wolfbcn
Duda sobre particiones antes de instalar Linux Mint Solucionado « 1 2 »
GNU/Linux
Roy-Mustang 10 15,552 Último mensaje 24 Febrero 2011, 01:01 am
por Roy-Mustang
Como instalar SopCast en Ubuntu 12.04 y Linux Mint 12
Noticias
wolfbcn 0 1,575 Último mensaje 12 Abril 2012, 14:07 pm
por wolfbcn
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines