elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Security Series.XSS. [Cross Site Scripting]


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Necesito ayuda para poder usar angry ip scanner en kali linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: Necesito ayuda para poder usar angry ip scanner en kali linux  (Leído 2,538 veces)
odiseo00

Desconectado Desconectado

Mensajes: 8


Ver Perfil
Necesito ayuda para poder usar angry ip scanner en kali linux
« en: 2 Noviembre 2021, 17:53 pm »

Les comento que ya tengo dias intentando poder utilizar angry ip scanner, pero no abre.
Al instalarlo me decia esto:
dpkg: problemas de dependencias impiden la configuracion de ipscan:
 ip scan depende de opndjdk-9-jre / oracle-java9-installer; sin embargo:
  El paquete 'openjdk-9-jre' no esta instalado.

Por otra parte tambien me pedia tener el libswt-gtk-4-java, pero de igual manera al querer instalarlo no me deja, me sale la siguiente leyenda:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
El paquete libswt-gtk-4-java no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «libswt-gtk-4-java» no tiene un candidato para la instalación

Me podrian apoyar con lo que tengo que hacer, soy nuevo en esto, cabe aclarar el sistema es de 32 bits.


En línea

el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 20.773


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #1 en: 2 Noviembre 2021, 18:34 pm »

¿Qué versión exacta de Kali Linux estás utilizando? ¿32 bits pero qué versión?

https://angryip.org/download/#linux


« Última modificación: 2 Noviembre 2021, 18:38 pm por el-brujo » En línea

odiseo00

Desconectado Desconectado

Mensajes: 8


Ver Perfil
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #2 en: 2 Noviembre 2021, 18:48 pm »

¿Qué versión exacta de Kali Linux estás utilizando? ¿32 bits pero qué versión?

https://angryip.org/download/#linux

Bare Metal KAli LInux 2021.3
En línea

el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 20.773


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #3 en: 2 Noviembre 2021, 22:54 pm »

Código:
sudo apt update

Código:
sudo apt install openjdk-9-jre

Código:
wget https://github.com/angryip/ipscan/releases/download/3.7.6/ipscan_3.7.6_all.deb

Código:
sudo dpkg -i ipscan_3.7.6_all.deb

Si falla, pega el resultado de:

Código:
cat /etc/apt/sources.list

Gestión de paquetes en Debian
https://blog.elhacker.net/2021/03/gestion-de-paquetes-en-debian-apt-get-install-aptitude.html
« Última modificación: 2 Noviembre 2021, 23:03 pm por el-brujo » En línea

odiseo00

Desconectado Desconectado

Mensajes: 8


Ver Perfil
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #4 en: 3 Noviembre 2021, 17:10 pm »

Al ingresar sudo dpkg -i ipscan_3.7.6_all.deb - Aparece lo siguiente
[sudo] password for kaliuser:
Seleccionando el paquete ipscan previamente no seleccionado.
(Leyendo la base de datos ... 382924 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar ipscan_3.7.6_all.deb ...
Desempaquetando ipscan (3.7.6) ...
dpkg: problemas de dependencias impiden la configuración de ipscan:
 ipscan depende de libswt-gtk-4-java; sin embargo:
  El paquete `libswt-gtk-4-java' no está instalado.
 ipscan depende de libswt-cairo-gtk-4-jni; sin embargo:
  El paquete `libswt-cairo-gtk-4-jni' no está instalado.

dpkg: error al procesar el paquete ipscan (--install):
 problemas de dependencias - se deja sin configurar
Procesando disparadores para kali-menu (2021.4.1) ...
Procesando disparadores para desktop-file-utils (0.26-1) ...
Procesando disparadores para mailcap (3.70) ...
Se encontraron errores al procesar:
 ipscan

-Queda instalado el Angry IP Scanner pero no deja abrirlo.

Encontre:
libswt-gtk-4-java_4.10.0-3_amd64.deb
libswt-gtk-4-java_4.10.0-3_arm64.deb
-pero al instar uno u otro no se puede , al intentar aparece:
dpkg: error al procesar el archivo libswt-gtk-4-java_4.10.0-3_amd64.deb (--install):
 la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
Se encontraron errores al procesar:
 libswt-gtk-4-java_4.10.0-3_amd64.deb

-No procede por la arquitectura, intente buscar pero no encuentro ninguno que corresponda para el sistema.
« Última modificación: 3 Noviembre 2021, 17:33 pm por odiseo00 » En línea

el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 20.773


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #5 en: 4 Noviembre 2021, 11:15 am »

amd64 es 64 bits y si usas 32 bits no podrás instalarlo y arm es otra arquitectura que tu no usas. Tendría que usar como bien dices i386

¿Porque usas Kali 32 bits? ¿Qué procesador tienes? No sé si es hay muchos paquetes 32 bits.
En línea

odiseo00

Desconectado Desconectado

Mensajes: 8


Ver Perfil
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #6 en: 4 Noviembre 2021, 15:20 pm »

Cuento con un A8-4500M con 4 de ram, es lo que estaba viendo que cuenta con muchas limitantes esta verison ya que intente buscar libreoffice para 32 y no hay soporte para esta arquitectura. Sera con el procesador y la ram que mencione sea mas que suficiente para correr la arquitectura de 64?
En línea

MinusFour
Moderador Global
***
Conectado Conectado

Mensajes: 5.285


I'm fourth.


Ver Perfil WWW
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #7 en: 4 Noviembre 2021, 17:36 pm »

¿Intentaste instalar los paquetes que te dice apt?

Código
  1. sudo apt install libswt-gtk-4-java libswt-cairo-gtk-4-jni

Y después puedes volver a correr el comando:

Código
  1. sudo dpkg -i ipscan_3.7.6_all.deb

Yo creo que veo esos dos paquetes en el repositorio de kali con 32 bits. Así que debe ser posible...
En línea

odiseo00

Desconectado Desconectado

Mensajes: 8


Ver Perfil
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #8 en: 4 Noviembre 2021, 18:32 pm »

¿Intentaste instalar los paquetes que te dice apt?

Código
  1. sudo apt install libswt-gtk-4-java libswt-cairo-gtk-4-jni

Y después puedes volver a correr el comando:

Código
  1. sudo dpkg -i ipscan_3.7.6_all.deb

Yo creo que veo esos dos paquetes en el repositorio de kali con 32 bits. Así que debe ser posible...

Si lo habia intentado pero me aparece lo siguiente:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias... Hecho
Leyendo la información de estado... Hecho
El paquete libswt-gtk-4-java no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

El paquete libswt-cairo-gtk-4-jni no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente

E: El paquete «libswt-gtk-4-java» no tiene un candidato para la instalación
E: El paquete «libswt-cairo-gtk-4-jni» no tiene un candidato para la instalación
En línea

MinusFour
Moderador Global
***
Conectado Conectado

Mensajes: 5.285


I'm fourth.


Ver Perfil WWW
Re: Necesito ayuda para poder usar angry ip scanner en kali linux
« Respuesta #9 en: 4 Noviembre 2021, 21:20 pm »

No, me acaba de dar cuenta que los paquetes están solo para amd64. Creo que puedes compilar los paquetes con apt-get.

Código
  1. # Desde home
  2. sudo apt-get build-dep libswt-gtk-4-java #instala las dependencias para hacer la build del paquete
  3. sudo apt-get install build-essentials # compiladores y demás
  4.  
  5. apt-get source libswt-gtk-4-java # descarga el codigo fuente del paquete
  6. # cd <directorio-donde-esta-el-codigo-del-paquete>
  7. dpkg-buildpackage -us -uc #construye el paquete

Y listo deberías tener un .deb para ese paquete que puedes instalar con dpkg. No estoy muy seguro si funcione, tecnicamente las fuentes deberían estar ahí para cualquier arquitectura creo yo... pero igual y no están. Lo cual significa que tienes que compilar manualmente.
En línea

Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Necesito ayuda con airodump-ng -kali linux- POR FAVOR
GNU/Linux
S1rbyt3 4 1,985 Último mensaje 8 Junio 2015, 07:08 am
por iUDEX
¿Necesito de una USB permanentemente para arrancar Kali Linux 2.0?
GNU/Linux
0wl. 4 1,691 Último mensaje 20 Enero 2016, 15:26 pm
por Gambl3r
Necesito ayuda con KALI LINUX
GNU/Linux
tuxred17 1 1,050 Último mensaje 23 Enero 2017, 01:29 am
por Jety
necesito ayuda con kali linux
GNU/Linux
hacker lopez 1 1,238 Último mensaje 29 Enero 2018, 23:21 pm
por yukixdxd
Necesito ayuda con Kali Linux
GNU/Linux
Harpy 1 1,593 Último mensaje 4 Enero 2021, 00:42 am
por EdePC
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines