elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Security Series.XSS. [Cross Site Scripting]


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  Necesito ayuda con Kali Linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Necesito ayuda con Kali Linux  (Leído 991 veces)
Harpy

Desconectado Desconectado

Mensajes: 1


Ver Perfil
Necesito ayuda con Kali Linux
« en: 2 Enero 2021, 17:09 pm »

☆☆Buenas. Estoy hace dos horas tratando de buscar una solución para esto. Yo estoy tratando de ejecutar HiddenEye en Kali Linux, pero el primer error que surge es que cuando quiero insertar un puerto me dice lo siguiente:

...............................                                              
[ WEBSERVER PORT SELECTION ]!
-------------------------------

 
  • Select Port [1-65535]:
  • We suggest using ports between [1024-65535] but you still able to choose any ports you want.

HiddenEye >>>  1024
Traceback (most recent call last):
  File "/home/happyface/HiddenEye/HiddenEye.py", line 44, in <module>
    server_runner.start_server(port)
  File "/home/happyface/HiddenEye/Defs/ActionManager/Server/server_runner.py", line 102, in start_server
    set_php(port=port)
  File "/home/happyface/HiddenEye/Defs/ActionManager/Server/server_runner.py", line 87, in set_php
    run_command(["killall", "-2", "php"], stdout=DEVNULL, stderr=DEVNULL)
  File "/usr/lib/python3.9/subprocess.py", line 349, in call
    with Popen(*popenargs, **kwargs) as p:
  File "/usr/lib/python3.9/subprocess.py", line 947, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib/python3.9/subprocess.py", line 1819, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'killall'

☆☆Una persona me dijo que instale los requerimientos con pip para solucionarlo. Lo hice pero tampoco puedo ya que tengo pip desactualizado independientemente de python3.9 (yo estoy utilizando python3.9 para todo esto). Intenté actualizar pip pero a la hora de hacerlo me sale lo siguiente:

debconf: delaying package configuration, since apt-utils is not installed
dpkg: error: requested operation requires superuser privilege
E: Sub-process /usr/bin/dpkg returned an error code (2)
happyface@localhost:~/HiddenEye$

☆☆Según lo que entendí, me está diciendo que apt-utils no está instalado ¿Cómo hago para instalarlo y proceder? Gracias.


« Última modificación: 2 Enero 2021, 17:19 pm por Harpy » En línea

EdePC
Colaborador
***
Desconectado Desconectado

Mensajes: 1.621



Ver Perfil
Re: Necesito ayuda con Kali Linux
« Respuesta #1 en: 4 Enero 2021, 00:42 am »

A simple vista me parece que estás usando un Usuario sin privilegios, quizá si haces un:
Código
  1. sudo su

Por otro lado en esta página https://bytefreaks.net/gnulinux/bash/bash-killall-command-not-found-a-solutiondice que killall es parte de psmisc y se instala con:
Código
  1. apt-get install psmisc


En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Necesito ayuda con airodump-ng -kali linux- POR FAVOR
GNU/Linux
S1rbyt3 4 1,748 Último mensaje 8 Junio 2015, 07:08 am
por iUDEX
Necesito ayuda con KALI LINUX
GNU/Linux
tuxred17 1 893 Último mensaje 23 Enero 2017, 01:29 am
por Jety
necesito ayuda con kali linux
GNU/Linux
hacker lopez 1 1,058 Último mensaje 29 Enero 2018, 23:21 pm
por yukixdxd
necesito algunos progrmas en kali linux
GNU/Linux
AgueroMilano 9 2,510 Último mensaje 5 Junio 2018, 02:56 am
por Machacador
MOVIDO: Necesito ayuda con Kali Linux
Dudas Generales
Songoku 0 313 Último mensaje 2 Enero 2021, 18:40 pm
por Songoku
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines