elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


+  Foro de elhacker.net
|-+  Sistemas Operativos
| |-+  GNU/Linux (Moderador: MinusFour)
| | |-+  fdisk no me detecta el SSD. Linux
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] 2 Ir Abajo Respuesta Imprimir
Autor Tema: fdisk no me detecta el SSD. Linux  (Leído 2,300 veces)
Drakaris

Desconectado Desconectado

Mensajes: 286


Todo lo que puedas imaginar, lo puedes crear.


Ver Perfil
fdisk no me detecta el SSD. Linux
« en: 15 Junio 2022, 20:32 pm »

Buenos dias.
Estaba montando mi SSD en Linux y todo fue bien.
Cree un particion EXFAT y todo bien.
Código:
mkfs.exfat /dev/sdg1
y lo monte en una carpeta
Código:
mount /dev/sdg1 /owncloud

Todo fue bien. Pero la lie bastante...
La carpeta /owncloud esta montada, y sin querer cree otra carpeta en la raiz (/) "ssd2t" y moví la carpeta /owncloud (la que monte con mount) dentro de la carpeta "ssd2t", por la cual que así
/ssdt2
   |
   |----> /ssdt2/owncloud

El problema es que lo monte en /owncloud y despues este lo moví. Como resultado ahora ni se muestra en el fdisk el SSD.

Además elimine el /ssd2t/owncloud..

El problema esta en que ahora desconecto y conecto el SSD y le hago un fdisk -l y no se muestra.
Código:
Disk /dev/mmcblk0: 119.3 GiB, 128043712512 bytes, 250085376 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x3b660569

Device         Boot  Start       End   Sectors  Size Id Type
/dev/mmcblk0p1        2048    614399    612352  299M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      614400 250085375 249470976  119G 83 Linux


Disk /dev/sda: 28.9 GiB, 31029460992 bytes, 60604416 sectors
Disk model: DataTraveler 3.0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x55cf4d2f

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1        2048 60604415 60602368 28.9G  c W95 FAT32 (LBA)

El disco es de 2TB.

Que hago.... como puedo recuperarlo? Lo probe en Windows y tampoco lo detecta...Creo que me cargué el superbloque del dispositivo....

No se que hacer..... Se puede solucionar de alguna manera? Muchas gracias.


En línea

Lo increible, no es lo que ves, sino como es
el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 21.430


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: fdisk no me detecta el SSD. Linux
« Respuesta #1 en: 16 Junio 2022, 13:00 pm »

Pues TestDisk es la mejor herramienta para recuperar particiones eliminadas por error.

Tutorial TestDisk para recuperar particiones dañadas
https://blog.elhacker.net/2014/01/manual-tutorial-testdisk-para-recuperar-particiones-danadas.html

Qué suerte tener una unidad SSD de 2TB xD

TestDisk funciona bajo Windows y Linux y no menees mucho el disco, con un poco de suerte, TestDisk debería encontrar la partición perdida y recuperarla.

https://www.cgsecurity.org/wiki/TestDisk_Paso_A_Paso


En línea

MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.478


I'm fourth.


Ver Perfil WWW
Re: fdisk no me detecta el SSD. Linux
« Respuesta #2 en: 16 Junio 2022, 13:53 pm »

Pues TestDisk es la mejor herramienta para recuperar particiones eliminadas por error.

Tutorial TestDisk para recuperar particiones dañadas
https://blog.elhacker.net/2014/01/manual-tutorial-testdisk-para-recuperar-particiones-danadas.html

Qué suerte tener una unidad SSD de 2TB xD

TestDisk funciona bajo Windows y Linux y no menees mucho el disco, con un poco de suerte, TestDisk debería encontrar la partición perdida y recuperarla.

https://www.cgsecurity.org/wiki/TestDisk_Paso_A_Paso

Los superbloques son parte del formato del sistema de archivos. No es algo físico del SSD.
Revisa que tu SSD esté bien conectado y que no haya ningún cable siendo apretado.

Revisa si lo ve tu BIOS/UEFI. Si no se ve ahi, por más que pases herramientas de recuperación no lo vas a encontrar.
En línea

Drakaris

Desconectado Desconectado

Mensajes: 286


Todo lo que puedas imaginar, lo puedes crear.


Ver Perfil
Re: fdisk no me detecta el SSD. Linux
« Respuesta #3 en: 16 Junio 2022, 15:17 pm »

Los superbloques son parte del formato del sistema de archivos. No es algo físico del SSD.
Revisa que tu SSD esté bien conectado y que no haya ningún cable siendo apretado.

Revisa si lo ve tu BIOS/UEFI. Si no se ve ahi, por más que pases herramientas de recuperación no lo vas a encontrar.

He revisado en la Bios y si esta, la BIOS lo detecta, el comando testdisk no detecta el disco duro.
https://imgur.com/vVEhgMl
En línea

Lo increible, no es lo que ves, sino como es
MinusFour
Moderador Global
***
Desconectado Desconectado

Mensajes: 5.478


I'm fourth.


Ver Perfil WWW
Re: fdisk no me detecta el SSD. Linux
« Respuesta #4 en: 16 Junio 2022, 16:08 pm »

Y puedes arrancar el debian que dice ahi? Me imagino que el SSD que dices que aparece ahí es el MX500 1TB de Crucial no?
En línea

Drakaris

Desconectado Desconectado

Mensajes: 286


Todo lo que puedas imaginar, lo puedes crear.


Ver Perfil
Re: Re: fdisk no me detecta el SSD. Linux
« Respuesta #5 en: 16 Junio 2022, 20:36 pm »

Y puedes arrancar el debian que dice ahi? Me imagino que el SSD que dices que aparece ahí es el MX500 1TB de Crucial no?
No no es este. Es uno de 2TB

Sent from my VTR-L09 using Tapatalk
En línea

Lo increible, no es lo que ves, sino como es
el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 21.430


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: fdisk no me detecta el SSD. Linux
« Respuesta #6 en: 17 Junio 2022, 10:59 am »

Citar
He revisado en la Bios y si esta, la BIOS lo detecta, el comando testdisk no detecta el disco duro.

¿Y cuál es en la BIOS?

CT son las siglas de Crucial creo recordar

En la captura de pantalla sólo veo dos unidades  un Seagate (ST) y un Crucial (CT) unidad SSD

Citar

Si la BIOS/UEFI no detecta el SSD de 2TB, TestDisk tampoco lo verá, es imposible.

En línea

Drakaris

Desconectado Desconectado

Mensajes: 286


Todo lo que puedas imaginar, lo puedes crear.


Ver Perfil
Re: fdisk no me detecta el SSD. Linux
« Respuesta #7 en: 17 Junio 2022, 11:02 am »

¿Y cuál es en la BIOS?

CT son las siglas de Crucial creo recordar

En la captura de pantalla sólo veo dos unidades  un Seagate (ST) y un Crucial (CT) unidad SSD

Si la BIOS/UEFI no detecta el SSD de 2TB, TestDisk tampoco lo verá, es imposible.



Es el ChipsBnkFlash Disk 5.00

Creo que lo detecta como USB pero no como disco. Así que creo que es imposible es este caso. No?
En línea

Lo increible, no es lo que ves, sino como es
el-brujo
ehn
***
Desconectado Desconectado

Mensajes: 21.430


La libertad no se suplica, se conquista


Ver Perfil WWW
Re: fdisk no me detecta el SSD. Linux
« Respuesta #8 en: 17 Junio 2022, 11:37 am »

¿Y la unidad esta Crucial SSD de 2TB está conectada por USB? ¿Has probado otro puerto USB Azul?

Ciertamente aunque esté conectada por USB, debería salir el nombre, modelo o fabricante del SSD y según la captura no detecta nada.

Supongo que lo otro que sale  (generic sm-sd,etc),  es un lector de tarjetas

La BIOS debe reconocer el dispositivo, esté o no formateado, dañado. Si en la BIOS no aparece, pues ni Linux, ni Windows lo reconocerán como bien dijo MinusFour.
En línea

Drakaris

Desconectado Desconectado

Mensajes: 286


Todo lo que puedas imaginar, lo puedes crear.


Ver Perfil
Re: fdisk no me detecta el SSD. Linux
« Respuesta #9 en: 17 Junio 2022, 13:10 pm »

El disco duro es un xrayDisk de 2TB. Cuando hago un lsusb si se muestra
Código:
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
Bus 001 Device 003: ID 1a2c:0e24 China Resource Semico Co., Ltd USB Keyboard
Bus 001 Device 002: ID 1e3d:198a Chipsbank Microelectronics Co., Ltd Flash Disk
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

es el
Citar
Bus 001 Device 002: ID 1e3d:198a Chipsbank Microelectronics Co., Ltd Flash Disk
además si hago un tail -f -n 0 /var/log/syslog y desconecto y conecto el cable USB del disco duro XrayDisk me sale lo siguiente.
Código:
Jun 17 12:57:55 debian kernel: [ 7170.240848] usb 1-2: USB disconnect, device number 2
Jun 17 12:57:55 debian kernel: [ 7170.285889] usb 1-9: reset high-speed USB device number 4 using xhci_hcd
Jun 17 12:57:59 debian kernel: [ 7173.613864] usb 1-9: reset high-speed USB device number 4 using xhci_hcd
Jun 17 12:58:01 debian kernel: [ 7175.625543] usb 1-2: new high-speed USB device number 5 using xhci_hcd
Jun 17 12:58:01 debian kernel: [ 7175.849136] usb 1-2: New USB device found, idVendor=1e3d, idProduct=198a, bcdDevice= 1.00
Jun 17 12:58:01 debian kernel: [ 7175.849144] usb 1-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Jun 17 12:58:01 debian kernel: [ 7175.856143] usb-storage 1-2:1.0: USB Mass Storage device detected
Jun 17 12:58:01 debian kernel: [ 7175.856267] scsi host9: usb-storage 1-2:1.0
Jun 17 12:58:01 debian mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:01.3/0000:01:00.0/usb1/1-2"
Jun 17 12:58:01 debian mtp-probe: bus: 1, device: 5 was not an MTP device
Jun 17 12:58:01 debian mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:01.3/0000:01:00.0/usb1/1-2"
Jun 17 12:58:01 debian mtp-probe: bus: 1, device: 5 was not an MTP device
Jun 17 12:58:01 debian kernel: [ 7176.081795] usb 1-9: reset high-speed USB device number 4 using xhci_hcd
Jun 17 12:58:02 debian kernel: [ 7176.871443] scsi 9:0:0:0: Direct-Access     ChipsBnk Flash Disk       5.00 PQ: 0 ANSI: 2
Jun 17 12:58:02 debian kernel: [ 7176.873222] sd 9:0:0:0: Attached scsi generic sg1 type 0
Jun 17 12:58:02 debian kernel: [ 7176.909581] sd 9:0:0:0: [sdb] Attached SCSI removable disk
Jun 17 12:58:04 debian kernel: [ 7178.541772] usb 1-9: reset high-speed USB device number 4 using xhci_hcd
Como se puede ver en la salida desconecto el usb
Código:
Jun 17 12:57:55 debian kernel: [ 7170.240848] usb 1-2: USB disconnect, device number 2
y lo vuelvo a desconectar. La cosa esta en que detecta el USB, pero me arroja un error
Código:
Jun 17 12:58:01 debian mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:01.3/0000:01:00.0/usb1/1-2"
Jun 17 12:58:01 debian mtp-probe: bus: 1, device: 5 was not an MTP device
Jun 17 12:58:01 debian mtp-probe: checking bus 1, device 5: "/sys/devices/pci0000:00/0000:00:01.3/0000:01:00.0/usb1/1-2"
Jun 17 12:58:01 debian mtp-probe: bus: 1, device: 5 was not an MTP device
lo detecta pero después hace un Attached SCSI removable disk
Código:
Jun 17 12:58:02 debian kernel: [ 7176.871443] scsi 9:0:0:0: Direct-Access     ChipsBnk Flash Disk       5.00 PQ: 0 ANSI: 2
Jun 17 12:58:02 debian kernel: [ 7176.873222] sd 9:0:0:0: Attached scsi generic sg1 type 0
Jun 17 12:58:02 debian kernel: [ 7176.909581] sd 9:0:0:0: [sdb] Attached SCSI removable disk
El problema es que parece ser que lo quiere montar en sdb y no lo consigue por lo cual lo elimina. Además si hago fdisk -l no sale el sdb, por lo cual, aunque no esta montado, ni sale en el fdisk
Código:
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000DM010-2EP1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 53CDB35D-584B-4C60-BCA3-038A47886F72

Device          Start        End    Sectors   Size Type
/dev/sda1        2048     206847     204800   100M EFI System
/dev/sda2      206848     239615      32768    16M Microsoft reserved
/dev/sda3      239616 1952452659 1952213044 930.9G Microsoft basic data
/dev/sda4  1952454656 1953521663    1067008   521M Windows recovery environment


Disk /dev/sdc: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: CT1000MX500SSD1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 0B5656D5-779F-4552-9155-2A6F4CCE391A

Device          Start        End    Sectors   Size Type
/dev/sdc1        2048    1050623    1048576   512M EFI System
/dev/sdc2     1050624 1951522815 1950472192 930.1G Linux filesystem
/dev/sdc3  1951522816 1953523711    2000896   977M Linux swap

El problema esta en que no se crea el archivo de dispotivo sdb, además si hago mount /dev/sdb /mnt me da error.
Código:
mount: /mnt: no medium found on /dev/sdb.
En línea

Lo increible, no es lo que ves, sino como es
Páginas: [1] 2 Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
ayuda con FDISK
GNU/Linux
ApOkAlizE 2 2,258 Último mensaje 14 Septiembre 2011, 08:23 am
por monos1
linux no me detecta la tarjeta red cable
GNU/Linux
desna 9 15,133 Último mensaje 30 Junio 2013, 19:59 pm
por desna
Kali Linux no detecta wifi en VMware
GNU/Linux
lfcl1992 1 5,324 Último mensaje 11 Marzo 2017, 12:42 pm
por Randomize
No detecta tarjeta de red ( kali linux )
GNU/Linux
Ib@n 4 5,984 Último mensaje 17 Septiembre 2017, 15:57 pm
por BloodSharp
Kali Linux no detecta tarjeta de red, ayuda
GNU/Linux
dAnGeRHACKER 3 1,761 Último mensaje 23 Junio 2022, 08:39 am
por carlober
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines