elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Tutorial básico de Quickjs


+  Foro de elhacker.net
|-+  Foros Generales
| |-+  Dudas Generales (Moderador: engel lex)
| | |-+  Pseudolenguaje como se escribe el mod ??
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: Pseudolenguaje como se escribe el mod ??  (Leído 2,329 veces)
fcosun

Desconectado Desconectado

Mensajes: 2


Ver Perfil
Pseudolenguaje como se escribe el mod ??
« en: 24 Junio 2013, 02:45 am »

hola,

en muchos lenguajes de programacion se debe de anteponer una funcion para convertir el valor del mod en entero.

Pero en Pseudolenguaje escrito en papel como se transforma un valor decimal a entero para luego pasarlo al Mod.

Esta bien o mal que lo escribe en papel la siguiente sentencia asi:


valor = rut mod 10 ;

en ves de:

valor =  trunc(rut/10)




en Pseint se pone el trunc por ejemplo

Código
  1. Proceso Numero_Verificador.
  2. i <- 0
  3. h <- 2
  4. k <- 0
  5. suma <- 0
  6. escribir "Leer Rut"
  7. leer rut1
  8. rut <- rut1
  9. // aca se saca cuantos numeros tiene
  10. Repetir
  11. rut <- trunc(rut/10)
  12. i <- i + 1
  13. hasta que rut = 0
  14. Repetir
  15. Repetir
  16. x <- trunc(rut1/10)
  17. mod <- rut1 - (x*10)
  18. suma <- suma + (mod*h)
  19. rut1 <- x
  20. si mod <> 0 Entonces
  21. k <- k +1
  22. FinSi
  23. h <- h + 1
  24. hasta que h > 7
  25. h <- 2
  26. k <- k + 1
  27. hasta que k >= 8
  28. entera <- trunc(suma/11)
  29. mod1 <- suma -(entera * 11)
  30. verificador <- 11 - mod1
  31. si verificador > 9 entonces
  32. escribir "Su digito Verificador Es k"
  33. sino
  34. escribir "Su digito Verificador Es ", verificador
  35. FinSi
  36. FinProceso
  37.  
  38.  


« Última modificación: 24 Junio 2013, 02:48 am por fcosun » En línea

Mitgus

Desconectado Desconectado

Mensajes: 63


Programming Lover


Ver Perfil
Re: Pseudolenguaje como se escribe el mod ??
« Respuesta #1 en: 24 Junio 2013, 02:57 am »

No sé como interpreta las sentencias Pseint, y tampoco entiendo muy bien lo que quieres hacer.

Si lo que buscas es conviertir un resultado real a entero, en programación usamos los famosos 'castings', en los que se transforma un valor dado a uno deseado respetando la estructura del tipo de dato(por ejemplo, no se puede convertir un entero largo 'long' a un entero corto).

La sintaxis de un 'Cast' es:

(tipo de dato a convertir) (dato o expresion)

Por ejemplo:

Citar
int resultado = (int) (48/3.2)

En vez de mostrar 38.86956... mostrará 38.


En línea

Linux User #560388
ivancea96


Desconectado Desconectado

Mensajes: 3.414


ASMático


Ver Perfil WWW
Re: Pseudolenguaje como se escribe el mod ??
« Respuesta #2 en: 24 Junio 2013, 15:21 pm »

En pseudolenguaje, la finalidad es que se entienda sin tener que usar comandos de un lenguaje en específico. Lo importante es que la comprensión sea sencilla y que no haya ambigüedades.
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
programacion basica pseudolenguaje
Ejercicios
kiefer 9 12,110 Último mensaje 30 Junio 2007, 15:27 pm
por Hadess_inf
como se escribe en un fichero el caracter nulo
Java
SUNAMI_EOL 3 8,234 Último mensaje 14 Marzo 2008, 15:24 pm
por egyware
¿Como se escribe una variable en un archivo de texto?(python)
Scripting
desnight 1 7,815 Último mensaje 5 Abril 2008, 04:21 am
por MM_code
[DUDA] COmo un administrador escribe en una web php.
PHP
~V 5 1,781 Último mensaje 30 Julio 2010, 21:30 pm
por bizco
El Presidente de Google escribe una guía explicando cómo cambiar de un iPhone...
Noticias
wolfbcn 0 784 Último mensaje 25 Noviembre 2013, 13:09 pm
por wolfbcn
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines