elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Top 20 herramientas Hacking más populares de 2020


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web (Moderador: #!drvy)
| | |-+  problema con wampserver
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: problema con wampserver  (Leído 993 veces)
druguito

Desconectado Desconectado

Mensajes: 110


Ver Perfil
problema con wampserver
« en: 21 Marzo 2013, 23:06 pm »

hola tengo un problema ,me baje el wampserver2.2(que trae el php5.3 y el mysql5.5.)y estoy tratando de abrir una base de datos en este servidor local ,pero sin resultado !! me sale este error:

Fatal error: Call to undefined function mysql_create_db() in C:\Archivos de programa\EasyPHP-12.1\www\miamersur_2012\basear.php on line 15

no se que podra ser, tambien tprove con el EasyPHP-12.1 que trae el PHP-5.4.6,pero me da el mismo error, el script que uso para abrir la base de datos es el siguiente,porfa ,si alguien le puede dar una mirada y decirme si tiene algun error, o si es otra cosa, puede ser que los programas esten mal? gracias y saludos


<html>
<head>
<title>fotos</title>
</head>
<body>
<?php
//establece las variables para la conexión con la base de datos
$Host = "localhost";
$User = "yo";
$Password = "";
$DBName = "misdiarios";

$Link = mysql_connect ($Host, $User, $Password);

if (mysql_create_db ($DBName, $Link)) {

print ("la base de datos, $DBName, ha sido creada con exito!<br>\n");
} else {
print (" La base de datos, $DBName, no pudo ser creada!<br>\n");
}
mysql_close ($Link);
?>
</body>
</html>


En línea

basickdagger


Desconectado Desconectado

Mensajes: 646


System.out.println("this is weird as fuck");


Ver Perfil
Re: problema con wampserver
« Respuesta #1 en: 22 Marzo 2013, 01:48 am »

hola tengo un problema ,me baje el wampserver2.2(que trae el php5.3 y el mysql5.5.)y estoy tratando de abrir una base de datos en este servidor local ,pero sin resultado !! me sale este error:

Fatal error: Call to undefined function mysql_create_db() in C:\Archivos de programa\EasyPHP-12.1\www\miamersur_2012\basear.php on line 15

no se que podra ser, tambien tprove con el EasyPHP-12.1 que trae el PHP-5.4.6,pero me da el mismo error, el script que uso para abrir la base de datos es el siguiente,porfa ,si alguien le puede dar una mirada y decirme si tiene algun error, o si es otra cosa, puede ser que los programas esten mal? gracias y saludos

Código:
<html>
<head>
<title>fotos</title>
</head>
<body>
<?php
//establece las variables para la conexión con la base de datos
$Host = "localhost";
$User = "yo";
$Password = "";
$DBName = "misdiarios";

$Link = mysql_connect ($Host, $User, $Password);

if (mysql_create_db ($DBName, $Link)) {

print ("la base de datos, $DBName, ha sido creada con exito!<br>\n");
} else {
print (" La base de datos, $DBName, no pudo ser creada!<br>\n");
}
mysql_close ($Link);
?>
</body>
</html>

bueno, según lo q medio recuerdo mysql_create_db, es para crear una BD peor si la BD ya esta creada, utiliza mysql_select_db... la vdd no probe tu codigo, pero asi a ojo de buen cubero xD tal ves sea eso


En línea

#!drvy
Moderador
***
Desconectado Desconectado

Mensajes: 5.592



Ver Perfil WWW
Re: problema con wampserver
« Respuesta #2 en: 22 Marzo 2013, 02:06 am »

Un poco de ingles no viene mal  :rolleyes:

Citar
Fatal error: Call to undefined function mysql_create_db() in C:\Archivos de programa\EasyPHP-12.1\www\miamersur_2012\basear.php on line 15

Traducción:
Citar
Error fatal.: Llamada a un función inexistente mysql_create_db() en C:\Archivos de programa\EasyPHP-12.1\www\miamersur_2012\basear.php en la linea 15

No existe la funcion mysql_create_db (esta marcada como totalmente obsoleta). En todo caso seria así:
Código
  1. $sql="CREATE DATABASE ".$DBName;
  2. if (mysql_query($sql,$Link)){
  3.   echo "la base de datos, $DBName, ha sido creada con exito!<br>\n";
  4. } else {
  5.   echo " La base de datos, $DBName, no pudo ser creada!<br>\n";
  6. }

Dos consejos:
  1. Utiliza echo en vez de print. Print en si incluye uso de funciones mas complejas y ralentiza un poco el procesamiento para texto simple.
  2. Deja de utilizar mysql() y utiliza mysqli(). mysql sera eliminada en futuras versiones de PHP y esta considerada como obsoleta en actuales.

Saludos
« Última modificación: 22 Marzo 2013, 02:09 am por drvy | BSM » En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

Mensajes similares
Asunto Iniciado por Respuestas Vistas Último mensaje
Problema con wampserver
Bases de Datos
GUN$ 1 1,603 Último mensaje 20 Junio 2010, 19:15 pm
por Falso Positivo
Configurar wampserver para servidor web.
Desarrollo Web
infinity92 0 1,187 Último mensaje 4 Octubre 2012, 16:36 pm
por infinity92
como instalar wordpress con wampserver 2014
Desarrollo Web
6TUNX4T 0 839 Último mensaje 14 Junio 2014, 05:26 am
por 6TUNX4T
panel de symlink en wampserver 2014
Desarrollo Web
6TUNX4T 0 813 Último mensaje 16 Junio 2014, 01:03 am
por 6TUNX4T
[Tutorial] Arreglar el error de wampserver
Desarrollo Web
6TUNX4T 0 1,328 Último mensaje 11 Mayo 2015, 01:17 am
por 6TUNX4T
WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines