elhacker.net cabecera Bienvenido(a), Visitante. Por favor Ingresar o Registrarse
¿Perdiste tu email de activación?.

 

 


Tema destacado: Entrar al Canal Oficial Telegram de elhacker.net


+  Foro de elhacker.net
|-+  Programación
| |-+  Desarrollo Web (Moderador: #!drvy)
| | |-+  efecto animate() de jQuery se ejecuta pero no se aprecia la animacion [Resuelto]
0 Usuarios y 1 Visitante están viendo este tema.
Páginas: [1] Ir Abajo Respuesta Imprimir
Autor Tema: efecto animate() de jQuery se ejecuta pero no se aprecia la animacion [Resuelto]  (Leído 2,067 veces)
4rkn63l

Desconectado Desconectado

Mensajes: 199



Ver Perfil
efecto animate() de jQuery se ejecuta pero no se aprecia la animacion [Resuelto]
« en: 11 Marzo 2012, 08:33 am »

Hola gente.

Tengo el siguiente inconveniente, a traves del plugin raw html he incluido codigo html en una pagina WordPress, despues con jQuery uso ajax y algunas animaciones sobre ese codigo. Sin embargo hay una parte en la que uso "animate()" pero la animacion no se aprecia, he estado analizando la aplicacion con inspector de google chrome y veo que las propiedades css que con la animacion deberia de cambiar si estan cambiando. Cabe mencionar que esa misma aplicacion la probe en otro WP pero que tenia otro tema y andaba bien....me parece raro que con este tema funcione todo y solo la parte de animate este fallando.

Ahora bien, estuve probando y solo podia aplicar animate a capas que eran "propias" del tema...es decir, head, footer....etc.

Alguna idea?


« Última modificación: 12 Marzo 2012, 06:11 am por 4rkn63l » En línea

raul338


Desconectado Desconectado

Mensajes: 2.633


La sonrisa es la mejor forma de afrontar las cosas


Ver Perfil WWW
Re: efecto animate() de jQuery se ejecuta pero no se aprecia la animacion
« Respuesta #1 en: 11 Marzo 2012, 15:07 pm »

Depende del CSS que ya tengan esos objetos (como por ejemplo: position relative y display inline )


En línea

4rkn63l

Desconectado Desconectado

Mensajes: 199



Ver Perfil
Re: efecto animate() de jQuery se ejecuta pero no se aprecia la animacion [Resuelto]
« Respuesta #2 en: 12 Marzo 2012, 06:15 am »

Listo  ;D, a como lo pense, el problema lo ocasionaba el tema, pues tiene una clase CSS del mismo nombre de las que tenia la animacion, esto provocaba que se le anadieran reglas que terminaban por afectar a la animacion.

Bendita herramienta la de Google Chrome!!  ;-)
En línea

Páginas: [1] Ir Arriba Respuesta Imprimir 

Ir a:  

WAP2 - Aviso Legal - Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines